Project

General

Profile

Emulator Issues #5573

Metroid Prime 3/Tri Bloom Offset

Added by MayImilae about 7 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Affects: RM3E01 and R3ME01

I've been doing a lot of testing with Prime 3 (the Trilogy version to be specific, but that doesn't appear to matter). It has A TON of problems. The wiki has the full list. This particular one is especially problematic though, as it is ALWAYS there regardless of any settings I try, and really screws up my attempts at screenshots. Even at 1x Native! It's a bloom offset issue, as seen below.

Normal Setup
OpenGL, Scaled EFB Copy on, Per-pixel on, EFB to Ram, 3x Native, 1080p resolution, and 8x CSAA and 16x AF (not that those matter)

http://wiki.dolphin-emulator.com/images/f/f9/MP3_Bloom1.png
http://wiki.dolphin-emulator.com/images/4/4e/MP3_Bloom2.png

Scaled EFB Copy OFF
OpenGL, Scaled EFB Copy OFF, Per-pixel on, EFB to Ram, 3x Native, 1080p resolution, 16x AF (doesn't matter)

http://img651.imageshack.us/img651/8558/mp3bloomnoscale.png

1x Native
OpenGL, Scaled EFB Copy on, Per-pixel on, EFB to Ram, 1x Native, 1080p resolution, 16x AF

http://img215.imageshack.us/img215/1923/mp3bloom1xnative2.png
http://img221.imageshack.us/img221/5402/mp3bloom1xnative.png

Note that the EFB copy scale off image and the 1x native image are suffering from the "squishing" problem, as detailed on the wiki. It's hard to avoid. Just ignore it.

It gets harder and harder to see as the resolution drops, but look closely, it's always there. Now, this could be a problem with the game, and not Dolphin. That is definitely a possibility, as it's pretty hard to see at native. But if it's not the game's fault, it's a pretty serious problem with how Dolphin renders things. Unfortunately I still haven't fixed my TV tuner yet since my recent Core i5 3570K upgrade, so, it will be very difficult for me to get a shot from my wii. But even then, my TV tuner is a tad fuzzy, so it would be hard to make out either way...

The problem affects Prime 3 and all of the Trilogy games, though in Prime 1 Tri and Prime 2 Tri it's alot less noticeable, for obvious reasons.

History

#1 Updated by MayImilae about 7 years ago

Shoot, forgot the computer specs and build information. Sorry about that.

Tested on 3.0-750 x64

Windows 7 x64
Intel Core i5 3570K
nVidia Geforce GTX275

#2 Updated by MayImilae about 7 years ago

The compiled builds on the hashless thread on the forum appear to be a month or so out of date. Would that have any impact on the test?

#3 Updated by MayImilae about 7 years ago

Thanks for the link. Tested it, still present with hashless. The game ran way way better though. It's fully playable now with EFB to Ram and LLE. Sweetness. Well, still horribly broken, but it doesn't have problems with slow down.

I'm increasingly thinking it's dolphin. Ok, let me rephrase it, I HOPE it's dolphin, cause then it can be fixed. Plus, a few other games do it as well, such as skyward sword's sword power up scenes. It's interesting because skyward doesn't have bloom offset anywhere else, yet with those scenes it's severe enough and close enough to be visible even on a wii. Sadly I don't have a screenshot of it in skyward sword, so I would have to play through quite a bit of it to fetch one.

Alright, tested on my wii, using my derping tuner. The result? ...maybe.

http://img195.imageshack.us/img195/6795/60098003.jpg
http://img528.imageshack.us/img528/4552/22273033.jpg

#4 Updated by NeoBrainX about 7 years ago

  • Status changed from New to Invalid

Uhm, that's pretty much the same output as Dolphin with 1xIR, isn't it? For the other cases, issues like that are expected due to the fact that the internal resolutions don't match the native one.

Also available in: Atom PDF