Project

General

Profile

Emulator Issues #5704

Joystick won't work on newest revs of Dolphin

Added by LexLight5 about 7 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

1) Game Name and ID (as it appears in right click > properties: "GZ2P01",
"RSBE01", etc):
This is not game-related, this is GCPad related. I try to set up a new joystick for Dolphin, but when I select the joystick on the device box, it becomes white and if you select another device on that box, it stays white.

2) What is the expected output? What do you see instead?
To use my joystick on the newest revs of Dolphin. I can set the buttons after what I've said previously, but those won't work.

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin? Please specify the exact revision when the
problem began.
I've said that it's not a game, right? Anyways, the joystick stuff works fine on 3.0, but not on the lastest revs.

4) What steps will reproduce the problem?
1. Go to "GCPad"
2. Go to "Devices" and try to set up another device to use with Dolphin.
3. You will see the "white box" problem and you won't be able to select another device (or use it).

5) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar, etc)? Do not say 'latest version'
this changes multiple times a day.
On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.
Dolphin 3.0-789x64 and Dolphin 3.0-807x64
My PC:
Intel i5 2500k 3,3 GHz
Gigabyte AMD Radeon 6670 2 GB DDR3
8 GB DDR3-1600
Windows 7 Ultimate x64
Motherboard Gigabyte Z77X-D3H (Ultra Durable 4)
The model of the Joystick: Thrustmaster Dual Analog 4 (Dolphin reconogises it as 3.2).

6) Please provide any additional information below.
I've tried with Mario Kart Wii (a game which has GC joystick compatibility) on the emulator, but the joystick wasn't working!

7) Attachments. IMPORTANT! We have a limited storage quota on
GoogleCode, so please use a 3rd party host for screenshots or any other
files (http://min.us/ for example).

A image of the problem:
http://imgur.com/8TO2e

History

#1 Updated by skidau about 7 years ago

Try going to Config -> GameCube -> Port 1 = Standard Controller and restart the game.

#2 Updated by LexLightlikesMLPFiM about 7 years ago

Thanks, Skidau, it works now!
(But the graphic problem with the devices is still there).

#3 Updated by skidau about 7 years ago

  • Status changed from New to Invalid

The graphic problem is a problem with wxwidgets and not a problem caused by Dolphin.

Also available in: Atom PDF