Project

General

Profile

Emulator Issues #5751

motion plus becomes un-calibrated in Skyward Sword after swordplay

Added by geminixnet over 7 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
Category:
Controls
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

OK first let me list my system.

Dolphin Build: 3.0-862 64bit
OS: Windows 7 Ultimate 64bit
Video Card: GeForce GTX 570
Graphic Drivers: 306.23
CPU: Intel I7 2600K @ 3.4GHz
RAM: 8GB Dual Channel
Game ID: SOUE01
Bluetooth Adapter: Asus Bluetooth V2.1 USB Adapter
Bluetooth Driver provider/version: Atheros Communications/7.2.0.60
Wiimote: Nintendo RVL-CNT-01

OK so I'm playing Skyward Sword. I made an ISO of my retail disc. For the most part the game runs perfectly smooth at 30FPS; though I noticed when you take out the sword to fight after a few swings it becomes "un-calibrated" is the best way to describe it. Now a quick way to fix it is to waggle the wiimote around some more till it becomes centered. OK let's say you take out Links sword, fight an enemy and then you take out your sword again, rather than being centered and facing straight it will be off to your far right, and then if you move your hand left it goes up. If you forcefully waggle it, it seems to correct itself, or you can go into the menu and re-calibrate it. This also affects selecting inventory. Let's say your just had to use your sword to kill an enemy again, then you press the "B" button to select something, rather than the little hand icon being centered it will be to the far left and the movement of the wiimote does not accurately reflect what's on-screen. I took the game and same wiimote to my actual Wii and played it there, no problems. So that means it's not the sensors in the wiimote as I first had thought. I did tweak quite a bit in the settings of the emulator to try to see if that would help.

Here are my current settings.

Dolphin Configuration
General Tab
Basic Settings

Enable Dual Core: Checked
Enable Idle Skipping: Checked
Enable Cheats: Checked
Frame Limit: Auto
Limit FPS: Un-checked

Advanced Settings

CPU Engine: JIT Recompiler
Lock Thread To Cores: Checked
Force Console as NTSC-J: Un-checked

Audio Tab

DSP Emulator Engine: DSP HLE Emulation
DSP LLE On Thread: Checked
Dump Audio: Un-checked
Audio Backend: Dsound
Sample Rate: 48000Hz

Wii Tab

Enable Screensaver: Un-checked
Use EuRGB60 Mode (PAL 60): Checked

Graphics
General Tab

Backend: Direct3D11
Adapter: Nvidia GeForce GTX 570
Full-screen Resolution: 1920x1080
Aspect Ratio: Auto
V-Sync: Un-checked
Use Full-Screen: Un-checked
Everything else on the general tab is unchecked.

Enhancements Tab

Internal Resolution: 3x Native (1920x1584)
Anti-Aliasing: None
Scaled EFB Copy: Checked
Per-Pixel Lighting: Un-checked
Force Texture Filtering: Un-checked

Hacks Tab

Skip EFB Access From CPU: Un-checked
Ignore Format Changes: Checked
EFB Copies: Texture
Texture Cache: Fast (all the way to the right)
External Frame Buffer: Disabled
Cache Display List: Un-checked
Disable Per-Pixel Depth: Checked
OpenCL Texture Decoder: Un-checked
Disable Fog: Un-checked
Skip Dest.Alpha Pass: Un-checked
OpenMP Texture Decoder: Un-checked

Everything on the Advanced Tab is unchecked.

Sorry if I wrote a book, I just wanted to be thorough on my settings. So Yea I can't figure out a way to fix it. I have tried checking "Skip EFB Access from CPU" I have tried changing "EFB Copies" to RAM rather than Texture but that seems to slow it way down to the point that you can't really play the game.

So any thoughts would be greatly appreciated. Also is anyone else experiencing this problem? I have also uploaded a video to YouTube showing what I'm talking about.

http://www.youtube.com/watch?v=uj8xYu44z2c

Thank you

History

#1 Updated by diegojp955 over 7 years ago

You should use the forums... but...
did you test with DX9, OGL?
have you tried other games?
your wiimote works perfectly on a real wii?

#2 Updated by MayImilae over 7 years ago

I've heard that it can become out of sync even on a real wii. You need to compare Dolphin to the real Wii and see how often you have to sync up.

#3 Updated by geminixnet over 7 years ago

I'm sorry, I did look all over the forums for an answer to my problem. I also extensively searched too. All I could find was someone having a similar problem with a sword game in Wii Sports+.

I did test with DX9 and OpenGL, still same issue. I also tried software renderer, same issue. Yes the wiimote works fine with an actual Wii. That was my first thought that it was a problem with the wiimote. As far as problems with the real wii, I can play for an hour or more and not have this issue. For the sake of trouble shooting, I also exported my save file from Dolphin and played it on my actual Wii.

My background is SQL, not programming; though what could be happening is that the emulator is not processing all the information. I noticed if you sword fight really "slow" ie don't waggle the wiimote that much, it tends to do OK for longer rather if you shake it around. Could it be the emulators interpretation of the data?

#4 Updated by kostamarino over 7 years ago

Press down in the d-pad while pointing to the center of the screen in any moment in order to recalibrate it. That happens with the real game often and you don't need to enter the menu to fix it.

#5 Updated by kostamarino over 7 years ago

Oh and you need the sensor bar in order for the wiimote to be properly calibrated.

#6 Updated by geminixnet over 7 years ago

OK I have a wireless sensor bar for my PC setup, yes I calibrate with it when I start the game. I'm aware that pressing down on the d-pad re-centers the device, but it does not calibrate the wiimote. The problem is that if the sensors think the wiimote is pointing left when in reality you are pointing it forward, pressing down on the d-pad to re-center it won't do anything you will still have to move the wiimote to whatever position it thinks forward is. When you start the game it actually calibrates the wiimote, then you use the IR Bar to center it. I'm not experiencing this problem with the actual Wii system. Yes you do have problems with the real Wii with the wiimote becoming un-centered, and have to re-center it with the d-pad, but this is not that.

#7 Updated by scientificraver over 7 years ago

I can confirm that a real wiimote looses calibration very quickly, at least once every 5 minutes.

#8 Updated by MayImilae over 7 years ago

What dolphin revisions have you tried, geminix? I played through the game on 3.0-600 without difficulty.

#9 Updated by geminixnet over 7 years ago

I have tried 3.0-862 and 3.0-458

#10 Updated by slmpika over 7 years ago

I have had something similar happen to me as well, but it didn't really affect me for most of the game. It's most noticeable with small motions, like targeting the clawshot, where the cursor will drift slowly while you try to target something. I was still able to swing the sword in the direction I wanted most of the time, but I had to make sure to exaggerate the motion. It also makes the harp minigame much more difficult. I would usually restart the emulator once every few hours to reset the calibration. After getting a new bluetooth adapter, I did notice that the motion-plus movement was much more accurate (though still not perfect), so maybe it has something to do with that.

#11 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug
  • Category set to controls

#12 Updated by school.player over 7 years ago

I can confirm this bug. It seems to do this to a tiny extent on the real Wii over a 30-60min period, but 1 or 2 sword slashes is enough to throw off Dolphin.

I've just chalked it up to the crappy WM+ emulation, since this happens in Wii Sports Resort swordplay too.

#13 Updated by Billiard26 over 7 years ago

  • Status changed from New to Won't fix

The swordplay already works extremely well in Dolphin.

The emulator does not run at exactly 100% speed at all times.
We have to deal with the OS to send/receive bluetooth packets.
Packets are dropped/inserted to deal with timing differences.
Real wiimotes are never going to be 100% flawless.

#14 Updated by scientificraver over 7 years ago

Never say never, it is just a matter of time and effort put into this. And I wouldn't say it works extremely well. SS is playable but exact swordplay is nearly impossible at the moment, since it gets out of sync way too quickly.

#15 Updated by ryshu69 over 7 years ago

Happens to me as well, it really takes away from the experience.

#16 Updated by white.phoenix over 7 years ago

just aim the wiimote at the sensor bar once in awhile and it learns it's neutral position again, i haven't had much trouble.

#17 Updated by white.phoenix over 7 years ago

Actually this is pretty noticeable when chopping bamboo. it becomes so miss-aligned that horizontal sword swings become vertical swings making it VERY difficult to score anything reasonably high. (and I was swinging while aiming at the sensor bar)

#18 Updated by hardy.kevin.c over 7 years ago

I can also confirm this issue. It seems that pointing the Wiimote at my sensorbar every now and then while aiming something or while in a menu seems to fix it (I don't usually have to tell it to recenter either, unless I need the cursor).

Still not sure if this is a bug with the game, dolphin, our individual bluetooth stacks and/or adapters, or some awkward combination of all three. It's not a game-breaking bug, but if it's still possible to improve it, that would be nice.

#19 Updated by scientificraver over 7 years ago

For me pointing the Wiimote at my sensorbar does not fix it. It is only fixed by manually telling it to recenter and this works for 1-2 minutes or so, then I have to recenter again. Other games work fine.

#20 Updated by rachelbryk over 7 years ago

Having played this game on console, i think you should consider yourself lucky if you only have to recenter the cursor every 1-2 minutes.

Also available in: Atom PDF