Project

General

Profile

Emulator Issues #5761

The Legend of Zelda: Ocarina of Time - random freezing + hanging if happens while showing Ocarina notes

Added by william.ribeiro.ibiapina over 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[The following is a template to help you fill out a more informative
report]

Note:
Many games do not run yet, or have known problems. Please do not report
those games without giving any more information. That means reports like
"Game XYZ crashes" are not helpful. Instead try to include as much debug
information as possible. Also try to search the issue tracker for similar
bugs before creating a new issue.

--------------------------------------

1) Game Name and ID (as it appears in right click > properties: "GZ2P01",
"RSBE01", etc):
D43J01 - ゼルダの伝説 時のオカリナGC

2) What is the expected output? What do you see instead?
I expected the game running at least as smoothly as Wind Waker, for example - even though it's an emulator running in another emulator. However, the game freezes randomly for a couple seconds, except when a character is teaching the player a song - in this case, the game shows the immediately next note and then hangs completely (video and controls only - audio keeps playing). The only ways to get out of this is by resetting the game or loading a save state.

3) Did the game ever work correctly (i.e. not have this problem) on an
earlier version of dolphin? Please specify the exact revision when the
problem began.
Dunno which revision was the first one, but 3.0-255 has it.

4) What steps will reproduce the problem?
1. Run The Legend of Zelda: Ocarina of Time (the limited edition w/ Master Quest)
2. Play normally (the issue seems to be completely random)
3. The worst effect occurs when the issue happens while a character is teaching the player a song (with the notes to be player with the Ocarina being shown one after another).

5) What version of dolphin are you using (32bit/64bit along with the
version as it appears in the title bar, etc)? Do not say 'latest version'
this changes multiple times a day.
On what operating system, drivers, and hardware? Be sure to list OS,
graphics driver information, and video card model if you are having
graphics problems, for example.
3.0-815 x64
Windows 7 Ultimate
NVIDIA GeForce 8200M G

6) Please provide any additional information below.
I've just now wondered if that Speed Up Disc Transfer Rate option would be of any help in this case... would it?

7) Attachments. IMPORTANT! We have a limited storage quota on
GoogleCode, so please use a 3rd party host for screenshots or any other
files (http://min.us/ for example).


Related issues

Is duplicate of Emulator - Emulator Issues #6938: The Legend of Zelda: Ocarina of Time Master Quest Likes to Hang/Crash [cpuTiming]Fixed

Has duplicate Emulator - Emulator Issues #5826: Zelda - OoT - MQ constantly crashes/freezes Duplicate

History

#1 Updated by school.player over 8 years ago

Have you tested this on the Virtual Console WAD in Dolphin? That would be helpful.

#2 Updated by william.ribeiro.ibiapina over 8 years ago

Is this game (and Master Quest) available for Virtual Console in the first palce? AFAIK, they were released only in a limited edition GC disc...

#3 Updated by rdragoon over 8 years ago

Yes, oot is on VC.

#4 Updated by william.ribeiro.ibiapina over 8 years ago

Oh yeah, the original game is indeed. Unfortunately, Master Quest is available only in the disc... since this issue still occurs in the latest builds, I'm thinking about this being related to the nature of the game itself (a ROM inside the disc). Would it be the case?

#5 Updated by Billiard26 over 8 years ago

issue 5826 has been merged into this issue.

#6 Updated by Billiard26 over 8 years ago

Tried DSP LLE?
Tried single core mode?

#7 Updated by william.ribeiro.ibiapina over 8 years ago

I always use DSP LLE, but never considered using single core mode as a workout (besides when playing Soul Calibur II). Will give it a try after getting the emulator again (my HD was damaged beyond repair, so I lost quite everything I had...). I'll report here whether or not it works.

#8 Updated by william.ribeiro.ibiapina about 8 years ago

Tested just now with 3.5-393 using single core mode. This issue still occurs - only appeared later, but since it seems to be completely random, I wouldn't trust this.
I keep believing this is due to the game's nature - being a ROM running in an emulator that is built in the GC's hardware. Anyone else thinks the same?

#9 Updated by euathlus about 8 years ago

I have the same problem, I have the PAL GC version of OoT+MQ and i tried different settings. The game freezes or Dolphin crashes after 3-20 minutes randomly. Would be nice if someone could fix this, I would even send the iso file if it would help. Best game

#10 Updated by william.ribeiro.ibiapina about 8 years ago

For me, the emulator didn't crash (yet), but the freezing issue seems very difficult, perhaps impossible, to know when and how many times it'll happen at each gameplay.

#11 Updated by Billiard26 about 8 years ago

  • Issue type set to Bug

#12 Updated by JMC4789 over 7 years ago

  • Status changed from New to Questionable

I've been playing the Zelda collector's edition Ocarina of Time and it plays perfectly. If this is still an issue please update us.

#13 Updated by klkblake over 7 years ago

I've been playing Ocarina of Time (from the disk w/ Master Quest) and have been having the same problem with random crashing. I've tried a number of revisions -- currently using 4f13f6ecaa from 19/11/2013, and been able to duplicate the crashes as far back as a few revisions after 3.0 (further back than that and it becomes to difficult to get it to compile with modern libraries). Sometimes dolphin crashes completely, sometimes the emulation loops (no error messages, fps reported as 0), and sometimes the emulation crashes without taking dolphin down with it. The error I received from the last time the latter happened:

Non-recoverable Exception 2
------------------------- Context 0x80131cf0 -------------------------
r0 = 0x80ab90d8 ( -2136239912) r16 = 0x80119814 ( -2146330604)
r1 = 0x80146ab0 ( -2146145616) r17 = 0x80119820 ( -2146330592)
r2 = 0x8013e4a0 ( -2146179936) r18 = 0xbf05610b ( -1090166517)
r3 = 0x00000004 ( 4) r19 = 0x8036ead4 ( -2143884588)
r4 = 0x80131cf0 ( -2146231056) r20 = 0x8036dea4 ( -2143887708)
r5 = 0x8009f2ec ( -2146831636) r21 = 0x0000008a ( 138)
r6 = 0x8073ad48 ( -2139902648) r22 = 0x0000008a ( 138)
r7 = 0x8002b8c4 ( -2147305276) r23 = 0x0000033c ( 828)
r8 = 0x00ac66c0 ( 11298496) r24 = 0x8036ead4 ( -2143884588)
r9 = 0xdfffffff ( -536870913) r25 = 0x8036dea4 ( -2143887708)
r10 = 0x00000000 ( 0) r26 = 0x00000910 ( 2320)
r11 = 0x80100000 ( -2146435072) r27 = 0x8011fb20 ( -2146305248)
r12 = 0x00000357 ( 855) r28 = 0x8036ead4 ( -2143884588)
r13 = 0x8013d4c0 ( -2146184000) r29 = 0x800088b0 ( -2147448656)
r14 = 0x8036dea4 ( -2143887708) r30 = 0x00000000 ( 0)
r15 = 0x80119808 ( -2146330616) r31 = 0x8011fa60 ( -2146305440)
LR = 0x80ab90d8 CR = 0x40000088
SRR0 = 0x8009f2ec SRR1 = 0x00000030

GQRs----------
gqr0 = 0x00000000 gqr4 = 0x00060006
gqr1 = 0x00000000 gqr5 = 0x00070007
gqr2 = 0x00040004 gqr6 = 0x07060706
gqr3 = 0x00050005 gqr7 = 0x05070507

Address: Back Chain LR Save
0x80146ab0: 0x80146b18 0x80ab90d8
0x80146b18: 0x80146b30 0x8002d480
0x80146b30: 0x80146b78 0x800083f0
0x80146b78: 0x80146ba8 0x800057b8
0x80146ba8: 0xffffffff 0x80003274

DSISR = 0x40000000 DAR = 0xe7ac66c8
TB = 0x003f19edee15c946

Instruction at 0x8009f2ec (read from SRR0) attempted to access invalid address 0xe7ac66c8 (read from DAR)

Last interrupt (20): SRR0 = 0x8009eb14 TB = 0x003f19edee12785e

Things that often trigger crashes: day/night transitions (it often crashes immediately after the rooster crows), transitions between areas, killing an enemy (for the first time in that are), falling from a high place. The probability of a crash occurring builds up over time and persists across save state save/loads. E.g, if I've just loaded up the game normally (not from a save state), I can experience a few triggers without issue. However, if I've experienced many triggers since I last loaded normally, any additional trigger carries a very high chance of crashing. Since loading normally teleports Link to his house, I often try and reload from save states and do things slightly differently so I can keep playing, but it's fairly easy to get into a situation where nearly any area transition will cause a crash. If I load a save state and try to repeat whatever I did the first time to cause a crash, it will nearly always crash.

#14 Updated by kenkengrovan over 7 years ago

Sorry for my bad english
We have the same problem when in ocarina of time properties in game config check enable dual core then if you have ar codes and patches remove them and now I can go to kokiri village

#15 Updated by JMC4789 over 7 years ago

  • Status changed from Questionable to Accepted

All the Ocarina of Time games have problems. Ignore my previous comment.

#16 Updated by JMC4789 over 6 years ago

  • Status changed from Accepted to Duplicate

I examined the crashing I see here and mine, and they're the same. Merging the issues together.

Also available in: Atom PDF