Project

General

Profile

Emulator Issues #5804

Graphic Addition Suggestion

Added by shinra35888 over 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Future
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

  1. I would like to request a horizontal flicker fix border option. The number we set will add a horizontal pixel line(s) across the top and bottom edges of the screen. Would get rid of some artifacts present when upping the native resolution.

  2. Vertical flicker fix border option. The number we set will add a vertical pixel line(s) along the left and right edges of the screen. Would get rid of some artifacts present when upping the native resolution.

  3. Scanlines. Would mask the blocky-ness of the 2D sprites when upping the native resolution.

  4. Scanlines Opacity setting. The higher the number we set, the greater the transparency for the scanlines.


Related issues

Is duplicate of Emulator - Emulator Issues #5806: [Feature Request] Implement Post-processing shaders in the DirectX backendDuplicate

Blocked by Emulator - Emulator Issues #5805: [Feature Request] Stackable Post-processing shadersWork started

History

#1 Updated by Sonicadvance1 over 8 years ago

  • Status changed from New to Accepted
  • Issue type set to Feature request

This may be addressed in the next release.

#2 Updated by scientificraver over 8 years ago

Scanlines are so outdated. Why not use an XBR filter on 2D Sprites instead?

#3 Updated by shinra35888 over 8 years ago

I still love scanlines. They usually don't look good without the opacity meter though. But with it, looks great. Opacity at 223 ftw! xD

XBR looks a bit playdoh'y to me. Kinda like Hqx but smoother. A little unnatural for my tastes. I'm a screen blur and scanline kinda' guy :P

Thanks in advance!

#4 Updated by Sonicadvance1 over 8 years ago

  • Milestone set to Future

#5 Updated by Billiard26 over 8 years ago

  • Status changed from Accepted to Duplicate

These things can be done with post-processing shaders.

Also available in: Atom PDF