Project

General

Profile

Emulator Issues #5806

[Feature Request] Implement Post-processing shaders in the DirectX backend

Added by Sonicadvance1 over 6 years ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Windows
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

As the title says.


Related issues

Has duplicate Emulator - Emulator Issues #5804: Graphic Addition SuggestionDuplicate

Has duplicate Emulator - Emulator Issues #5813: High Internal Resolution and Texture Filtering Issue and SuggestionDuplicate

Is duplicate of Emulator - Emulator Issues #9376: [Feature Request] Post processing effects in D3D11Fixed

History

#1 Updated by parlane over 6 years ago

Invalid report, did not use issue template. Closing.

#2 Updated by Sonicadvance1 over 6 years ago

  • Milestone changed from Next to 4.0

#3 Updated by Billiard26 over 6 years ago

issue 5804 has been merged into this issue.

#4 Updated by Billiard26 over 6 years ago

issue 5813 has been merged into this issue.

#5 Updated by Billiard26 over 6 years ago

issue 5813 has been merged into this issue.

#6 Updated by delroth almost 6 years ago

  • Milestone changed from 4.0 to Current

Are we keeping this for 4.0?

#8 Updated by NeoBrainX almost 6 years ago

  • Status changed from New to Work started

#9 Updated by NeoBrainX almost 6 years ago

  • Milestone deleted (Current)

Not important enough to block 4.0. We'll see if I can find some time to finish this in the next few weeks.

#10 Updated by theincrediblemastere about 3 years ago

I'm pretty sure this can be closed now.

#11 Updated by mimimi about 3 years ago

theincrediblemastere wrote:

I'm pretty sure this can be closed now.

Isn't this pr exactly what the issue is about:
https://github.com/dolphin-emu/dolphin/pull/3366
?

#12 Updated by JosJuice about 3 years ago

  • Status changed from Work started to Fix pending
  • Assignee deleted (NeoBrainX)

Yes, https://github.com/dolphin-emu/dolphin/pull/3366 sounds exactly like it fixes this.

#13 Updated by ryanebola16 almost 3 years ago

I believe that PR 3366 doesn't include DX12. DX12 should also have post-processing shader support.

#14 Updated by Billiard26 6 months ago

#15 Updated by Billiard26 6 months ago

  • Status changed from Fix pending to Duplicate

Also available in: Atom PDF