Project

General

Profile

Emulator Issues #5855

Force Feedback not Working

Added by shinra35888 over 8 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I'm trying to get the dolphin emulator to rumble. I am using the Radioshack PS2 to usb controller adapter. I am also using a playstation 2 controller.

In-game, I can't get any forcefeedback. When I look in the options, the Rumble [motor] box is empty. If I click on that empty box, it'll say sdl/0/usb dual vibration joystick. Nothing will be in the final 2 boxes. Pressing Test, Select, | or, or Set does nothing.

Dxdiag says : ForceFeedback Driver = D:\Program Files (x86)\VID_0E8F&PID_0003\Masspread\DualVibration\GAJoyFF.dll

This feature works on every normal pc game and all emulators that support rumble except this one. I am not using x360ce, just the bare controller. So no native xinput support. I am also using the emulated gamecube controller setting.

My operating system is Windows 7 Home Premium 64-bit.

I am using the x64 version of the dolphin emulator: Dolphin Git 3.5-124
I've tried the x86 version too but I ran into the same problem.

History

#1 Updated by diegojp955 over 8 years ago

Try using DInput instead then click the box and set one of the effects listed: Constant, Triangle, Sine, etc.

#2 Updated by shinra35888 over 8 years ago

Tried that initially because it was set to that by default. When using DInput/0/USB Dual Vibration Joystick, same results happen. No rumble and nothing shows in those last 2 spaces in the rumble section.

I got the emulator build from the emucr website and I also tried the stable build from this site.

#3 Updated by diegojp955 over 8 years ago

Did you install the adapters' driver?

#4 Updated by diegojp955 over 8 years ago

Or execute joy.cpl to test first if have actually implemented ff

(Windowskey + R, then type 'joy.cpl' and enter, choose your hardware and go to 'effect' or somewhat tab)

#5 Updated by shinra35888 over 8 years ago

I made a small error in the name of the adapter. It is the radioshack playstation to usb adapter connected to a ps2 controller. On the face of the disc, it says to install in a computer running on 98, 98se, me, 2k, and xp. It doesn't say 7 because I got it along time ago before 7 existed. In my xp machine, the force feedback option to test is in the location you told me to go. In this win7 machine, the force feedback test is not there. I just reinstalled the drivers from the disk as well. But again, the rumble works in every other game and emulator.

#6 Updated by skidau over 8 years ago

  • Status changed from New to Invalid

I think you'll need to use the x86 version of Dolphin, not the 64bit version for rumble to work. For further help, try asking on the forums:

http://forums.dolphin-emu.org

#7 Updated by shinra35888 over 8 years ago

eeeh, I just said in the beginning post that I tried both...

#8 Updated by danialhorton over 8 years ago

Give the attached testing utilities a try

#9 Updated by shinra35888 over 8 years ago

with this tester in the above zip, these are the rumbles that work when I click on the checkboxes:

constant
periodic
grooves

#10 Updated by shinra35888 over 8 years ago

with fedit.exe and choosing effect > insert, all rumbles work all the way down to sawtooth down.

#11 Updated by danialhorton over 8 years ago

on the Rumble button in dolphin, you have to click square/ramp, etc and then click select before the test button will actually work.

#12 Updated by shinra35888 over 8 years ago

That's the thing, when I click the rumble button, nothing is shown. The box beside 'Test' is blank and the box above 'Clear' is blank.

#14 Updated by skidau over 8 years ago

Are you using the x86 version? You have to use DInput, not SDL.

#15 Updated by shinra35888 over 8 years ago

Finally shows up for x86 after the umpteenth time. When switching to sdl, the box stays blank until you hit refresh. Also, which is the most accurate rumble to use? Setting all causes the emulator to crash. So how many can I pick in total to have that not happen?

So is this going to be fixed for x64 version or not?

#16 Updated by shinra35888 over 8 years ago

Also, in the emulator, testing Square, Triangle, Sawup, and Sawdown rumble crashes the emulator as well. Sine just doesn't work. So all I can use is constant or ramp.

Also available in: Atom PDF