Project

General

Profile

Emulator Issues #5883

Skyward Sword - Crash with DX11

Added by Anonymous over 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

SOUE01
3.5-184 x64 JITTIL DX11

I noticed a similar issue that has been deemed fixed. When the old woman tells you to seal the imprisoned the 3rd time. It freezes and crashes with that message.


Related issues

Is duplicate of Emulator - Emulator Issues #5682: Zelda SS Crash when entering a silent realm trial (in newer revisions only)Fixed

History

#1 Updated by tommyhl2.SS over 8 years ago

Fill out the issue template properly.

#2 Updated by Anonymous over 8 years ago

I provided every answer already. I didn't keep the template text in the issue, it's useless noise and some of it doesn't apply.

#3 Updated by parlane over 8 years ago

Do you have a save near that location?

#4 Updated by delroth over 8 years ago

Why are you using JITIL? Use JIT64.

#5 Updated by Anonymous over 8 years ago

I never had a problem with JITIL with the games I play. I already tried JIT64 same issue. I attached my save. You need to beat the imprisoned then the cutscene will happen.

I also made a save state that takes after the imprisoned is beat but before the crash.
https://skydrive.live.com/redir?resid=1973992AD6E248B0!1015&authkey=!AHTWdiPlUS9qpPo

#6 Updated by ludovic.prevot over 8 years ago

did you try dsp LLE? and OpenGL?

#7 Updated by sanitarium026 over 8 years ago

Try to use OpenGL and JIT (recommended), i've already have this problem at this moment..

#8 Updated by Anonymous over 8 years ago

OpenGL and JIT worked. I couldn't use my save state, but I beat the guy pretty quick. I updated to 3.5-202 before trying it.

#9 Updated by Billiard26 over 8 years ago

  • Status changed from New to Invalid

Using savestates - assuming invalid.

#10 Updated by Anonymous over 8 years ago

That would be assuming wrong. I only used save states for bug purposes. In
fact, what I did was beat the boss, and do a save state right before the
point of crashing so you can get the exact reason why it's crashing and fix
it.

The silent realm zones are a problem in DX11, as well as imprisoned scenes.
It still crashes, the bug is not fixed or this is a very similar bug. You
can load the game, load the game save (not save state) and try to enter the
silent realm. It took me 3 tries to enter it without crashing on DX11. I
didn't change anything in between. Seems like after a while, something gets
corrupted and it will crash, but it doesn't happen 100% of the time, just
most of the time.

OpenGL and JIT worked, but that also crashed on me a few times. Silent
Realms plus stuff involving Imprisoned cut scenes still crashes dolphin.

#11 Updated by Billiard26 over 8 years ago

  • Status changed from Invalid to Questionable
  • Issue type set to Bug

Have you tried "Single Core" mode?

#12 Updated by Anonymous over 8 years ago

I already gotten past the crash parts, but no I don't think I tried that.

#13 Updated by giedoterol about 8 years ago

I've beaten the game with DX11, the only crash I've had was the Silent Realm one.
Started playing with Dolphin build 940 or something near that one.
Guess this one was unintentionally fixed :)

#14 Updated by skidau about 8 years ago

  • Status changed from Questionable to Duplicate

Also available in: Atom PDF