Project

General

Profile

Emulator Issues #5977

Older Wiimotes (Pre -TR) have broken audio in emulated Bluetooth

Added by white.phoenix over 7 years ago. Updated about 2 months ago.

Status:
Won't fix
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Revision d5ec631337c7 fixes the input delay regression introduced by Revision 11a4c92325d5 however the wiimote speaker/vibrations are still out of sync and will delay/echo.

This was discussed in IRC, and we tried many values on line 185 of WiimoteReal.cpp without success, so I'm opening this just as a reminder.

I've tested with Zelda: Skyward Sword (SOUE01) and New Super Mario Bros, but it also occurs in the wii menu by adjusting the volume slider. Seems to be worse with a generic bluetooth dongle using generic windows bluetooth stack. To be honest I'm not entirely sure if this is just me or reproducible by others.

Steps to reproduce: Make the wiimote make a lot of sounds or vibrations.

Dolphin Version: 3.5-374 x64 on Windows 7 x64


Related issues

Has duplicate Emulator - Emulator Issues #6132: DKCR Wiimote disconnects very often - Game UNPLAYABLEDuplicate

Has duplicate Emulator - Emulator Issues #6200: Disabled Speaker Data breaks controls of Mario Strikers Charged FootballDuplicate

Has duplicate Emulator - Emulator Issues #8002: No More Heroes: Calls have really bad quality coming from the Wiimote speaker.Duplicate

Has duplicate Emulator - Emulator Issues #8459: WiiMotionPlus sound lagDuplicate

Has duplicate Emulator - Emulator Issues #10032: Problema nos Speakers Wii RemoteDuplicate

Has duplicate Emulator - Emulator Issues #9061: Super Paper mario: Several issues with using Tippi's abilityDuplicate

History

#1 Updated by white.phoenix over 7 years ago

Also related was issue 5966

#2 Updated by white.phoenix over 7 years ago

Also forgot to mention the vibration lags and echos/repeats too, for example getting 9 vibrations instead of 5.

#4 Updated by Billiard26 over 7 years ago

issue 6132 has been merged into this issue.

#6 Updated by Billiard26 over 7 years ago

Disconnects are caused by the delays we inject on the output reports when speaker data is present.

#7 Updated by Billiard26 over 7 years ago

issue 6200 has been merged into this issue.

#8 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug

#9 Updated by JMC4789 about 7 years ago

The disconnects are unrelated to Dolphin; works on bluetooth stacks that are not default in windows.

#10 Updated by NeoBrainX almost 7 years ago

  • Status changed from New to Questionable

OnHold=>Questionable.

#11 Updated by Billiard26 over 6 years ago

Iirc, "disconnects" in the emulator (not physical bluetooth disconnects) DO occur with some games when speaker data is enabled. (caused by delays that we inject, like I'd said)

#12 Updated by zerolagg over 6 years ago

The Wiimote speaker still sounds bad and games like Fragile Dreams is very necesary for listen the tips from characters and listen special sounds for search through sound any characters.

I tried use diferents Wiimotes(White original,Black,Red in box game Mario Kart) and Toshiba BlueTooth stack,DSP HLE LLE but nothing works

Please is the only error that i detected in the emulator any works perfect even High Resolution (2560x2112) except Wiimote speaker and many games use this for add fun to the game.

#13 Updated by mac1202 almost 6 years ago

Same thing under linux stable or git version; hle or lle the sound from the wiimote speaker is awful.

#14 Updated by flacs over 5 years ago

issue 8002 has been merged into this issue.

#15 Updated by MayImilae over 5 years ago

issue 8459 has been merged into this issue.

#16 Updated by JMC4789 almost 5 years ago

  • Status changed from Questionable to Fix pending

I know this is going to sound crazy... but...

Fixed in PR-3245 -> https://github.com/dolphin-emu/dolphin/pull/3245

#17 Updated by JMC4789 almost 5 years ago

  • Subject changed from Real wiimote speaker sounds almost as bad as dubstep to Older Wiimotes (Pre -TR) have broken audio in Dolphin

#18 Updated by JMC4789 almost 5 years ago

-TR Wiimotes now have working Wiimote audio on Windows at the very least.

https://dolphin-emu.org/download/dev/8acf8cf4d07684e9dc515a22b642e66e8fe7e231/ was the fix, aka, 4.0-8325

#19 Updated by JosJuice almost 5 years ago

  • Status changed from Fix pending to Questionable

Changing back to Questionable because this issue now only is about non-TR Wii Remotes.

#20 Updated by rancourttommylee almost 5 years ago

when you think fix the bug for wiimote non -TR?

#21 Updated by JMC4789 almost 5 years ago

  • Status changed from Questionable to Accepted

Considering it took 3 years to get -TR Wiimote audio working... 2018 - 2019?

#22 Updated by JosJuice over 3 years ago

#23 Updated by JosJuice about 3 years ago

  • Has duplicate Emulator Issues #9061: Super Paper mario: Several issues with using Tippi's ability added

#24 Updated by leoetlino over 2 years ago

  • Subject changed from Older Wiimotes (Pre -TR) have broken audio in Dolphin to Older Wiimotes (Pre -TR) have broken audio in emulated Bluetooth

#25 Updated by danileon95 9 months ago

JMC4789 wrote:

Considering it took 3 years to get -TR Wiimote audio working... 2018 - 2019?

Welp, it's 2020 now lol

#26 Updated by Billiard26 about 2 months ago

  • Assignee set to Billiard26
  • Status changed from Accepted to Won't fix

I've determined the main cause of poor Wii remote audio with emulated Bluetooth.

Genuine Wii Remotes seem to operate at 100hz until "sniff" mode is enabled.
This is observable from the rate of input reports and activity on the i2c extension bus.

The 6khz audio data produces 150 speaker data packets per second.
Remotes tend to not process many of these causing their decoder to desynchronize from the games' encoder.

"TR" remotes seem to buffer the reports better. They still perform poorly without sniff mode, just not as bad as non-TR.

The Wii sends "HCI_Write_Link_Policy_Settings" (0x000D) and "HCI_Sniff_Mode" (0x0003).
Both the min and max intervals are set to 5ms.

Remotes then operate at 200hz and handle the high rate of speaker data.

Unfortunately Bluetooth managers do not expose the ability to configure or enable sniff mode.
I think it's unlikely they ever will. This is something that applications should probably not be controlling.

Without some equivalent of "Bluetooth Passthrough" or elevated permissions to send HCI commands to the Bluetooth hardware this issue appears not fixable.

Note that re-encoding the 6khz audio to 3khz for 75 packets per second didn't seem to help much in my tests.

Also available in: Atom PDF