Project

General

Profile

Emulator Issues #599

EFB copy to RAM crashes r2276

Added by AHeinerm almost 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game: Paper Mario 2: The Thousand Year Door
Dolphin Version: Win32 build r2276
OS: Win32 Vista(Tweaked for compatibility and speed)
Primary Settings:
http://img3.imageshack.us/img3/1825/settingspd3.gif

Using OpenGL plugin,

EFB copy to GL texture works fine, while EFB copy to RAM causes the
following error message:
http://img26.imageshack.us/img26/6564/crashnm5.gif

The crash occurs after confirming the following dialog box(when the event
ends):
http://img3.imageshack.us/img3/539/cmp1pj4.gif

Additional information: I've tried each setting with safe and unsafe
texture cache. This is an unrelated issue, but a screenshot of the unsafe
texture cache is here(note the extra pixels, appear to be placed on the
very top right or left of some textures):
http://img6.imageshack.us/img6/6853/cmp2py8.gif

Trying to stop the emulation in any case causes dolphin to crash
completely(unhandled exception).


Related issues

Is duplicate of Emulator - Emulator Issues #360: Bounding Box registers are not working correctlyFixed

History

#1 Updated by AHeinerm almost 11 years ago

Another small thing I've noticed: The option to HLE the bios all the time is not
saved when the configuration dialog is closed.

#2 Updated by Anonymous almost 11 years ago

  • Status changed from New to Questionable

does this still happen?/Can anyone else duplicate?

#3 Updated by Nintendo-Daniel over 10 years ago

Yeah, still happens in r2666 for me when EFB copy to RAM option is selected. EFB copy
to GL texture works fine, as said by the previous poster above. :)

#4 Updated by sl1nk3.s over 10 years ago

Is this the only game which crashes with copy EFB to ram or is there others ?

#5 Updated by AHeinerm over 10 years ago

Don't know. Still crashes on r2745.
Log:
E: * Warning: Read from invalid memory region (0x7c6102ca)

#6 Updated by AHeinerm over 10 years ago

Ok. The crash occurs because of issue 360.

#7 Updated by Anonymous over 10 years ago

  • Status changed from Questionable to Duplicate

#8 Updated by marcus over 10 years ago

what?

#9 Updated by AHeinerm over 10 years ago

The crash is a product of issue 360.

#10 Updated by marcus over 10 years ago

how does that figure? all the thing in issue 360 does is return the bounding box of
an object on the screen. What does an invalid memory region have to do with it? The
bounding box function is not even used until several minutes after the place where
the screenshot was taken.

#11 Updated by AHeinerm over 10 years ago

I'm over 9000 percent sure that the X-Naut is copied right after that message (logs
prove). The issue in 360, returning the INCORRECT value of the bounding box has
incorrect results as well, which includes the crash in this issue.

#12 Updated by marcus over 10 years ago

ok. If you've done your research, I'm fine with it. I hope ector can get that
bounding box working correctly sometime soon.

Also available in: Atom PDF