Project

General

Profile

Emulator Issues #6058

Real Wiimote doesn't work anymore in Michael Jackson Experience after real-wiimote-scanning branch merge

Added by hatarumoroboshi about 7 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
Controls
% Done:

0%

Operating system:
Windows
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Have you searched the issue tracker for a similar issue?
Yes

Game Name?
Michael Jackson Experience

Game ID?
SMOP41

What went wrong?
Real Wiimote doesn't work anymore

What did you expect to happen?
Real Wiimote to work

What steps will reproduce the problem?
Start the game, when you get to the main game menu the Wiimote is already disconnected, if you reconnect it with ALT+F5 it stays connected for 5-6 seconds then it gets disconnected again...try again to reconnect but always only 5 seconds then gets disconnected again and again and again...
If you disable the Speaker in the Dolphin Wiimote options the Wiimote still gets always disconnected in 5-6 seconds and furthermore the pointer goes crazy.

What version of Dolphin were you using?
3.5.491 32-bit ( revision ef7083d78cde )

64 or 32 bit Dolphin?
32-bit

What version of Dolphin used to work?
revision e5c53e371f5e (3.5-432)

What Operating System were you using and what are your hardware
specifications?
Win XP 32-bit, MS stack, Eminent em1081 bluetooth dongle, Real Wiimote (original Nintendo Wii remote plus)

64 or 32 bit Operating system?
32-bit

Any other relevant information or links to logs:
The cause of the issue is the real-wiimote-scanning branch merge: revision 46adbfa9ede1 (3.5-471) ; previous revision e5c53e371f5e (3.5-432) works perfectly.


Related issues

Has duplicate Emulator - Emulator Issues #6093: Wiimote will disconect after a few seconds.Duplicate

Has duplicate Emulator - Emulator Issues #6170: Wii-Motes V3.0 vs. 3.5 not working Duplicate

History

#1 Updated by hatarumoroboshi about 7 years ago

Forgot to write that my wii remote plus ID is RVL-CNT-01

#2 Updated by Billiard26 about 7 years ago

  • Status changed from New to Questionable

What? only this game is affected?

#3 Updated by hatarumoroboshi about 7 years ago

Well for now I've found this one...If I find some other games I'll let you know;-)

P.S. why you always put questionable on issues?

#4 Updated by Billiard26 about 7 years ago

OK.. what I meant to ask is:

Are you able to use wiimotes in other games?

It's questionable because I can't reproduce it and it sounds like a duplicate of issue 6049.

#5 Updated by hatarumoroboshi about 7 years ago

Another game affected is Just Dance 2 (again an Ubisoft game with almost the same engine)

Yes I'm able to use the Wiimote in other games (for example in Wii Sports seems to work perfectly so far)

how could it be a duplicate of issue 6049 when that one is for Wiimotes not beeing recognised (refreshed) while this one is for Wiimote beeing disconnected?
In fact this issue has not been fixed by revision cedfa452b449 and it's still there.

#6 Updated by Billiard26 about 7 years ago

Please set your log config to "Warning" and show me the log during one of these disconnections.

Preferably paste the log contents here: http://pastie.org/

#7 Updated by hatarumoroboshi about 7 years ago

Here's the log: from the very beginning (pairing the Wiimote and refreshing) then starting the game and then in the end some disconnections and reconnections with ALT+F5...

http://pastie.org/6375033

#8 Updated by skidau about 7 years ago

  • Status changed from Questionable to Accepted

I am getting the same issue here in Dolphin x64 3.5-518 (rcedfa452b449) using Windows 7 x64. The real wiimote (RVL-CNT-01) disconnects a few seconds after connecting.

#9 Updated by hatarumoroboshi about 7 years ago

This should have something to do with the old "alternate Wiimote timing" option (that was lately "auto-integrated" in Dolphin), because now Disney Epic Mickey keeps on disconnecting real wiimote (the game works good before the real-wiimote-scanning branch merge aka revision 46adbfa9ede1 )

#10 Updated by hatarumoroboshi about 7 years ago

And before someone should ask, the option for disabling the speaker data in the wiimote settings doesn't solve the problem for no one of the games affected mentioned so far...

#11 Updated by Billiard26 about 7 years ago

Alternate wiimote timing was already removed in re5c53e371f5e.

#12 Updated by hatarumoroboshi about 7 years ago

I know, that's why I wrote that it was "auto-integrated"

#13 Updated by Billiard26 about 7 years ago

Why would this have anything to do with alt wiimote timing if it was working after the removal and broken by real-wiimote-scanning?

#14 Updated by hatarumoroboshi about 7 years ago

What I'm trying to say is that the games that in old revisions needed that option (when it wasn't yet "integrated"), after the real-wiimote-scanning branch merge don't work anymore (keep on disconnecting real wiimote)

#15 Updated by hatarumoroboshi about 7 years ago

Problably the real-wiimote-scanning branch breaks someting about that implementation...

#16 Updated by hatarumoroboshi about 7 years ago

...and to confirm my theory, Red Steel 2 (another game that needed alternate wiimote timing in the past) keeps on disconnecting real wiimote after the real-wiimote-scanning branch...

#17 Updated by Billiard26 about 7 years ago

Figuring out exactly which revision in real-wiimote-scanning caused the problem would be mega-useful.
I'm lazy, but I will get around to it eventually.

If you want to speed up my fixing of the issue you could figure that out for me. :p
Downloads: http://dolphin-emu.org/download/list/real-wiimote-scanning/1/

#18 Updated by hatarumoroboshi about 7 years ago

Ok, tomorrow I'll try to find it out

#19 Updated by o0oxmen93o0o about 7 years ago

i have same problem.

#20 Updated by hatarumoroboshi about 7 years ago

OK, I tested all the revisions of the branch:

From 262 to 413 they don't work (al least on my system: Windows XP 32-bit), because the wiimote cannot be refreshed (recognised by dolphin/game)

414 refreshes the wiimote but already has the problem explained in this issue...

#21 Updated by binhboongboong1992 about 7 years ago

many game dont working with wii mote( disconnect a few sec)on revision e5c53e371f5e (3.5-432)

#22 Updated by skidau about 7 years ago

issue 6093 has been merged into this issue.

#23 Updated by evilmandark78 about 7 years ago

i'm having the same problem with "Metroid Prime Trilogy" (Win XP 64-bit, MS-Stack, Asus BT-211 bluetooth dongle and an original Nintendo Wii Remote plus [non-TR]).

#24 Updated by JMC4789 about 7 years ago

Turning off Wiimote sounds will fix the disconnect in Metroid Prime Trilogy.

#25 Updated by evilmandark78 about 7 years ago

@JMC4789
thanks for the info! it indeed works with wiimote sound turned off.

#26 Updated by juanramon.myoffice about 7 years ago

Having the same problem with rayman origins, DKCR, and Just dance 2 and 3.Original wiimotes disconnect ingame after 5 or 6 second of pressing alt+f5, but they continue paired. They work well without disconnections in NSMB , wii play and wii sports. I have two original wiimotes and two 3rd party (dealxtreme) and all of them behave the same.

#27 Updated by juanramon.myoffice about 7 years ago

How do you turn off the wiimote sound?. Because when I set WiimoteEnableSpeaker = False, the wiimote doesn't disconnect in rayman origins, but it responses to wiimote presses a lot of time later. No slowdowns (60fps), just very slow response, any hints?. Sorry for my English . Thanks.

#28 Updated by evilmandark78 about 7 years ago

@juanramo
are you using 1 or 2 real wiimotes?

i've tested around a bit more, and came to the following conclusion:
- 1 real wiimote + Speaker disabled = working fine
- 1 real wiimote + Speaker enabled = working fine
- 2 real wiimotes + Speaker disabled = controls not working or responding with extreme delay
- 2 real wiimotes + Speaker enabled = constant disconnects

#29 Updated by juanramon.myoffice about 7 years ago

evilmandark78
I'm not so lucky :
-1 real wiimote + "WiimoteEnableSpeaker = False" ---> not working or extreme delay
-1 real wiimote + "WiimoteEnableSpeaker = True" ---> constant disconnects
-2 real wiimotes + "WiimoteEnableSpeaker = False" ---> not working or extreme delay
-2 real wiimotes + "WiimoteEnableSpeaker = True" ---> constant disconnects

All the tests are with Original nintendo wiimotes, but the behaviour is the same with my two other 3rd party ones.

It happens in rayman origins, DKCR, Just Dance 2 and 3

It works perfectly in New super mario, wii sports , wii play and Just Dance (first one) with 4 wiimotes.
In the attached picture is my configuration.

#30 Updated by skidau about 7 years ago

issue 6170 has been merged into this issue.

#31 Updated by frank.adelhof about 7 years ago

I have this Problem in all Games... Dolphin 3.0 Working fine with Wiimotes and 3.5 will not work with any wiimote...

#32 Updated by hatarumoroboshi about 7 years ago

In order to fix this issue wouldn't it be better to reintroduce the Alternate Wiimote timing option?

#33 Updated by Billiard26 about 7 years ago

@ hatarumoroboshi
"Better"? Better than fixing it properly? No.

#34 Updated by Billiard26 about 7 years ago

  • Issue type set to Bug
  • Category set to controls
  • Operating system Windows added

Please try the real-wiimote-minor-fixes branch and tell me if anything has changed.
Downloads: http://dolphin-emu.org/download/list/real-wiimote-minor-fixes/

#35 Updated by Billiard26 about 7 years ago

  • Status changed from Accepted to Duplicate

I am told this can be worked around by disabling wiimote speaker data.

#36 Updated by hatarumoroboshi about 7 years ago

I'll try it as soon as possible

#37 Updated by hatarumoroboshi about 7 years ago

The real wiimote minor fixes branch doesn't fix the problem
Unchecking "enable speaker data" also doesn't fix it

#38 Updated by Billiard26 about 7 years ago

  • Status changed from Duplicate to Questionable

#39 Updated by Billiard26 about 7 years ago

Is the issue resolved in r018282c2b9f2c0f128b0ae6ce9157ae01de5c4d5 (3.5-1204) when Disabling speaker data?

http://dolphin-emu.org/download/

#40 Updated by Billiard26 about 7 years ago

  • Status changed from Questionable to Fixed

Assuming this is fixed by r018282c2b9f2c0f128b0ae6ce9157ae01de5c4d5 based on other very similar issues being fixed.

Also available in: Atom PDF