Project

General

Profile

Emulator Issues #6070

Metroid Prime 2 (MPT) multiplayer not loading

Added by krudemetal over 7 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name
Metroid Prime Trilogy

Game ID
R3MP01

What went wrong?
This game loads different game DOLs through a menu loader. Loading the three main games (Prime 1, Prime 2: Echoes and Prime 3: Corruption) works, but selecting the MP2 multiplayer from the menu loader does not. Instead of loading the multiplayer, it just starts a singleplayer game of MP2.

What steps will reproduce the problem?
Select a profile from the main loader menu, then choose "MP2 Echoes - Multiplayer Mode". After the loading screen, the single player campaign will start up instead.

What version of Dolphin were you using?
Tested with Dolphin 3-5-491 and 3-5-597.

64 or 32 bit Dolphin?
64 bit.

What version of Dolphin used to work?
As far as i can tell, none.

What Operating System were you using and what are your hardware
specifications?
Win7 64 bit, 2.6GHz quad core, GTX 460, 8GB RAM

History

#1 Updated by krudemetal over 7 years ago

I just want to add that it's not just the multiplayer that doesn't work. Apparently the arguments that the menu loader is supposed to pass on to the next DOL get lost.

Which means that "Start MP2 in multiplayer instead of singleplayer" gets lost on the way on one hand.
On the other hand, diffiulty selections for the games in Trilogy are also selected via the menu loader. I just tried to start MP1 on Hard mode ("Hypermode") and after saving and returning to the menu loader, it displays that the game i started is on Normal difficulty ("Veteran", the default).

#2 Updated by krudemetal over 7 years ago

Another argument failure (probably):

Upon completing Metroid Prime 1, after the credits and when saving the completed game, the game crashes when it should return to the menu loader.

#3 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug

#4 Updated by MayImilae over 7 years ago

Tested in 3.5-1335 win64. Confirmed. Multiplayer does not load, it just fires up the last Metroid Prime 2 single player save. There is no dol for the multiplayer, so it appears to just be loading rs5mp2_p.dol (Prime 2). So apparently whatever the launcher does to fire up the multiplayer and not the single player game is not working correctly.

#5 Updated by Bearborg about 7 years ago

This also seems to affect different save files. Trying to launch any of the games from the second or third save slots will always load the equivalent save from the first save slot.

#6 Updated by MayImilae about 7 years ago

  • Status changed from New to Accepted

#7 Updated by Aaron5367 about 7 years ago

A quick note from a friend and to confirm #1's last comment. This issue expands into saves between all three of the games. After starting a game and choosing normal / hyper, it consistently changes to veteran. I believe this is related to what's going on here as well.

What went wrong?
This game loads different game DOLs through a menu loader. Loading the three main games (Prime 1, Prime 2: Echoes and Prime 3: Corruption) works, but selecting the MP2 multiplayer from the menu loader does not. Instead of loading the multiplayer, it just starts a singleplayer game of MP2.

What steps will reproduce the problem?
Create a non-veteran game on any of the three games, save, and look at the difficulty on the main menu.

What version of Dolphin were you using?
Testing on Dolphin 3.5-269
(had to have multidol support and alt. wiimote timing)

64 or 32 bit Dolphin?
64

What version of Dolphin used to work?
Haven't tested this on any older versions as the trilogy just started working. The newer ones lack "alt. wiimote timing" which makes 3 unplayable.

What Operating System were you using and what are your hardware
specifications?
Windows 7
Intel i5 2500k @ 4.4Ghz
8 Gb DDR3
ATI Radeon 6550

#8 Updated by MayImilae about 7 years ago

Aaron5367: New dev versions have "Enable Speaker Data". Turn it off to fix the wiimote disconnecting problems.

https://wiki.dolphin-emu.org/index.php?title=Metroid_Prime:_Trilogy

#9 Updated by JMC4789 about 6 years ago

https://dl.dropboxusercontent.com/u/484730/MetroidPrimeTrilogyMultiplayerMP2.jpg

magumagu seems to have this issue on the run in the IPC-HLE Disc Channel branch

#10 Updated by JMC4789 about 6 years ago

House of the dead 2/3 is another game that suffers from this problem.

https://forums.dolphin-emu.org/Thread-wii-the-house-of-the-dead-2-3-return?pid=325962#pid325962

#11 Updated by MayImilae about 6 years ago

  • Status changed from Accepted to Fixed

Also available in: Atom PDF