Project

General

Profile

Emulator Issues #609

Dual-Layer Disk Support

Added by marcus over 11 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

It would really help to have this. Many games, most notably SSBB, are
broken because of the lack of dual-layer support. Thank you!

History

#1 Updated by rikyskull over 11 years ago

about super smash bros : i tried the dvd5 version of ssbb (with jp patch) , but it
gives the same "insert ssbb disk" error ; maybe it hangs for a different kind of
problem :/

#2 Updated by marcus over 11 years ago

jp patch?

#3 Updated by rikyskull over 11 years ago

jp=john peterson. he fixed the first hang of the "now loading" screen, the game
freeze anyway , and the tried version is not a dual layer disk :(

#4 Updated by XTra.KrazzY over 11 years ago

I don't get it, an ISO is an ISO, no matter what its size is. It should work (unless
we are having 64 bit FST issues...)

#6 Updated by marcus over 11 years ago

hmmmm...now I'm confused...So it isn't a dual-layer problem with brawl?

#7 Updated by ChaosCode over 11 years ago

JP has said it has nothing to do with Duel layer. Some how a registry is being over
writen causing the issue. He was not able to find out what was causing it.

#8 Updated by thegamefreak0134 over 11 years ago

Could it be that Brawl tries to communicate with the DVD drive in the Wii directly to
discover (and perhaps workaround) some issues that the early models of Wii had with
dual layer disc?

#9 Updated by marcus over 11 years ago

to discover?

#10 Updated by thegamefreak0134 over 11 years ago

That was a total guess, I don't pretend to know if that's possible, or if Brawl
does anything of the sort. _^

#11 Updated by marcus over 11 years ago

I think that if this has nothing to do with dual-layer, the problem is that there is
a bit in the game code that checks wether or not the disk is in the drive, and
dolphin is not giving an answer, so it assumes that the disk has been taken out.

#12 Updated by rikyskull over 11 years ago

i don't think about that : i have seen someone with a modded wii getting the same
"insert disk" problem, maybe it's something releated to the update, that is launched
at the first run of the game.

#13 Updated by marcus over 11 years ago

"maybe it's something related to the update"

GENIUS!!!

Of course...It's one of those "why didn't I think of that moments"...if this is the
problem, all you would have to do is run the brick blocker to remove the updates
from the disk and POOF! it would work!

Going to test right now!

#14 Updated by lpfaint99 over 11 years ago

it is probably not the error 001 issue. see
http://code.google.com/p/dolphin-emu/issues/detail?id=417&can=1&q=ssbb#c5

Dolphin doesnt look at the updates on the disc at all

#15 Updated by marcus over 11 years ago

no good...

#16 Updated by XTra.KrazzY over 11 years ago

maybe it's the wii update that fixes some issue in the Wii or enable dual layer disk
support. I remember that both SMG and SSBB caused all of the modchips to update their
firmware. Each one separately.

#17 Updated by marcus over 11 years ago

this is getting more and more confusing...

well, if someone can fiure out what the modchip makers did to the their modchip
firmware to fix this, it could be applied in the same (or perhaps different) way to
dolphin.

Any takers?

#18 Updated by lpfaint99 over 11 years ago

unfortunately, I believe that the changes made to the firmware only changed how the
disc appears to the drive, Because we HLE the drive functions it is probably unrelated

but I could be wrong :p

#19 Updated by marcus over 11 years ago

hmmm...define HLE...I forget what it means...

#20 Updated by lpfaint99 over 11 years ago

There's Low Level Emulation LLE, and High Level Emulation HLE

http://en.wikipedia.org/wiki/High-level_emulation

#21 Updated by marcus over 11 years ago

ah...makes sense.

And what are the biggest diffs in dolphin?

#22 Updated by XTra.KrazzY over 11 years ago

lpfaint99: Maybe there's a "ReadHighUnencrypted" for dual layer disks, or some other
function we don't know about.

#23 Updated by rikyskull over 11 years ago

maybe i'm wrong..but jp fixed this or at least he found a way to avoid the problem ;
for him the game hangs at the end of the intro..

#24 Updated by marcus over 11 years ago

How'd he do that?!?!?

#25 Updated by lpfaint99 over 11 years ago

Check the first post here
http://forums.ngemu.com/dolphin-discussion/115310-wii-super-smash-bros-brawl-official-thread.html

This is only for the PAL version, NTSC version I have never been able to get past the
insert disc error.

XTra.KrazzY: that would be my assumption, looking for some function that is not
implemented, I wonder if bushing has disassembled the update that SSBB requires...

#26 Updated by marcus over 11 years ago

hmmm...but why didn't it fix the NTSC one?

#27 Updated by lpfaint99 over 11 years ago

different regions will almost always have different memory addresses for the same thing

#28 Updated by marcus over 11 years ago

So changing the equivalent memory address in the NTSC one would do the same thing?

#29 Updated by XTra.KrazzY over 11 years ago

lpfaint99: These are, put simply, ugly hacks.

"if(_Data == 0 && _Address == 0x80496a0c) return;"
We should emulate that, not skip it.

"0x801D5898:dword:0x4E800020"
Same goes for the patch.

#30 Updated by lpfaint99 over 11 years ago

XTra.KrazzY: yeah, very clearly :)

which is probably why it doesn't get ingame with the hacks

marc...@cox.net: meh no clue, I'd rather fix it correctly than port ugly hacks to the
ntsc region

#31 Updated by marcus over 11 years ago

hmmm...ok...but have you found the problem then?

#32 Updated by sl1nk3.s about 11 years ago

I don't know if the problem was really the "Dual-Layer Disc Support" because this
problem seems fixed in the latest revs !
http://forums.ngemu.com/dolphin-discussion/119559-super-smash-bros-brawl-fully-playable.html

#33 Updated by fires.gc about 11 years ago

  • Status changed from New to Invalid

i dont think that there is something like a dual layer problem... dual layer reading
has worked all the time (afaik)

#34 Updated by marcus about 11 years ago

Yes, that is the case.

"Pending a commit, but yes, F|RES has gotten it running"

When is that commit?

#35 Updated by ChaosCode about 11 years ago

stop asking. he will commit it when its ready.

#36 Updated by marcus about 11 years ago

sorry...

Also available in: Atom PDF