Project

General

Profile

Emulator Issues #6120

ARM/Android Laundry list

Added by Sonicadvance1 about 8 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Task
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Posting a sort of "todo" list of things that need to be done still with the ARM/Android port of Dolphin. This is basically my Wunderlist in public format. These aren't in the most particular of orders.

  • Android Input
    • Needs to be reworked to use the ControllerInterface and be cleaner inside of the Java source
  • Draw up more onscreen controls
    • Basically just need more controls drawn, I only currently have the A and B buttons
    • Probably should use a atlas or something
  • Handle Android screen rotations
    • Currently on screen rotation, the EGL context wipes and you don't get any more onscreen visuals
  • Support immediates in the register cache
    • Supporting immediates would allow quite a few instructions to be optimized out similar to JIT64 does
  • Flush only required GPRs when dropping to Interpreter
    • This is a micro-op, instead of flushing all registers in the cache before dropping to Interpreter. Check which registers are used by the next instruction and flush only the required ones. Which would be R0-R3 + registers that is used
  • Downcount optimization
    • Each block hits the CoreTiming::Downcount variable. This should be optimized by throwing downcount in to ppcState or even its own dedicated register
  • When d != a && d != s, don't load destination register
    • Currently the register cache will preload a PPC register when you call for it. This can be optimized so if the destination reg in a instruction is neither of the other two, you don't load it since the result will be thrown away anyway.
  • Make register cache not use dedicated temp registers.
    • Currently four registers are squirreled away for temporary usage. This can easily drop to three, but to be even better, it should be changed so that temp registers will pull from the same pool as the dedicated PPC registers, so if we don't use a lot of temp registers in a block, we have more PPC registers to play with
  • Make VideoSoftware use regular texture decoding
    • Right now VideoSoftware uses a large portion of its time decoding texture's texels on the fly, which can be optimized out similar to the other video backends, via the use of a texture cache.
  • DSP LLE JIT
    • Make a ARM/VFP/NEON capable JIT for the DSP
  • Time stretching in OpenSLES
    • Billiard said he was going to take the time to make it so all backends would use soundstretch indirectly. This has yet to come to fruition.

There is my list of current todos that I need done.

History

#1 Updated by delroth about 8 years ago

  • Add this to the GSoC ideas page on our wiki

#2 Updated by Sonicadvance1 about 8 years ago

Input is cleaner, but not all input is in yet.
I've drawn up some graphics for on screen buttons. Not all complete yet.

#3 Updated by MofoMan2000 about 8 years ago

Dolphin on my 'droid? I think I just came a little.
Please make sure physical key control is an option for devices with slide-out keyboards!

#4 Updated by Sonicadvance1 over 6 years ago

  • Status changed from New to Won't fix

Also available in: Atom PDF