Project

General

Profile

Emulator Issues #6139

Super Mario Sunshine Lined Loading Screens

Added by JMC4789 over 7 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name - Super Mario Sunshine - GMSE01

in DX9 and OpenGL, the loading screens don't work properly, instead being striped in various ways.

http://i.imgur.com/4PDtPRV.png

3.0 - 456, r1680c6849ffc8e64d376d4108052c3b825791aa4 is when this first started happening. Strangely enough, if you copy older builds into the 456 folder, they suddenly stop working too, even if you delete the game configs. These older builds had another form of the glitch that looks like this - http://i.imgur.com/nxKdy9H.png

Note, to prove a point, one screenshot is from 441, and the other screenshot is from 441 moved into 456's folder, showing that the glitch happens even with the older exe! I also deleted the game configs just in case they'd be affecting it. I don't think there's anything I could have done to break it, but considering that the build in question is a translation merge, I'm not exactly sure how it could have broken it. Both were freshly downloaded from dl.dolphin.org/oldbuilds so, I'm not entirely sure what I could have done.

Last but not least, here's a fifolog. Have fun! - http://www.mediafire.com/download.php?85ltosxwj3swdmv


Related issues

Is duplicate of Emulator - Emulator Issues #7749: OpenGL Fails to Properly Emulate Point/Line-WidthFixed

History

#1 Updated by daxtsu over 7 years ago

This issue doesn't exist in 3.5-1067-dirty. Use a newer build?

#2 Updated by gamedevistator over 7 years ago

what is your graphics card because when i had that build, i never had that problem.

#3 Updated by MayImilae over 7 years ago

According to SS, this only happens at 1x IR. And yes, JMC4789 and SS tested it on latest.

#4 Updated by daxtsu over 7 years ago

When I run it at 1x IR in OGL or DX9, I don't get the issue on the latest build, so I dunno what to tell you. What kind of GPU are you guys running? I have a GTX 670 with Forceware 314.21..

#5 Updated by JMC4789 over 7 years ago

I'm using a GTX 280; this seems to be one of those issues that doesn't make sense or even happen to everybody.

#6 Updated by MayImilae over 7 years ago

Reproduced. Requires that you set Internal Resolution to "Auto". Auto (Windows Size) produces hard lines with crisp edges. Auto (Multiple of 640x528) has fuzzy lines.

#7 Updated by MayImilae over 7 years ago

Alright, plotted out the various behaviors. It should be noted that Scaled EFB Copies has no effect on this glitch. At least none that I saw.

DX9
Manually setting IR - 1x works, everything else is broken
Auto (Window size) - Broken on all window sizes
Auto (Multiple of 640x528) - Broken on all window sizes

OpenGL
Manually setting IR - Works
Auto (windows size) - Broken on all window sizes
Auto (Multiple of 640x528) - Works at all window sizes except 1x

DX11
Everything works no matter what IR is used.

#8 Updated by rodolfoosvaldobogado over 7 years ago

this is caused by the method this games uses to render the disolve screen.
it uses a large amount of horisontal lines. in dx11 the line width is scalled with the screen, in opengl this scalling is incorrect. in dx9 you cannot set the width of the lines. to fix this, on opengl the scalling method must be correted. and in dx9 line rendering must be emulated with triangles.

#9 Updated by JMC4789 over 7 years ago

Nice! Thank you for the detailed explanation!

#10 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug

#11 Updated by MayImilae about 7 years ago

  • Status changed from New to Accepted
  • Category set to gfx
  • Priority set to Low

#12 Updated by gamedevistator almost 7 years ago

This issue is questionable because i dont have this issue and i have and amd radeon hd 6870 oc. i did have this issue when i had an old radeon graphics card, but not on this one. Could be your drivers or a setting in the Nvidia drivers.

#13 Updated by gamedevistator almost 7 years ago

This issue is questionable because i dont have this issue and i have and amd radeon hd 6870 oc. i did have this issue when i had an old radeon graphics card, but not on this one. Could be your drivers or a setting in the Nvidia drivers.

#14 Updated by MayImilae almost 7 years ago

You were using D3D11. This is very well known and highly documented, with a well known cause.

#15 Updated by crazysheep17 about 6 years ago

So this issue fixed itself at some point, works with openGL now. Revision 2306.

#16 Updated by crazysheep17 about 6 years ago

for auto window size tht is. However, contrary to what MaJo said manually setting it to 2.5 causes this.

#17 Updated by JMC4789 about 6 years ago

  • Status changed from Accepted to Duplicate

Also available in: Atom PDF