Project

General

Profile

Emulator Issues #6154

Paper Mario Water Reflection Problems After Stone Key Quiz

Added by JMC4789 about 7 years ago.

Status:
Fixed
Priority:
Low
Assignee:
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game: Paper Mario The Thousand Year Door - G8ME01

After going through a pipe into the sewers, the water reflections(?) are a bit messed up depending on where you walked. Sometimes they were only slightly messed up, and sometimes the entire surface was messed up.

As customary, I messed with the graphics settings and went back to Dolphin 3.0 and confirmed it was still happening. OpenGL, D3D9, D3D11 and Software Renderer are all afflicted by the glitch.

This is my first playthrough of the game, so I'm not 100% sure how this is supposed to look, but I'm assuming that it's trying to reflect things in the water and it's just not working. If need be, I'll find a way to transfer my save to console and figure out how it looks there. It's pretty safe to say this isn't how it's supposed to look. Depending on where you stand, it can sometimes flicker how it's glitched, too.

Messing with the EFB settings seems to affect it, killing EFB Copies seems to disable it all together. Other than that, I tried all the back-ends from Fifo-log and a savepoint. If need be, I can upload my savefile too; it's almost as easy as using a fifo-log considering how close the save is.

Screenshots - http://i.imgur.com/V3B7SXW.png http://i.imgur.com/Sss7YAF.png

Fifo-log - http://www.mediafire.com/download.php?d92ywyqcqz06ckb


Related issues

Has duplicate Emulator - Emulator Issues #6334: Paper Mario: Thousand Year Door - Weird Water GlitchesDuplicate

History

#1 Updated by MayImilae about 7 years ago

Confirmed via fifolog in 3.5-1064.

#2 Updated by JMC4789 about 7 years ago

https://www.youtube.com/watch?feature=player_detailpage&v=LALAl86j0WY#t=13s

Youtube Video shows no reflections, but probably some kind of effect applied to underwater stuff.

#3 Updated by Billiard26 almost 7 years ago

  • Issue type set to Bug

#4 Updated by Anonymous almost 7 years ago

http://www.youtube.com/watch?v=9zqat3qUcks#t=29s

A video I recorded of this glitch

#5 Updated by Billiard26 almost 7 years ago

issue 6334 has been merged into this issue.

#6 Updated by jgswweet almost 7 years ago

I have noticed that setting the texture cache to accuracy reduces the problem, but it seems to flicker through glitching and not glitching.

Definitely an EFB cache issue.

#7 Updated by MayImilae over 6 years ago

  • Status changed from New to Accepted
  • Category set to gfx
  • Priority set to Low

Confirmed by seeing it myself in 3.5-1394. Weeeird.

#8 Updated by crudelios about 6 years ago

  • Status changed from Accepted to Work started

Please refer to issue 6196 for progress details.

#9 Updated by crudelios about 6 years ago

  • Status changed from Work started to Fixed

Fixed by revision cdfe58f7ede0.

Also available in: Atom PDF