Project

General

Profile

Emulator Issues #6275

Nintendo Puzzle Collection (J) has severe lockups in D3D9/D3D11

Added by JMC4789 over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game: Nintendo Puzzle Collection - GZPJ01

In D3D9/11, there is severe lockup on any kind of loading or transition (moving through menus, loading character screens, etc.) but gameplay remains unaffected.

During the lockup, Dolphin shows 60 fps, but drops down to 0 after it finishes and then recovers to normal framerate. Just letting the opening demo roll will show how severe of a problem it is.

The problem has existed as long as the game has played, from what I can tell. OpenGL has always worked, even pre-GLSL merge.

I ran this in 3.5 1282, 3.5, and 3.0 to test.

I tested this on my Core i5 760@3.0 GHz and GTX 280, my Core i7 2670 QM with GTX 560m, and a friend tested it on their Core i7 3xxx Laptop. All three had the exact same behavior.

I can get video of the problem if need be, but the fifo-log doesn't seem to capture the problem.


Related issues

Is duplicate of Emulator - Emulator Issues #6572: EFB access cache needs to be moved to VideoCommonFixed

History

#1 Updated by Billiard26 over 7 years ago

  • Issue type set to Bug

#2 Updated by tommyhl2.SS over 7 years ago

I'm not getting any lockups with this game at all.

3.5-1302

Asus Laptop: K53TA
OS: Windows 7 Home Premium, 64-Bit - SP1
CPU: AMD Llano A6-3400M, Quad-Core, 1.4GHz-2.6GHz (Overclocked)
GPU: AMD Radeon HD6650M, 1GB GDDR3 (Catalyst 13.1)
RAM: Samsung 4GB DDR3-1333

#3 Updated by JMC4789 over 7 years ago

I tested on my Core2duo (which has a 5850) and did not get the lockup either. Appears to be a nVidia only bug.

#4 Updated by kostamarino over 7 years ago

@ JMC4789 i have an nvidia card and no lockups with the game.

#5 Updated by JMC4789 over 7 years ago

Then I don't know what's going on, probably my computers just being jackasses. Or at least, the nVidia ones. I don't know how to fix this on them, since SS has Windows 7, my computers are running windows 7, the difference was Radeons.

This is an odd issue now... I'll continue to mess with things.

#6 Updated by tommyhl2.SS over 7 years ago

  • Status changed from New to Questionable

#7 Updated by JMC4789 over 7 years ago

Okay, so, I apparently was pretty stupid when I wrote this issue report. The bug only happens in one of the subgames, not all three. Panel De Pon is one of my favorite games, and honestly I didn't check the others. The other two don't suffer at all. Compare D3D9/11 to OpenGL, you'll find every single transitions locks up. This also means my previous tests on the Radeon should be rendered invalid, since I just mashed A and loaded the first game that came up.

Either way, I tested this on 3.5-1593 and it's still an issue for me. I apologize for the incomplete report, and hope this allows people to more concisely confirm the problem.

#8 Updated by JMC4789 about 7 years ago

My computer has entirely changed since I made the original issue report, and even still, I get this issue. If anyone else has the game, more testing would be appreciated! Thanks in advance.

#9 Updated by adam.jimenez about 7 years ago

Happens to me as well with ATI card and DX9/11. Works fine with opengl.

#10 Updated by JMC4789 over 6 years ago

  • Status changed from Questionable to Accepted

Marking as accepted. Not sure what causes this, or what determines if it happens.

On my current PC(s) D3D11 will always have it happen but OGL will always be fine.

#11 Updated by kwanyeung20 over 6 years ago

I also got this issue even with intel graphics 4400, it seems you just need to enable the option skip efb access from cpu

#12 Updated by JMC4789 about 6 years ago

  • Status changed from Accepted to Duplicate

Also available in: Atom PDF