Project

General

Profile

Emulator Issues #6281

Skyward Sword and Mario Galaxy 2 Crashing when changing to certain areas

Added by billy.lundevall about 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I have searched for this issue but haven't found a official thread or solution.

The Legend of Zelda: Skyward sword crashes when entering any of the silent realm trials when the screen turns white and what I assume, loads the new area.

Super Mario Galaxy 2 crashes when the first boss (the dragon) is just defeated and the screen turns black. I assume this is the same problem.

I have traced the problem back to versions newer then 3.0 - 760. In this version the areas load just fine. (I have only tested master branches and only 64-bit).

To reproduce the problem, simply enter one of the trials in Skyward Sword or beat the dragon in Galaxy 2.

I have my game files synced between two different PCs.

i7 2600k

16gb DDR3

Asus p67 Sabertooth

Geforce 580 2gb


Core i5 2500k

8gb DDR3

Asus Maximus IV Gene Z

Geforce 560 1gb


Related issues

Is duplicate of Emulator - Emulator Issues #5682: Zelda SS Crash when entering a silent realm trial (in newer revisions only)Fixed

History

#1 Updated by pauldacheez about 8 years ago

The Skyward Sword issue is related to shader optimization and can be fixed by using OpenGL. The SMG issue can likely be fixed by using DSP LLE. Try those, come back with results.

#2 Updated by billy.lundevall about 8 years ago

Skyward Sword works with OpenGL.

Super Mario Galaxy works after defeating the dragon using DSP LLE, it does however create occasional audio stuttering.

#3 Updated by pauldacheez about 8 years ago

The audio stuttering is normal for LLE - using the OpenAL audio backend or just overclocking by a few hundred MHz will get rid of it. I recommend the latter if you aren't a fan of ludicrous audio latency. >_>

(Hey, someone mark this as fixed/invalid/duplicate since these bugs are known and hard to fix and workaroundable!)

#4 Updated by Billiard26 about 8 years ago

  • Issue type set to Bug

#5 Updated by scientificraver about 8 years ago

Are there any plans to get the Zelda SS crash fix, discussed in issue 5682, implemented into master? OpenGL is just too slow to run Zelda in high definition on many systems.

It is just one line of code that needs to be changed.

#6 Updated by pauldacheez about 8 years ago

scientificraver: If you've got a Nvidia GPU, checking "Hacked Buffer Upload" gets you some free extra framerate. (I've pinged neobrain on IRC about this anyway.)

#7 Updated by Autoran1 almost 8 years ago

  • Status changed from New to Duplicate

This issue is nothing to do with SMG 2, pretty mach a duplicate

#8 Updated by basti1georges over 7 years ago

Hey billy !

Have you found a solution for the silent realm trials ? I tried OpenGL but it's way too slow to be playable. Old dolphin veersions (3.0-772 and older) are supposed to be working but Wii Motion Plus isn't implemented. I don't know what to do at that point and i found nothing !

#9 Updated by billy.lundevall over 7 years ago

I simply used an old version, I don't remember which one right now but I believe I mentioned the exact version earlier. I did however run in openGL because I found it to be more stable overall.

#10 Updated by basti1georges over 7 years ago

Alright, so maybe i should find a way to run it in OpenGL with a smoother config. I wish i had a more powerful PC.
Thank you.

Also available in: Atom PDF