Project

General

Profile

Emulator Issues #6338

GBA link causes immense slowdown in either VBA-M or dolphin then fails (LoZ:WW)

Added by Xv8M4g3r about 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Legend of Zelda: Wind Waker (GZLE01)

What happens?
Attempting to use the tingle tuner to connect to a gba (using VBA-M) causes either Dolphin or VBA-M to slow to a crawl. The lag is noticed in whichever of the 2 emulators was started second.
(In more recent versions of dolphin, enabling "turbo mode" in vba-m results in much smaller, but noticeable, slowdown in dolphin (if dolphin was started last). Lag in VBA-M if started last is still multiple-seconds-per-frame).
Eventually the connection fails, and dolphin continues to run as normal. VBA-M hangs.
Very rarely I get tingle start to load on the gba, it's very very slow then freezes, and WW has already informed me it has given up. I can not reliably reproduce this, and it's only happened on 3.5-367 so it's probably not much help, but at least the code is being sent to VBA-M in some form.

What did you expect to happen?
Connect successfully to VBA-M and let me use it to control tingle.

What steps will reproduce the problem?
get to the point in the game you get the tuner, tell dolphin there is a GBA connected to port 2 (or 3 or 4), open VBA-M, enable joybus to 127.0.0.1(or appropriate). Run a gba bios file in VBA-M, then use the in game tuner item.

What version of Dolphin were you using?
3.5-1387 x64. VBA-M version 1149 x86 MFC (I can't find a more recent build with GC connection support, will see if I can build one when I have time).

What version of Dolphin used to work?
Never.

What Operating System were you using and what are your hardware
specifications?
Win7 x64 i5-2500k@stock, AMD HD6870.

So, yeah, looks like it's been in this state for quite some time. If someone can help me out with where to start looking, I'd love to help tackle this. (If only so I can finally do a 100% run of the game .)


Related issues

Is duplicate of Emulator - Emulator Issues #3177: FF Crystal Chronicles - Multiplayer Mode Works Incorrectly with EmulatorFixed

History

#1 Updated by rachelbryk about 7 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF