Project

General

Profile

Emulator Issues #6458

(G95E01/GSAJ01) Multi Disc Demo (Jul 2002) - Star Fox Adventures demo issues

Added by ixtsptf about 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Do *not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images.
*

READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are here!

Have you searched the issue tracker for a similar issue?

Yes.

Game Name?

Interactive Multi Game Demo Disc July 2002
Star Fox Adventures Demo

Game ID?

G95E01 - Interactive Multi Game Demo Disc Jul. 2002
GSAJ0 - Star Fox Adventures Demo (08 2002.05.17 E3_2002_StarFox)

What went wrong?

Two notable issues:

1.) If you try and run the Star Fox Adventures demo with dual core on (with JIT core), the following errors can occur when the title screen's opening video starts to play:

a.) It either crashes Dolphin out right
b.) Game hangs with annoying buzzing sound, sometimes it looks like 
    the game has crashed but you can actually press start to continue.
c.) Backpatch error: Attempted to write to 82022bfc, FF2D97FC  
    Backpatch write - not through EAX 
    Then Dolphin crashes     

"c" prints out different addresses all the time, so it's difficult to say which addresses are actually affected. However, it's safe to say that the video that plays in the beginning is causing the issue.

2.) If you try to run the demo with dual core disabled, the previous problem will not occur. However, if you create a new game and either select the option to either play the full game, play at Ice Mountain, or play at Thorntail Hallow (http://i.imgur.com/4mVEnc7.jpg this screen), the game will fade out like normal and then throw out a "Failed to compile pixel shader!" message repeatedly.

For the pixel shader errors, please check the link at the bottom for the log files that were generated.

What did you expect to happen?

The game to work like it can in the final retail version.

What steps will reproduce the problem?

This will depend either or not you bother running the game from within the demo disc or you ripped the demo tgc file from the demo disc and converted it to a GCM. But this will assume you did the latter.

For issue #1 (make sure to have dual core enabled and JIT core as well):
1.) Start the game
2.) After the Nintendo and Rare logo screens fade out, a 3D monitor will appear to start plaything the movie. At this point, Dolphin will present one of the 3 variations I mentioned before

For issue #2 (make sure dual core is disabled now. Also make sure Use Panic Handlers is enabled so that you can see the ps errors occur one at a time):
1.) Start the game
2.) After the Nintendo and Rare logo screens fade out, the 3D monitor will start to play the THP movie like normal.
3.) Press start and the title screen will appear, press it again to create a game save
4.) After you create a game save, a screen allowing you to either choose from 3 different areas or from the beginning of the game will appear (this screen: http://i.imgur.com/4mVEnc7.jpg). Choose Ice Mountain
5.) The screen will fade out, wait a few seconds, and a series of bad ps error message will appear. If you click through the messages long enough, you'll get this to slowly appear: http://i.imgur.com/xL591eo.png - Fox should obviously not look pink and be missing parts of his model.

What version of Dolphin were you using (please test the latest version
from http://dolphin-emu.org/download first, 3.5 or 3.5-367 are not valid
tests!)?

Dolphin 3.5-1720

64 or 32 bit Dolphin?

64 bit.

What version of Dolphin used to work?

None. I checked as far back as Dolphin 3.0 and the same errors occurred. The retail US version works fine, though.

What Operating System were you using and what are your hardware
specifications?

OS: Windows 7 Home Premium SP1
GFX Card: NVidia GeForce 680 GTX
CPU: Intel 2500k @ 3.3ghz
MB: Asrock z68 extreme 3 w/ latest BIOS

64 or 32 bit Operating system?

64 bit.

Any other relevant information or links to logs:

Here's a link to a bunch of bad ps logs that were generated when I tried to play "Ice Mountain":
http://www.mediafire.com/download/ozenxw1ueffwfs5/starfox_demo_bad_ps_logs.zip

I remember Star Fox Adventures always used to have problems like these in older versions.

I know this is a pointless version of the game to acknowledge. But the game is actually a somewhat older version of the game with a few differences that people would like to explore, but with these issues it's almost impossible to play on Dolphin. The only way you can play the game is if you disable dual core and disable panic handlers. However, even though panic handlers are disabled, millions of bad ps logs are generated during a few minutes of game play that can completely fill up a hard drive easily without the user knowing.

Speaking of which, maybe it would be a good idea to have an option to disable the output of these bad ps logs file in Dolphin so that unsuspecting users who have disabled "Use Panic Handlers" aren't surprised when they slowly see their free disk space drop due to all the log files that Dolphin generates. Also would be nice to have an option to quit to Dolphin in the same error message so that users don't have to kill the process in Task Manager if they find themselves with an infinite amount of error messages they can't close out of.

But that's just a thought. I don't know if that would be time worth investing.


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by skidau about 7 years ago

Is your ISO 1,459,978,240 bytes in size? If not, please redump your demo disc again as that is the likely cause of these errors.

#2 Updated by ixtsptf about 7 years ago

Hi skidau!

I double checked the ISO. The MD5 hash is 8417046B747EC2525D61FFC632406860. I double checked with redump.org and it matches what they have on the site. The file size is the amount that you specified. I managed to extract everything from the iso, etc. And Dolphin didn't report any errors.

I also forgot to mention that I've tried all the different video backends and they all give the same bad ps error messages.

Would you like a FIFO log?

#3 Updated by ixtsptf about 6 years ago

Update!

The texture issues along with the bad ps log spam issues are fixed. I don't know which revision fixed it, but as of 4.0-1601 (6950f533aee33cbdce7ecfd5f59e3aba3836e730) the problem no longer occurs in both the DirectX and OpenGL backends.

The only issue left remaining pertains to issue of the game not launching beyond the Rareware logo with dual core enabled.

#4 Updated by ixtsptf about 6 years ago

Another update.

The hanging issues with dual core mode are still present as of 4.0-2071 (15c1250d9d3f7aa7821a142582d63f38f782f15a). However, I tested the latest dc-netplay branch build and the issues aren't present there.

I noticed that several dual core issues are being merged into issue 7143. Perhaps this one should be too? This is the only problem present right now.

#5 Updated by JMC4789 about 6 years ago

Okay, so if you're saying the hanging only happens on dualcore mode, I request you comment on the dualcore issue and say what's going on there, then I'll mark this on duplicate there. Thanks for the update!

#6 Updated by JMC4789 about 6 years ago

  • Status changed from New to Duplicate

The multi-game demo disc I have does similar things. Definitely an issue. But, I think it's related to dualcore causing GPU desyncs, as sometimes the games do load.

Also available in: Atom PDF