Project

General

Profile

Emulator Issues #6541

Mega Man Network Transmission tends to crash when FPS and VPS are far apart

Added by JMC4789 over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game: Mega Man Netowrk Transmission - GREE08

The game will crash if the video thread is what's being maxed out. Basically, on dualcore, the FPS and VPS both want to be 60, but more likely than not, if you have slowdown, the FPS will drop without the VPS dropping. If this becomes really bad during a load time, the game can hang.

What did you expect to happen instead?

What steps will reproduce the problem?
1. Dualcore on, Software Renderer
2. Attempt to load a save game
3. Admire Black Screen
4. ???
5. Profit!

This happens on every build of dolphin, I tested up to 3.5-1920. It is very rare, and didn't happen in normal play (though the music glitch did, which I believe is related.) I was not using savestates or cheats when the crash happened. Enabling GPU Sync option does not fix the problem.

Tested on a Core i5 3570K with a GTX 760 and 8GB of ram running Windows 7. Because my computer is very powerful, getting it to slowdown was tough. I was using D3D11, which helped me trigger the music glitch, but I was unable to crash the game on a hardware video backend.

My Core i7 2670 QM laptop also didn't not experience crashes on hardware back-ends, but the music glitches were slightly more common. But I was using savestates because I was stuck using keyboard. Meh, that's another issue anyway.


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by skidau over 6 years ago

Does the problem occur in Single Core mode?

Does the problem occur when the OpenAL backend is used?

#2 Updated by JMC4789 over 6 years ago

Does not happen in Single Core Mode with any audio back-end.

Happens in Dualcore even using OpenAL Audio back-end.

Under single core FPS and VPS are always the same, so it doesn't desync.

#3 Updated by parlane almost 6 years ago

  • Status changed from New to New

#4 Updated by JMC4789 over 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF