Project

General

Profile

Emulator Issues #6553

Accessing any option of "With Friends" submenu in Super Smash Bros Brawl causes FPS drop and a lot of AlphaRead warnings

Added by mbc07 about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Next
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Super Smash Bros Brawl

Game ID?
RSBE01

What went wrong?
When you enter in "Brawl", "Friend roster", "Team Multi-Man Brawl" or "Home-Run Contest" submenus in Super Smash Bros Brawl, the game suddenly drop to 1-5 FPS and a lot of "Src\PixelEngine.cpp:193 W[PE]: (r16) ALPHAREAD" errors starts popping out in Log

What did you expect to happen instead?
The FPS shouldn't drop

What steps will reproduce the problem?
1. Boot Super Smash Bros Brawl and enter in "Nintendo Wi-Fi Connection" menu
2. Answer "Yes" to the question and wait the game establish the connection. After that, you'll be in a submenu with the options "With Friends", "With Anyone" and "Options", Enter in "With friends" menu
3. A new menu (with "Brawl", "Friend roster", "Team Multi-Man Brawl" and "Home-Run Contest") will appear. Choosing any option of this menu will suddenly drop the game framerate to 1-5 FPS and a lot of AlphaRead errors will start popping out in the Log...

Dolphin 3.5 and Dolphin 3.5-367 are old versions of Dolphin that have
known issues and bugs. Have you tested with the latest version from
http://dolphin-emu.org/download ?
Yes

Which versions of Dolphin did you test on?
3.5-2175

Which version of Dolphin used to work?
Didn't find any revision that have wii-network support and doesn't have this issue

What are your PC specifications (example: Operating System, CPU and GPU)?
HP Envy dv6t-7300 CTO Quad Edition
CPU: Intel Core i7 3630QM @ 2.4GHz
GPU: nVidia GeForce GT 635M @ 2 GB GDDR3
RAM: 8 GB @ DDR3-1600

64 or 32 bit Operating System?
Windows 8 (x64)

64 or 32 bit Dolphin?
Dolphin 3.5-2175 (x64)

Any other relevant information?
This bug occur in all video backends. With OpenGL the frame drop is less aggressive (5-10 FPS), but the same problem are here too


Related issues

Is duplicate of Emulator - Emulator Issues #6572: EFB access cache needs to be moved to VideoCommonAccepted

History

#1 Updated by delroth about 5 years ago

  • Status changed from New to Accepted
  • Priority set to Normal
  • Category set to gfx
  • Milestone set to Next
  • Operating system N/A added

Definitely not 4.0 imho, we won't have the time to fix this. Not even sure how fixable it is. Does it lag that much if you disable PE logs?

#2 Updated by mbc07 about 5 years ago

Disabling the logs doesn't change anything, still cause the sudden drop from constant 60 FPS to around 1-5 FPS... How I remove the 4.0 flag from the issue title then?

#3 Updated by NeoBrainX about 5 years ago

Try checking "Skip EFB access from CPU" in the hacks tab of the graphics dialog.

#4 Updated by mbc07 about 5 years ago

Skip EFB access from CPU works. I'll add that to the wiki page...

#5 Updated by delroth about 5 years ago

With OpenGL the frame drop is less aggressive (5-10 FPS)

Praise the all mighty EFB access cache \o/

#6 Updated by NeoBrainX about 5 years ago

  • Status changed from Accepted to Invalid

Game is hitting a code path which is known to be slow.

#7 Updated by JMC4789 about 5 years ago

Even though this is a performance issue, knocking a Core i5 3570K to 0 fps is pretty impressive. And the fact it works fine in OpenGL leads me to believe it may be a fixable issue.

Wouldn't this be better labeled as wontfix?

#8 Updated by JMC4789 about 5 years ago

issue 6571 has been merged into this issue.

#9 Updated by JMC4789 about 5 years ago

issue 6571 has been merged into this issue.

#10 Updated by delroth about 5 years ago

It is a fixable issue, and it will be fixed with a VideoCommon refactoring. I'll file an issue about this.

#11 Updated by delroth about 5 years ago

  • Status changed from Invalid to Duplicate

Also available in: Atom PDF