Project

General

Profile

Emulator Issues #6705

Skies of Arcadia Legends freezing all the time

Added by abalienostats over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Skies of Arcadia Legends

Game ID?

GEAP8P

What went wrong?

The game freezes basically all the time.

What steps will reproduce the problem?

The problem is related to threading, I think. It is 100% solved if I run with the "Dual Core" option disabled.

I also had a couple of older versions of the emu to test and they all had this freezing problem. FPS go to 0, and the sound goes "PEEEEEEEEEEEEEEE".

This also happens a lot more frequently when the speed isn't maxed. So the more the CPU struggles, the more likely the freeze. Almost always saving the game to a save state was enough to produce the freeze. By recalling that same state the game would then proceed (at least for a few more seconds before freezing again).

Which versions of Dolphin did you test on?

Latest few dev releases, stable 4, and a couple of older versions.

What are your PC specifications (example: Operating System, CPU and GPU)?

Core Duo E8400

64 or 32 bit Operating System?

64

64 or 32 bit Dolphin?

64


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by abalienostats over 6 years ago

Oh, and I tried both the US and EU version to see if there were differences, but nope.

And I tried running at 1x res, since I read in another bug report that it could fix FIFO problems, but here it doesn't fix the freezing.

The freezing is related to the Dual Core option, and happens on all video setting, DX9,11, and OGL.

#2 Updated by skidau over 6 years ago

  • Status changed from New to Fixed

Fixed by r2d00c3a4f8b4.

#3 Updated by kostamarino over 6 years ago

Skidau are you sure it is fixed? This is an old issue as stated, not a latest regression. The game would become unstable especially if it didn't run at it's full normal speed, which is easy to reproduce if you play the game pressing tab, sooner rather than later it will freeze.

#4 Updated by kostamarino over 6 years ago

To the op: try the sync gpu setting, it gives much better performance in this game than what disabling dual core would give and perhaps it fixes the freezing.

#5 Updated by abalienostats over 6 years ago

I'll test this new version but nope, synch gpu in the game settings did nothing to fix the freezing.

#6 Updated by abalienostats over 6 years ago

Nope, not fixed.

For some reason the performance seems better, so the freezing happens slightly less frequently, but still happens.

Saving the game using the quickstate a few times produces the freeze consistently.

#7 Updated by skidau over 6 years ago

  • Status changed from Fixed to Accepted

Let us know if syncgpu with openAl as the audio backend fixes the random freezing for you.

#8 Updated by abalienostats over 6 years ago

That makes performance far more stuttery, and I got a freeze like 20 seconds into the game, so earlier than usual (likely because performance is worse).

As I said, the only thing that consistently seems to fix it is the Dual Core option being disabled. I think I was able to get the freezing even with the sound disabled.

#9 Updated by delroth over 6 years ago

Bad dump maybe? Check against redump.org.

#10 Updated by abalienostats over 6 years ago

Nope.

CRC-32: a8e18c76
MD4: 681c106517b78d5992ec9c3b0bcd6493
MD5: bd814992f1e39d4147c775ff8b32d022
SHA-1: 30ee1d7777fe51bcd7c4deeb867651d5b6e96e41

#11 Updated by kostamarino over 6 years ago

Try a new game without using save states. Save states are unreliable btw in general. Here sync gpu fixes it using the latest rev to be frank.

#12 Updated by abalienostats over 6 years ago

I always test without save states, saving states are just a way to trigger the freezing quickly.

#13 Updated by abalienostats about 6 years ago

Something happened here? I tested the 4.0-330 and it looks like framerate is MUCH better.

The game would be absolutely playable if it didn't freeze like 5-10 seconds. I was only able to test the introduction (that previously ran much slower) by juggling save states.

So nothing can be done to synch those damn cores?

#14 Updated by abalienostats about 6 years ago

It seems this has changed something: http://code.google.com/p/dolphin-emu/source/detail?r=b863e40677710f2d53cae8aedfe450b4215562d3

The emulator is a bit more resilient, but it still freezes. If before it was every 10 seconds, now it's every 50. Especially easy to trigger by simply trying to save state, it almost always causes a freeze.

#15 Updated by tetsuo666666 almost 6 years ago

Playing it in dc-netplay branch (https://de.dolphin-emu.org/download/list/dc-netplay/1/?cr=de) fixed this for me.
Played for a few hours without any freeze so far.

#16 Updated by JMC4789 almost 6 years ago

Dualcore Netplay Branch seems to affect a lot of games that sync GPU affects. Interesting?

#17 Updated by abalienostats almost 6 years ago

Yes, this is true. That build solves the freezes even for me.

But it's also a fair bit slower. Is it due to different code or just because it's compiled differently, or not optimized, or just a few commits behind?

If this bug was solved it would be a good idea to integrate it on the main build...

Can a dev look into this?

#18 Updated by JMC4789 almost 6 years ago

The build has a fairly low compatibility rate and a ton of other problems that will prevent it from being merged at this time.

#19 Updated by abalienostats over 5 years ago

From time to time I check if new versions improve the situation.

Nope. It freezes as usual, and the performance seems considerably worse than the version I pointed out in my Nov 8 message.

The same happens for the two Zeldas I sometime test: Twilight and Windwaker.

#20 Updated by skidau over 5 years ago

abalienostats, would you please test if turning on Dolphin movie recording prevents the game from freezing?

From the Dolphin, start Skies of Arcadia. Once the game has started, stop the game, and then from the Dolphin menu, select Emulation > Start Recording. Now you can start playing, checking if the game freezes.

#21 Updated by flavoredorange over 5 years ago

Same problem here, only happens on Direct3D and in my case it will usually recover from the freeze in a few seconds on its own, but still kind of annoying. Sometimes can take as much as 30 seconds or more but exiting fullscreen tends to make it recover if needed. Disabling dual core seemed to fix it as mentioned.

#22 Updated by JMC4789 over 5 years ago

  • Status changed from Accepted to Duplicate

This is unnecessary with the master issue. This issue isn't invalid or anything, it's just better to combine these into one issue.

Also available in: Atom PDF