Project

General

Profile

Emulator Issues #6780

Hikaru no Go 3: non-responsive to input

Added by calmcc over 6 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Controls
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name:
Hikaru no Go 3

Game ID:
GHTJA4

What went wrong?
Game does not progress. At the first text box encountered (either starting a new game, or continuing further in from a save state), or at a match screen (you can only get to this point if you try to do free mode, instead of story mode), the game does not respond to input. The game recognises all the buttons when setting up the game in the menu (i.e. going back and forth, changing options, starting the game, etc), but once the game has begun properly, it stalls. Sprites still move, so it's not a total crash, but the game doesn't accept any input & thus can't proceed.

Have checked to see if switching controls to keyboard would help progress the game, but this doesn't work. Have tried both versions (32 and 64 bit), and both have the same issue.

What did you expect to happen?
I expected the game to progress, like it does with Dolphin 3.0 (both 64 and 32-bit versions). It does not.

What steps will reproduce the problem?
Backup your own copy of this game, then check the md5 checksum. Once you've confirmed that the m5s checksum is the same as the one shown on redump.org (and thus know it is a 1:1 backup of the game), load it up in Dolphin 4.0.1 (either version). Set up your joypad. Start the game in Story Mode. You will not see the floating "A" button prompt that usually pops up after a text/dialogue piece has finished.

My settings:
Direct3D11, 800x600 fullscreen res., V-Sync on, 1x Native res, no Anti-Aliasing, 1x Anisotropic filtering, Scaled EFB Copy checked, EFB copies Texture checked, DualCore/Idle Skipping checked, Framelimit off, Force console as NTSC-J.

Dolphin Version:
Dolphin 4.0.1 Revision d8fd449745a720efecb447a560ac9dde5e37180d

Did the game ever work correctly?
Yes; worked fine with Dolphin 3.0. Broken with Dolphin 3.5 (both 64-bit and 32-bit), and continues to be broken with Dolphin 4.0.1 (both 64-bit and 32-bit)

Operating System and version:
Windows 7 Home Premium 64-bit

Any other relevant information:
Intel Core i5 CPU 2.4GHz M 520 @ 2.40GHz
ATi Mobility Radeon HD 5470
4Gb RAM


Related issues

Is duplicate of Emulator - Emulator Issues #10544: Streaming Audio Issues Across Many GameCube TitlesFixed

History

#1 Updated by JMC4789 over 6 years ago

I'm sorry I haven't responded before this. Since most people will not have the game, could you please find the exact build that is causing your problem? That's the only way we could get enough information to confirm/fix this issue. Thanks.

#2 Updated by parlane over 6 years ago

  • Status changed from New to New

#3 Updated by peterstandard about 6 years ago

I have this same issue with the x64 version of Dolphin 4.0.2 stable and 4.0-1763 development version. The "A" button never appears so it's essentially softlocked at the first text box. The attached screenshot shows as far as the game will progress with Dolphins 4.0 and higher.

Dolphin 3.5 x64 and earlier does not have this issue. This video shows the expected behavior: http://youtu.be/HqWAanOhDW0?t=50s

#4 Updated by JMC4789 about 6 years ago

Thanks for the information, can you find the exact build this behavior begins? That way we can accept this issue and assign it to someone.

#5 Updated by peterstandard about 6 years ago

Works:
Dolphin-win-x64-v3.0-917 master branch, revision 78ff8a769c5401facf060c9c7d92a8347076f353 compiled Dec 24 2012 @ 13:47:19
Dolphin-3.5-x64 master branch, revision 4798524b754bc4816c0d8525473e84f3dba28b3a compiled Dec 24, 2012 @ 21:11:27

Doesn't work:
Dolphin-win-x64-v3.5-78 master branch, revision ba348c29d7055314957d36d80fd515a5f4bb9a31 compiled Dec 26, 2012 @ 15:11:09
Dolphin-win-x64-v3.5-80
Dolphin-win-x64-v3.5-122
Dolphin-win-x64-v3.5-141
Dolphin-win-x64-v3.5-144
Dolphin-win-x64-v3.5-250
Dolphin-win-x64-v3.5-367 master branch, revision ca46a34dde49347f320e8cb9cdc8df7a022657 compiled Feb 2, 2013 @ 22:32:45

I tracked it this far: https://github.com/dolphin-emu/dolphin/commits/master?page=110
It must be one of the 7 commits at the bottom, from "Merge branch 'new-ax-hle'" and below. The first thing on the next page is the 3.5 stable, which does work. I don't know how to compile these on windows, so I'm afraid that's as narrow as I can get it. Is there anything else I can do to help you figure this out?

#6 Updated by JMC4789 over 5 years ago

Can you try LLE audio?

#7 Updated by JMC4789 over 5 years ago

There have been quite a few audio tweaks, please try LLE audio and latest master on HLE please.

#8 Updated by calmcc over 5 years ago

https://code.google.com/p/dolphin-emu/issues/detail?id=5908

I had raised this before, almost 2 years ago, in January 2013. At that time, JMC4789 threw the issue back to me, and waited for a response from me before opening the ticket again. In my experience, that's not the way to handle legitimate bug reports, so I decided to let it marinate for a year, before posting another ticket (this one).

Again, no real answers have been given.

As far as I can tell, this has nothing to do with audio emulation, and everything to do with changes to the way the 4.0 build deals with emulation, compared to previous builds.

4.0 fixed a lot of compatibility, but it broke a lot of compatibility, too. One of the games that was compatible, but now is not, is Hikaru no Go 3.

Concerning sound, there are 3 options: DSP HLE emulation (fast), DSP LLE recompiler, and DSP LLE interpreter (slow). I have tried all 3 settings, but (of course), the graphical compatibility issue remained: I could not progress because the 'A' button prompt never appears.

The system I tried this on recently is far more capable of handling games, so I'm disappointed that this 2 year old issue has still not received attention, or been given plausible explanations as to why compatibility was broken.

Build:
Dolphin 4.0 x64, Revision c25be031fc1031d795157d8344b87b7841145197

Specs:
OS: Windows 8.1 Pro
CPU: i5-4690K @ 4.4 Ghz
GFX: AMD Radeon HD 7900 series (MSi R9 280 Gaming 3Gb)
RAM: 8Gb

If development on this emulator has stalled (last build was released over a year ago), please remove Hikaru no Go 3 from the 'compatible' list on the wiki, and place it in the 'broken' list. If the development team has no idea how to fix the issue, please just say "we don't know why it won't work now".

TIA.

#9 Updated by skidau over 5 years ago

  • Status changed from New to Accepted
  • Category set to controls

This appears to be a memcard timing issue (see issue 7481).

#10 Updated by psxlover over 5 years ago

"I had raised this before, almost 2 years ago, in January 2013. At that time, JMC4789 threw the issue back to me, and waited for a response from me before opening the ticket again. In my experience, that's not the way to handle legitimate bug reports"
What's wrong with that? You can't expect them to have every game. You already have the game and you can download the latest build (it's less than 5mb). It wouldn't take you more than 5 minutes to test and respond.
Btw he was expecting you to post in that bug report and not raise a new one.

"If development on this emulator has stalled (last build was released over a year ago)"
? Last build was an hour ago (https://dolphin-emu.org/download/list/master/1/). If you are watching the code development has moved to github (https://github.com/dolphin-emu/dolphin)

"please remove Hikaru no Go 3 from the 'compatible' list on the wiki"
It's a wiki, you can change it yourself. Also it's compatibility is 3 stars which means: "Starts: Starts, maybe even plays well, but crashes or major graphical/audio glitches"

"This appears to be a memcard timing issue (see issue 7481)."
Why would it be a memcard timing issue? The issue you linked doesn't mention anything about unresponsiveness in games, plus the issue appears after the game has finished saving, has asked the user for input, has loaded a new scene, shown text and is about to ask for input again.

#11 Updated by skidau over 5 years ago

psxlover, it's just a guess, based on "New AX-HLE" being the change where the problem first started. New AX-HLE is a DSP change. The DSP in a GameCube is responsible for not only audio, but GBA and memcard management as well. In Dolphin 3.5, DSP HLE works with this game, but DSP LLE does not. The major difference between DSP HLE and DSP LLE (in terms of outward behaviour) is timing. Therefore, the guess is that there is a timing issue in the memcard emulation where the timing difference between DSP HLE and DSP LLE is enough to break the game.

As this is a guess which might be wrong, it could still be an audio problem, but based on what I know of Dolphin's DSP emulation, it would be unlikely that this is the case.

Note that the game does not hang or crash. The animation continues but the "Press the A button" prompt does not appear as if the game is waiting for something.

#12 Updated by Tenchi almost 3 years ago

Can I bump this issue?

Dolphin 5.0 as well as the latest build still do not run this game correctly. The game stalls after the first bubble of dialogue, when the prompt for skipping to the next dialogue does not appear.

I have tried 3.5 and noticed that this issue is not present. After reading some comments here about audio, I noticed that for all dialogues, the prompt appears at the precise instant when the spoken line of audio ends, so it might be related.

I would love to be able to play this game, unfortunately the cell shading is broken on 3.5 and ruins the whole mood.

Hoping someone could solve this!

#13 Updated by JMC4789 over 2 years ago

I finally have this game and have two conclusions:

1: This is an audio timing issue
2: LLE audio never worked.

While the first conclusion may not be true, I'm pretty sure the second one is after testing it myself. I have a few things to try on this.

#14 Updated by JMC4789 over 2 years ago

So, after messing with the game for a lot longer.

Old-HLE is changing the behavior of the game in a way that it is able to know when audio stops playing. I can tell this because if you watch on console + old-HLE, character's mouths will stop moving once dialogue is done. If you watch in Dolphin, their mouths will keep moving until the animation loop ends. This leads me to believe the game is unable to tell when an audio has stopped playing, but, I'm unable to figure out why. It doesn't seem to be a timing issue because you can completely mess up the timings in old-HLE and it'll work. Run the emulator at 8x speed and the audio at 1x speed and it'll hit late. Run the audio way too fast and the emulator slow? It'll hit early.

I can't surmise why it's happening, but those were the behaviors I was able to isolate.

#15 Updated by JMC4789 over 2 years ago

  • Status changed from Accepted to Duplicate

Combining into a new issue with other issues stemming from the same bug.

#16 Updated by JMC4789 over 2 years ago

Also available in: Atom PDF