Project

General

Profile

Emulator Issues #6786

Sonic Riders Zero Gravity Afterburst Effect Sticks on Screen until changing Texture Cache Setting

Added by JMC4789 about 8 years ago. Updated 7 months ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game: Sonic Riders Zero Gravity

What went wrong?

After doing a gravity boost (this game's main gimmick) some of the effect sticks on the screen instead of clearing properly.

What steps will reproduce the problem?
[Don't assume we have played the game and know its level names. Be as
detailed as possible.]
1. Start up any race in the game on either Graphics Backend. Can be on EFB2Ram or EFB2Tex and any cache setting
2. Do a gravity boost by hitting B or R or L (R and L must be held) assuming you're using a GameCube controller. Don't use the Wiimote controls.
3. Change the Texture Cache setting to make the screen return to normal

Which versions of Dolphin did you test on?

3.5, 4.0, 4.0-298 and Tev_Fixes_New branch

Which version of Dolphin used to work?

None

What are your PC specifications (example: Operating System, CPU and GPU)?

Core i5 3570K, GTX 760, 8GB of Ram, Windows 7 64 bit, used 64bit Dolphin

Doesn't seem to work well in fifo, but I do have screenshots. Please swap back and forth between the screens because the effect is very subtle. I tried circling the spots but that just made them harder to see. Flipping back and forth will make it very apparent what's wrong

Effect left on: http://i.imgur.com/jNAUSfy.jpg
How it's supposed to look: http://i.imgur.com/8rDON2L.jpg

History

#1 Updated by kostamarino about 8 years ago

Hashless doesn't seem to have this issue (i used efb to ram while testing).

#2 Updated by JMC4789 about 8 years ago

  • Status changed from New to Accepted

Very nice catch, I would have never thought of checking that. Since someone else seems to have confirmed it, accepting the issue.

#3 Updated by a41pizza about 7 years ago

Seeing how the hashless branch is super old at this point, I tested this using the latest master (4.0-3950 as of writing) and Iriisuka branch (316a4c5), with and without EFB to RAM.
The ghosting is still there.
-KHg8m3r

#4 Updated by mimimi about 7 years ago

This doesn't make much sense. Changing the texture cache setting should result in all textures gettting different caches than before, resulting in replacing all textures in the cache. So basically it's clears/resets the cache. This should only be required if dolphin generates the same hash for 2 different textures. Which should not happen with the safe texture cache option.

So i hope either safe texture caching fixes the problem. Or changing the graphics settings in general fixes the problem, and it's not actually texture cache related, but something else entirely.

#5 Updated by a41pizza about 7 years ago

I'm not switching from EFB from Texture to RAM while playing, I'm setting it to Texture or RAM, and then staying in that state while playing.

I have safe texture cache always on, and it still ghosts.

I'll try some other combos of settings to see if I can make it disappear.

#6 Updated by r543 about 6 years ago

I've found something interesting about this issue:
It doesn't happen in the very old Dolphin-win-x86-r7716 build with Direct 3D9(default settings without any changes), not sure about the other rendners but I think Direct 3D11 works too. Haven't had time to mess around with the old builds, so I can't tell if it happens with any builds before or after that, according to a different user it only works with this build.

While playing in 4.0.2 I've noticed that the effects appear even when not doing gravity moves, maybe it automatically appears whne doing tricks/going fast/when other characters do that move, but it sticks on the screen after that.

In the latest Development versions(tried 8258 & 8246, both x64) the game light goes very dark after you cross the starting line(can be seen very well in the first level of the game), I'm guessing that this effect has something to do with the gravity moves and might be linked to this.

#7 Updated by ZephyrSurfer 7 months ago

The visual issue is no longer present. I'm not sure if the issue is fixed correctly or just the symptoms are removed though.

Started in
3.0-710 -> https://github.com/dolphin-emu/dolphin/commit/29e21026e9bf790a21f5a398d151e683196ade1e

No longer present in
5.0-1490 -> https://dolphin-emu.org/download/dev/01047319f82e6ee50e89ed8045cf713ee3ae0a56/

#8 Updated by JMC4789 7 months ago

That looks like a legitimate fix for it, but I don't know for sure.

#9 Updated by ZephyrSurfer 7 months ago

I am assuming these things should get cleared/invalidated. These trails remain on screen even after selecting to restart a race (before 5.0-1490).

Them being the wrong colour was maybe just a different issue that made this one visible.

Also available in: Atom PDF