Project

General

Profile

Emulator Issues #6802

Skyward Sword - Unnecessary DOF rendering

Added by greatbrian2 over 7 years ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
The Legend of Zelda: Skyward Sword

Game ID?
SOUE01, SOUJ01

What went wrong?
Unnecessary DOF effect in some scenes.

What did you expect to happen instead?
There should be no DOF effect at all.

What steps will reproduce the problem?
[Don't assume we have played the game and know its level names. Be as
detailed as possible.]
Run the game.

Dolphin 3.5 and Dolphin 3.5-367 are old versions of Dolphin that have
known issues and bugs. Have you tested with the latest version from
http://dolphin-emu.org/download ?

Obviously. Tried every setting.

Which versions of Dolphin did you test on?
4.0.1

Which version of Dolphin used to work?
None.

What are your PC specifications (example: Operating System, CPU and GPU)?
i7-860 2.8 GHz, Windows 7 32-bit, HD Radeon 6970

Any other relevant information (e.g. logs, screenshots, configuration
files)

Pic 1
Emulator: http://min.us/lmX8fbxbQ5YOn
Wii: n/a

Pic 2
Emulator: http://min.us/l4ZyupfzBKnh5
Wii: http://min.us/lbneMYwacfAzwh

Pic 3
Emulator: http://min.us/lb8WGdP6LN6st
Wii: http://min.us/lbvcjdPT2ey2h7

Pic 4
Emulator: http://min.us/lsEpN93dHZKl
Wii: http://min.us/lEzebPhRFN4sk

These are just select samples. The defect occurs throughout the game. Please fix ASAP.

History

#1 Updated by MayImilae over 7 years ago

  • Category set to gfx

Try the latest development version. Also, what is your backend and settings?

#2 Updated by greatbrian2 over 7 years ago

Sorry, I just discovered something strange. Disabling ignore format changes appear to fix the problem. I'll test again tonight. Got stuff to do right now.

#3 Updated by MayImilae over 7 years ago

  • Status changed from New to Accepted

Hmm, that is curious. Reproduce it. It appears only in very few specific places, and not in normal gameplay, but it's really weird.

Here is a fifolog of one of the scenes he mentioned in screenshots. I played it in 4.0-265 with OpenGL, efb to texture, ignore format changes off, and all the right things, and it still shows up.

http://www.mediafire.com/?sg8hb4k3d78b5qb

I'll do some revisions testing on this and report back. I don't remember this when I played through it.

#4 Updated by greatbrian2 over 7 years ago

Disabling ignore format changes only partially fix #4 (old man still looks a tad blurry), but still, I think the DOF is broken. So far the issue only occurs during cutscenes. Also, disabling ignore format changes is required to make the other textures visible (D3D backend). Not disabling it will cause some textures (i.e. plants on walls in houses, vines) to not appear at all.

#1, #2, #3, etc. still produces blur regardless of settings.

P.S. I just started playing this on emulator, so there is a possibility that there are more defects on the way.

#5 Updated by NeoBrainX over 7 years ago

What do you mean with "Disabling ignore format changes "? You mean, uncheck the checkbox?

@ MaJoR: If that's the case, why did you not close this thread instead?

#6 Updated by MayImilae over 7 years ago

neobrain

The problem is not fixed by unchecking "Ignore format changes". There is currently no way around it besides disabling EFB copies outright. Even software does it (with EFB to Ram style glitches that liter this game). Yea, EFB to Texture is more accurate with Skyward, EFB to Ram shows tons of errors. Just try it on that fifolog. EFB to Ram may be tie-dye hell, even it still has the blur.

Fortunately, this bug appears to only occur in select places, like cinematic close ups. The fifolog I provided coinsides with one of his emulator/wii comparison screenshots, so we already know what hardware looks like for that fifolog. I.e. not blurred all to hell.

#7 Updated by kostamarino over 7 years ago

Actually if you look at pic 2 there is a depth of field effect in the background with wii, just not on the character. It seems to be a depth issue with the effect in dolphin.

#8 Updated by JMC4789 over 7 years ago

Fixed in the Tev_Fixes_New branch

#9 Updated by JMC4789 over 7 years ago

Can someone confirm it's fixed in all areas that have this issue. The example image I was given looks fine, but I'm not very familiar with this game. Thanks!

#10 Updated by greatbrian2 over 7 years ago

I will test it tomorrow night. However, one of my friends told me the fix didn't work.

#11 Updated by phire over 7 years ago

Make sure you test with EFB2ram enabled.

#12 Updated by phire over 7 years ago

And with EFB2tex too, I've been getting conflicting reports about SS working with/without EFB2ram.

#13 Updated by greatbrian2 over 7 years ago

Just tested it with EFB to RAM. The fix DID NOT work. The results are the same as before.

#14 Updated by JMC4789 over 7 years ago

  • Status changed from Accepted to Accepted

Can you test that it's happening on the Tev_Fixes_New branch as well? https://dolphin-emu.org/download/list/tev_fixes_new/1/

I don't play on console, so it's very possible that I messed this up somehow. Reopening.

#15 Updated by greatbrian2 over 7 years ago

Nothing. Same results.

#16 Updated by JMC4789 over 6 years ago

Can someone recheck this issue now? 4.0-2626 may have fixed it.

#17 Updated by kostamarino over 6 years ago

Nope, it is still there.

#18 Updated by kostamarino over 6 years ago

Oops sorry, i meant to answer for issue 7478, this issue might be fixed.

#19 Updated by JMC4789 over 6 years ago

This isn't fixed by this still.

Also available in: Atom PDF