Project

General

Profile

Emulator Issues #6833

Blaster Master: Overdrive NTSC Visible Background Tile Edges

Added by kolano almost 6 years ago. Updated 5 months ago.

Status:
Invalid
Priority:
Low
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!

Game Name?
Blaster Master: Overdrive

Game ID?
W2MEBB

What went wrong?
Gaps appear at edges of background tiles. This only seems to occur with the NA version.

What did you expect to happen instead?
Images to be rendered without gaps, as seen with PAL version.

What steps will reproduce the problem?
[Don't assume we have played the game and know its level names. Be as
detailed as possible.]
1.Start a new game, gaps are clearly visible on initial screen.

Dolphin 3.5 and Dolphin 3.5-367 are old versions of Dolphin that have
known issues and bugs. Have you tested with the latest version from
http://dolphin-emu.org/download ?

Which versions of Dolphin did you test on?
4.0, and a few dev releases up to 4.0-427

Which version of Dolphin used to work?
None, this has been a long standing issue since the 3.x days.

What are your PC specifications (example: Operating System, CPU and GPU)?
Windows 7

64 or 32 bit Operating System?
x64

64 or 32 bit Dolphin?
x64

Any other relevant information (e.g. logs, screenshots, configuration
files)
https://wiki.dolphin-emu.org/index.php?title=File:Blaster_Master-Overdrive_Sprite_Edges.jpg

History

#1 Updated by skidau almost 6 years ago

Internal Resolution settings of whole multiples should fix this. Are you using a whole multiple IR setting (e.g. 1x, 2x, 3x)?

#2 Updated by kolano almost 6 years ago

I'm using the auto setting, so it should be an even multiple.

#3 Updated by kolano almost 6 years ago

Issue seems to occur with any "Internal Resolution" setting higher than 1x.

#4 Updated by JMC4789 almost 6 years ago

This happens on a lot of games, I'm not sure it's a bug with Dolphin though, simply an effect of raising the internal resolution to something it's not meant to be.

#5 Updated by parlane almost 6 years ago

  • Status changed from New to New

#6 Updated by JMC4789 over 5 years ago

  • Category set to gfx

Could we get a graphics guy to confirm if this is an issue or invalid/wontfix?

#7 Updated by JMC4789 over 5 years ago

I checked it out. The PAL version doesn't care what internal resolution you run at, while the U.S. version does. Could it be some kind of rounding error in Dolphin?

#8 Updated by crazysheep17 about 5 years ago

Still exists on 4-2741.

#9 Updated by JMC4789 about 5 years ago

  • Status changed from New to Questionable
  • Priority set to Low

#10 Updated by JMC4789 over 4 years ago

Umm, I see some defects at 1x IR in latest master? Can someone confirm this; look just above the spike pit in the first area.

#11 Updated by kolano over 4 years ago

So, yes, in 4.0-5823 I see a defect above the spike pit in the first screen. A light gray line that seems like it shouldn't be there.

I tried to reference some let's plays off of YouTube, many of which seem to show the same defect. Unfortunately it's not clear which may be using Dolphin to play, I'm guessing most of them are. There is at least this this one...
https://www.youtube.com/watch?list=PLTrGf4JA0WlPC8RWo813ujTwcuOU5pMCq&v=6XRcow7xn2E&feature=player_detailpage#t=68
...which doesn't appear to be using Dolphin and also doesn't show the defect.

#12 Updated by JMC4789 over 4 years ago

  • Status changed from Questionable to Accepted

Moving to accepted as there are minor defects even at 1x IR.

#13 Updated by kolano about 3 years ago

Adding that I think this same issue may effect Muramasa: The Demon Blade, though I think I've only tested the NA version.

#14 Updated by kolano almost 2 years ago

Other effected titles:
Hollywood Squares
The Price Is Right 2010 Edition
Press Your Luck 2010 Edition

#17 Updated by iwubcode almost 2 years ago

kolano wrote:

Other effected titles:
Hollywood Squares
The Price Is Right 2010 Edition
Press Your Luck 2010 Edition

Yes this was also captured in #10401 , it seems like a bug in texture uvs being off? In addition to all those titles mentioned, I wonder if this is the cause for De Blob as well?

#19 Updated by kolano over 1 year ago

Also:
Sexy Poker

#20 Updated by kolano over 1 year ago

Seems this effects some GameCube titles as well. It seems to be occuring in Sonic Adventure 2 Battle.

#21 Updated by JMC4789 over 1 year ago

  • Status changed from Accepted to Invalid

This particular game has those same tile edges on console. The Sexy Poker bug is at least valid, so, I think I can close this.

#22 Updated by kolano over 1 year ago

I question this being invalid. There is clear screen capture evidence of it being present. Though it's been claimed the Blaster Master tile edges are visible on the console, these issues effect a wide array of other titles too, particularly if >1x IR is used.

#23 Updated by kolano over 1 year ago

Hollywood Squares
Muramasa: The Demon Blade
Press Your Luck 2010 Edition
The Price Is Right 2010 Edition
Super Swing Golf

...likely numerous others where screenshots have not been captured

#24 Updated by dangerism 5 months ago

It's been some time, and as I'm still experimenting with texture pack development for this game, I'm challenging the status of this issue being invalid as well, as the game has no issues with texture seams in the original and when using the original textures at > 1xIR.

I'm not saying it's a bug, because as people have put it it's a normal thing that happens when you upscale the original texture, but I'm hoping there's at least some devs looking into a workaround to help mitigate its effect. I know it's not caused by poor texture preparation, because I've tried upscaling the original textures 4x using nearest neighbour, and the seams are still there.

#25 Updated by JMC4789 5 months ago

Higher resolutions can uncover pixel inaccuracy issues.

Unless we want to fill the emulator with pixel offset hacks, this isn't going to get fixed. We already have one.

Also available in: Atom PDF