Project

General

Profile

Emulator Issues #6837

Sonic Colors white box graphical glitch

Added by a41pizza over 7 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!

Game Name?
-Sonic Colors

Game ID?
-SNCE8P

What went wrong?
-At the start screen, there is a white box on the bottom middle-left of the screen. At the level choosing screen, your pointer is surrounded by a smaller version of said white box.

What did you expect to happen instead?
-No white box. It is 100% opaque and can't be seen through.

What steps will reproduce the problem?
[Don't assume we have played the game and know its level names. Be as
detailed as possible.]
1. Run the game. It's always present

Dolphin 3.5 and Dolphin 3.5-367 are old versions of Dolphin that have
known issues and bugs. Have you tested with the latest version from
http://dolphin-emu.org/download ?
-Yes

Which versions of Dolphin did you test on?
4.0-433, 433, 427, 414, 406, 404, 399, 393, 381,

Which version of Dolphin used to work?
-Last works in 4.0-399, broken since 4.0-404

What are your PC specifications (example: Operating System, CPU and GPU)?
Windows 7 Ultimate x64
i7-4700MQ
Nvidia GTX 770M
8GB 1600mhz RAM

64 or 32 bit Operating System?
64

64 or 32 bit Dolphin?
Both

Any other relevant information (e.g. logs, screenshots, configuration
files)

-This problem showed up a while ago in 4.0-325 and dissapeared in 4.0-356 (the first windows build since 4.0-330), so something in-between there fixed it.

History

#1 Updated by MayImilae over 7 years ago

  • Category set to gfx

Screenshots? Fifolog? There isn't any visual references here. Fifolog is preferred, but at least upload screenshots.

#2 Updated by a41pizza over 7 years ago

http://imgur.com/PQyUe0H
http://imgur.com/dUtZwyQ,EIucxaU

Here's some screenshots. The second link has two pictures. Where can I upload a .dff fifolog to?

#3 Updated by pauldacheez over 7 years ago

Compressing it and uploading it here should be fine, though min.us or another host would be preferable.

Make sure to keep the FIFO log to just a few frames. I've never seen neobrain ask for more than ten, and he usually asks for only two or three.

#4 Updated by a41pizza over 7 years ago

Min.us isn't letting me upload.....
Oh well, I zipped them up:

#6 Updated by a41pizza over 7 years ago

Yeah, but I'm not sure if that's actually the issue, or if it just broke an old fix. I noted in the report that this issue had popped up before in 4.0-325, but it dissapeared somewhere in between 4.0-330 and 4.0-356

#7 Updated by Xtreme2damax over 7 years ago

Any developer working on fixing this or will revert the revision responsible for this issue? It appears other games are affected besides this game according to other issue reports.

#8 Updated by JMC4789 over 7 years ago

Xtreme2damax: It's not that simple. Apparently, PPC_FP didn't actually cause the break, as much as it dug up other problems in dolphin. Reverting it breaks a ton of things and fixes tons of others.

This is a complex problem that has to be handled carefully. Trust me, a lot of the games I play are affected by this, but the best thing to do is show patience while they figure out a proper way to fix it. I hope this explains what's going on.

#9 Updated by JMC4789 over 7 years ago

  • Status changed from New to Accepted

If it makes you feel better, I'll also accept this. Assuming the game runs in JITIL (no guarantee) you could probably play it in JITIL for the time being.

I pretty much think all issues related to this bug will be merged eventually.

#10 Updated by Xtreme2damax over 7 years ago

I see, I didn't know that so thanks for explaining.

Off topic: Suddenly I am having to enter recaptcha's when leaving comments, very annoying.

#11 Updated by Autoran1 over 7 years ago

  • Status changed from Accepted to Fixed

Confirm this issue is existed for me on 6xx's builds, but now i'm on master 720 and it's fixed

Also available in: Atom PDF