Project

General

Profile

Emulator Issues #6897

Swingerz Golf glitches minor graphical flickers under certain settings

Added by JMC4789 about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Swingerz Golf

Game ID?

GWGE4F

What's the problem? Describe what went wrong in few words.

When using certain settings, parts of the character (hands and hair usually) would flicker during certain holes

What did you expect to happen instead?

Normally I would expect faster settings to give problems, but here setting the texture cache to safe was one of the culprits. I expect the Texture Cache being set to safe a safe option.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]

  1. Go into graphics settings. In hacks, either set "EFB2RAM" and Texture Cache fast or "EFB2Texture" and texture cache safe. These two combinations are known to have the glitch.
  2. Start up this mediocre golf game
  3. Mash through the menus, select the girl, she has longer hair, easier to see
  4. Play through a few holes, eventually before a shot her hair/hands will be flickering wildly

Strangely enough, EFB2Texture + Texture Cache Fast works just fine. That's what bothers me about this glitch. As well, it occurs in both D3D and OpenGL.

Even more annoyingly, the glitch WILL STOP during Fifo-recordings, and then as soon as you're done recording the fifo, it will continue on, as if taunting you.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

r4d1f113ab15c051368d4de9c50c0f4e8188f25f1 and rcf9d812233

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

I tried out 4.0 and it was still happening, really didn't feel like trying 3.5 or older due to them having tons of other problems.

When testing on console, I discovered that the characters hair/hands are not animated in any way around the club. So this isn't like some kind of half working/broken animation; it simply shouldn't be happening.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Core i5 3570K, Geforce GTX 760, Windows 7 64 bit.

Are you using the 32 or the 64 bit version of Dolphin?

64bit

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Even though fifo-logs are useless for this, maybe seeing what it's doing can assist in tracking down what's wrong. I repeat: YOU WILL NOT SEE THE GLITCH IN THE FIFOLOG. https://dl.dropboxusercontent.com/u/484730/SwingerzHairFlicker.7z

-Screenshots-
http://i.imgur.com/tbokv6n.jpg
http://i.imgur.com/dlfIORD.jpg
http://i.imgur.com/Pl1IQtC.jpg
http://i.imgur.com/xLNwc3u.jpg


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by parlane almost 6 years ago

  • Status changed from New to New

#2 Updated by JMC4789 almost 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF