Project

General

Profile

Emulator Issues #6907

Tales of Symphonia random crashes

Added by LordRaiven24 about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name: Tales of Symphonia
Game ID: (I have no idea)

The problem:
The game runs absolutely perfectly on both high and low quality. Perfectly being with no lagg, sound crashes or frame skips. Yet after playing a little while the game crashes sometimes. Usually the crashes happen when in 'field-mode' (as shown in the screenshot). This mode might be more demanding for the emulator, but it still runs smoothly.
I do notice a small sound change before the crash but its very faint. It's difficult to describe.

I expected the logg to show some kind of error but I only see this sometimes: "Warnig: iCalcStcPnt1 ArgStcPnt 0". The emulator doesn't crash when it prints this message, but it's worth mentioning I suppose.

Version: As shown in the printscreen this was done on version 4.0.
Also I'm using the 64 bit version, which is supported by my PC.

Log Screenshot: http://i.imgur.com/xyD4IcQ.png

I hope this helps!


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by pauldacheez about 6 years ago

As is routine with this kind of issue, can you verify that you don't have a bad dump of the game? Check the file's MD5 hash with a tool like WinMD5 and compare it to the one on redump.org. http://redump.org/disc/1279/ http://redump.org/disc/1280/

...Also, wait, what, why do you only have one of the discs? It's a two-disc game, you're gonna need that other disc at some point.

#2 Updated by delroth about 6 years ago

Use 4.0.2 and try again.

#3 Updated by LordRaiven24 about 6 years ago

Hmm Ive been using the experimental compiler and OpenGL for a few hours, no crashes yet

#4 Updated by JMC4789 about 6 years ago

  • Status changed from New to Questionable

I played this a little bit an was unable to produce any crashes in moderately up to date dev builds. Will update as I go back and play this game more.

#5 Updated by JMC4789 about 6 years ago

I'm still not able to produce a crash, even in JIT. Are you in long range mode or just traveling?

#6 Updated by JMC4789 almost 6 years ago

  • Status changed from Questionable to Duplicate

Since the OP has disappeared and I found a way to trigger a crash at any point, I'm going to merge this into my new issue.

Also available in: Atom PDF