Project

General

Profile

Emulator Issues #6911

Wii Emulation Monster Hunter Tri Character Creation Can't Use Custom Colors

Added by nvafes814 about 6 years ago.

Status:
Won't fix
Priority:
Low
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Monster Hunter 3 Tri

Game ID?
RMHE08

What's the problem? Describe what went wrong in few words.
Basically, at the start of the game in character creation, you can either select default colors, or use a color pallet to select specific colors in different hues and brightness values, however when used it only makes the color black.

What did you expect to happen instead?
I expected it to just chose the specific color I wanted.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Start the game and begin the normal game mode, top option at the main menu.
2. Then chose an empty file and create a new game
3. In character creation afterwards, go to any section where you edit the color of a character, not counting skin color, and select the box which gives you the generic color rainbow for choosing different specific color hues and the such.
4. Attempt to choose a color, it should turn black.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
I tested on Dolphin 4.0 and Dolphin 3.0-757(hashless). Please note that Dolphin 4.0 also has a brightness problem making the character creation area very bright.

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
3.0-757 (hashless) fixed the brightness, however the color pallet problem still occurs.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
OS: Windows 7 64 bit
CPU: AMD Phenom II X4 960T Processor (4CPUs) 3.00GHz
GPU: Nvidia GeForce 9800GTX/9800GTX+

Are you using the 32 or the 64 bit version of Dolphin?
64 bit

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
http://img202.imageshack.us/img202/5320/jyfa.png

History

#1 Updated by skidau about 6 years ago

In Dolphin 4.0, have you tried all hw video backends (OGL, D3D11, D3D9)? Same results in all?

#2 Updated by JMC4789 about 6 years ago

  • Status changed from New to Accepted
  • Priority set to Low
  • Easy set to Yes

This is an INI issue.

For some stupid reason (likely speed issues) skip EFB Access is enabled via the INI file.

On D3D it causes severe slowdown in the character screen to turn "off" skip EFB Access from CPU. But in OpenGL it's fine, and you will get your colors to show up. I'm going to accept this on the grounds that the INI should NOT EVER have a hack set that disables an in-game feature from working.

#3 Updated by JMC4789 about 6 years ago

It was brought to my attention by Delroth that the reason OGL doesn't slowdown is because it doesn't emulate EFB Pokes.

For right now, this is up in the air, if OGL implements it in the future and the game becomes unplayable with it on, it may be a case where the player needs to enable it just to set their color and then turn it off past that point.

Not a very good situation to be in regardless. Whether this is changed or not should be up to people that aren't me.

#4 Updated by nvafes814 about 6 years ago

skidau
Yes it is a problem with every graphics backend, OGL, D3D11 and D3D9 do not show up the colors.
@JMC
Turning off/on EFB access didn't solve anything in any graphics of the graphics settings/backends, even on the hashless and 4.0 versions of Dolphin.

#5 Updated by JMC4789 about 6 years ago

I tested it, if you turn "off" skip EFB access while the game is running, it will work, even in 4.0

#6 Updated by JMC4789 about 6 years ago

-Proof that I know what I'm doing-

http://imgur.com/a/26kBD

#7 Updated by kostamarino about 6 years ago

If i remember correctly there was an optimization for opengl that made this work somewhere properly speed wise with it on when using opengl.

http://code.google.com/p/dolphin-emu/source/detail?r=1e558aedeb0bff49645ea41be774f0789de4c6a8

#8 Updated by nvafes814 about 6 years ago

@JMC
Ah, thought you meant to turn off skip EFB access while the game wasn't running, as it said it could cause issues to open up the graphics settings while the game was running. Got it to work, thanks.

#9 Updated by JMC4789 about 6 years ago

  • Easy changed from Yes to No
  • Category set to gfx

Totally not sure what to do with this issue any more. It only works well in OpenGL due to an unemulated feature. I guess this just stays around until there's a proper solution.

Removing the easy tag because that was an poorly thought out plan of action.

#10 Updated by JMC4789 almost 6 years ago

Honestly I think this needs a Wiki note and to be closed now that OpenGL is getting the proper emulation. This is either fixed or wontfix at this point.

#11 Updated by JMC4789 almost 6 years ago

  • Status changed from Accepted to Won't fix

This is moving to wontfix for now. I'll probably make an issue report saying that EFB Pokes are stupidly slow. Custom colors work, and now that OGL has EFB Pokes, it's slow too.

wontfix... for now.

Also available in: Atom PDF