Project

General

Profile

Emulator Issues #6933

Phantasy Star Online 1 & 2 Plus on GameCube acts like it's being played on a Wii

Added by JMC4789 over 7 years ago.

Status:
Questionable
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Phantasy Star Online 1&2 Plus

Game ID?

GPOE8P

What's the problem? Describe what went wrong in few words.

When it asks you to set the calendar/time, and you hit yes, the game hangs. This is actually accurate to console... the Wii console. The GameCube works fine and lets you go back to the calendar. Now, I know you're thinking "you probably don't have a bios stupid" but I did get a bios, and I even booted the game through bios to make sure.

What did you expect to happen instead?

I honestly don't know. I expected it to work, but that was before I knew the Wii didn't work with it. At this point, either form of emulation should be fine.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Start up game
2. Say yes when it asks you to set Calendar time

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

I tested on 4.0 and various builds at 4.0-496

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

I don't know, some people reported it did work at some point but I could not confirm.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Core i5 3570K, GTX 760, Windows 7 64bit

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

I don't think there's anything to put here. Accepting this by default because it's on the Wiki and forums.

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs.]

History

#1 Updated by tueidj over 7 years ago

How about you just choose "no" because Dolphin already sets the clock for you?

#2 Updated by JMC4789 over 7 years ago

Honestly, sure. But, when I talked to HdkR on IRC, he seemed to think it worked on Dolphin at some point.

Again, this is fine to be rejected and what not, I just wanted to put an issue up here if anyone cared or wanted the old functionality of at least booting into the GC bios working.

#3 Updated by tueidj over 7 years ago

I seriously doubt it ever worked, but if it did it was before moving from SVN to git ( because looking at ProcessorInterface.cpp in the source browser shows no meaningful history).

#4 Updated by JMC4789 over 7 years ago

  • Status changed from New to Questionable

This shouldn't be accepted, It's just, not new or untested. I guess this should be questionable.

It's really worthless to fix, though. I just wanted to post it because I was told it worked at some point.

#5 Updated by Anonymous over 7 years ago

tueidj: the entire svn history is in git.

I'm not sure if this ever worked. IIRC it sets some bits in the hot reset scratch register thingy which i'm forgetting the name of, and then hot resets. IPL sees the flag when booting and loads the calendar screen.

#6 Updated by tueidj over 7 years ago

Sure the history exists, but it doesn't show up in google code's source browser.
The "Return to Menu" flag is in the SRAM somewhere, possibly bit 0x40 on byte 0x13.

Also available in: Atom PDF