Project

General

Profile

Emulator Issues #6965

CTGP Revolution (a MKWii mod) requires interp to install, won't run due to whatever breaks Riivolution support

Added by mariosegafreak over 5 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Not sure if I should report this. CTGP Revolution will error with "The disk drive appears to have stalled" when trying to launch. It also errors saying "Try LLE Emulator if this is homebrew", but I'm already using it.

Game Name?
CTCP Revolution 1.03.0014

Game ID?
RMCE01, I guess.

What's the problem? Describe what went wrong in few words.
It doesn't load the game and says the drive has stalled.

What did you expect to happen instead?
Load the game.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. modify SD.raw, add ctgpr files
2. load the channel
3. launch game

Which versions of Dolphin did you test on?
4.0-1

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Win 7 64 bit

Are you using the 32 or the 64 bit version of Dolphin?
64 bit

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)


Related issues

Is duplicate of Emulator - Emulator Issues #10927: Games that require proper icache/dcache emulation to workAccepted

History

#1 Updated by pauldacheez over 5 years ago

Would you mind trying this on a current development build? Stable builds are outdated as far as the issue tracker's concerned. https://dolphin-emu.org/download/

#2 Updated by mariosegafreak over 5 years ago

Tested with latest version.

"Dolphin.exe has stopped working"

#3 Updated by mariosegafreak over 5 years ago

And I mean 4.0-658-x64.

#4 Updated by jimbo1qaz over 5 years ago

On Jit64, crash on load.
On Jit64IL, freeze after some time.
On interpreter, installer completes after half a hour of button-mashing.

I boot from DOL or a skeleton disk with boot.dol replaced with the channel. The channel loads, I "change disk" to Mario Kart Wii, attempt to load game, then it says that "disk drive is not spinning up", just like the OP. If MrBeanHead is an asshole, he may intentionally break Dolphin support.

I think that making a CTGP ISO is more resistant to MrBeanHead's attacks on human rights in favor of a fascist copyright police state. I'm in the process of trying to make one.

How would I enable debugging features in Dolphin?

#5 Updated by pauldacheez over 5 years ago

  • Status changed from New to Accepted

MrBeanHead's attacks on human rights in favor of a fascist copyright police state

...Uh... it's more likely that he just unknowingly does something that doesn't work in Dolphin. Granted, there are some shady folks in the emulation/game-modding communities, but I think this is more a thing that Dolphin just doesn't do correctly. I mean, look at Gecko OS, it was broken in Dolphin until just last night due to issues with Dolphin's floating-point accuracy, not because Gecko OS's creators are assholes.

Of course, if you actually know the guy hates Dolphin, yeah, let's go with the fascism explanation.

How would I enable debugging features in Dolphin?

Simply launching it with the -d flag will do. On Windows, you can right-click Dolphin.exe > Create Shortcut, right-click the shortcut > Properties, and add -d to the Target line, after the " at the end; it should look something like this: http://www.sph.umich.edu/computing/windows/putty-shortcut-properties.gif

Of course, using the debug features isn't nearly as easy. I can at least tell you that when you boot a game it'll be paused and you'll have to unpause it, and for actual debugging you're gonna want to figure out how to disable parts of the JIT until the thing doesn't crash on JIT64.

http://www.chadsoft.co.uk/
http://wiki.tockdom.com/w/index.php?title=CTGP_Revolution
^ These two pages are for reference for anyone else who wants to test this. (Also, wtf, since when does Mario Kart Wii have a fanbase and modding community?)

#6 Updated by tueidj over 5 years ago

Forget it - turns out they ripped a bunch of code out of Riivolution, so it's never going to work properly on Dolphin.

#7 Updated by pauldacheez over 5 years ago

So the installer's broken on everything but interp, but the game itself is broken due to whatever breaks Riivolution support. Huh.

#8 Updated by mariosegafreak over 5 years ago

I think the interp requirement is due to http://code.google.com/p/dolphin-emu/source/detail?r=b863e40677710f2d53cae8aedfe450b4215562d3 but I'm not sure. This change was disabled in the latest build, does anyone want to check if the installer works now?

#9 Updated by jimmyli1528 over 5 years ago

Riivolution code has been removed. No apparent progress so far.
I am working on the ISO converter, which will be finished within this next century.

#10 Updated by leoetlino over 1 year ago

  • Status changed from Accepted to Duplicate

The launcher is heavily obfuscated and needs dcache/icache. The authors really don't like Dolphin.

#11 Updated by leoetlino over 1 year ago

Also available in: Atom PDF