Project

General

Profile

Emulator Issues #6967

Goblin Commander: Unleash the Horde Image Alignment

Added by kolano about 6 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Goblin Commander: Unleash the Horde

Game ID?
GGCE0A

What's the problem? Describe what went wrong in few words.
Large images are not rendered properly, each tiles right most pixel is rendered on the left hand side.

What did you expect to happen instead?
The right most pixel of each tile to be rendered in the appropriate position.

What steps will reproduce the problem?
1. Start the game
2. Observe the Jaleco and Goblin Commander images

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-595

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7, Intel Core i7-960, nVidia GeForce 580

Are you using the 32 or the 64 bit version of Dolphin?
64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

https://wiki.dolphin-emu.org/index.php?title=File:Goblin_Commander-Image_gaps.jpg

History

#1 Updated by JMC4789 about 6 years ago

Have you tried running at 1x IR? I know it's a bit silly to ask that, but a lot of times I forget to check when I see image problems like that.

#2 Updated by kolano about 6 years ago

Yes, issue is still present with 1x IR. It appears to be related to having anti-aliasing options enabled with either the OpenGL or DirectX back-ends.

#3 Updated by kolano about 6 years ago

Er hrm, actually it seems to be a combo of anti-aliasing and forced texture-filtering.

With OpenGL: Seems to render appropriately /w anti-aliasing if texture-filtering is disabled.
With DirectX: Seems to render appropriately if both anti-aliasing and texture-filtering are disabled.

#4 Updated by JMC4789 about 6 years ago

  • Status changed from New to Invalid

neobrain confirmed that this is not an issue. If it doesn't happen without enhancements, then we really can't do anything about it; as the emulator does its part correctly.

If someone wants to look at the code and can find a flaw in the algorithm, that's another story, but as of now I'm marking this invalid.

Sorry I couldn't bring a better answer, but that information was the nail in the coffin.

#5 Updated by kolano about 6 years ago

It's a valid issue, just a valid issue related to enhancements. I understand the lack of desire to investigate issues related to enhancements though. Might save trouble if problematic enhancements, such as this, could be disabled on a per game basis though.

Also available in: Atom PDF