Project

General

Profile

Emulator Issues #7086

Final Fantasy Crystal Bearers Water Texture Flickering

Added by josephwbat over 6 years ago. Updated almost 4 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
FFCC THE CRYSTAL BEARERS

Game ID?
RFCEGD

What's the problem? Describe what went wrong in few words.
During scenes with specific water textures, the water will flicker.

What did you expect to happen instead?
The water should appear as normal without flickering.

What steps will reproduce the problem?
1. Launch Dolphin.
2. Play a gameplay or scene with water and it flicker.
3. You can see it most evidently in the beginning of the game during its introduction/tutorial.

Which versions of Dolphin did you test on?
Dolphin 4.0.2

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Have not tested.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 7 64bit.
i7 3930k
NVidia GeForce 780 Ti

Are you using the 32 or the 64 bit version of Dolphin?
64bit.

Is there any other relevant information?
Switching between EFB-RAM and EFB-Texture results in the same problem.

RFCPGD-1.png (2.81 MB) RFCPGD-1.png seapancake, 10/06/2016 12:57 PM
5626

Related issues

Has duplicate Emulator - Emulator Issues #9351: Water Flickering in Final Fantasy Crystal Bearers still isn't fixed.Duplicate

Has duplicate Emulator - Emulator Issues #9484: Final Fantasy Crystal Bearers Water Texture FlickeringDuplicate

Has duplicate Emulator - Emulator Issues #9485: Final Fantasy Crystal Bearers Water Texture Flickering [Short description of your bug here (~10 words)]Duplicate

History

#1 Updated by MayImilae over 6 years ago

No screenshots, fifologs, or ways to reproduce quickly (wii save + real instructions). Saying "start the game and play" without any other explanation is not sufficient. Please provide those.

https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

#2 Updated by josephwbat over 6 years ago

Hello,

Screenshot is below of missing water texture. Occurs in DX9, DX11, OpenGL modes.

#3 Updated by NeoBrainX over 6 years ago

Try again with a current development build from https://dolphin-emu.org/download/ . If that doesn't help, provide a fifo log showing the issue. Read the link MaJoRoesch posted for details.

#4 Updated by josephwbat over 6 years ago

Latest development build does not resolve.

#5 Updated by pauldacheez over 6 years ago

Then provide a fucking FIFO log already.

#6 Updated by captgrrr over 6 years ago

better screenshot - https://dl.dropboxusercontent.com/u/5006456/RFCEGD-4.png
fifo log -
https://dl.dropboxusercontent.com/u/5006456/FFCC%20THE%20CRYSTAL%20BEARERS%20water.7z

The double image in the screanshot flickers on and off much like the black squares on the ground in the fifo log.

i7 3770k @ 4.5ghz
radeon 7950
16gm ram
win8.1x64

#7 Updated by captgrrr over 6 years ago

I think the comment above is what the original poster is talking about anyway.

#8 Updated by JMC4789 almost 6 years ago

  • Status changed from New to Accepted

Can you try the game with RealXFB or something? That's super weird. That screenshot and fifo definitely proves something's up.

#9 Updated by Autoran1 over 5 years ago

This issue has really strange behaviour, but it reacts on Fast Deth option for a while:
Stepm into the water than turn FastDepth ON, water will be rendered correctly until character moves and water will be buggy again, than you can turn the option OFF and the cycle will repeat itself
look's like FastDepth option triggers smth

#10 Updated by BJSerpas over 5 years ago

This issue is still present on the latest build of Dolphin (6215-x64). It happens regardless of video backend, internal resolution, or any graphics settings (including Virtual or Real XFB). While unofficial builds are unsupported, it may be helpful to know that this issue also occurs on the latest build of Ishiiruka (353.6c16034), also regardless of any and all video settings.

I believe issue 1899 is a similar (or identical) issue to this one. It has, however, been marked as fixed, which is obviously not true. I don't see any indication of the build that the issue was "fixed" in, however it must have been broken some time afterwards, given that the issue is about 3 years old and the issue is still present.

What can we do to help narrow down the cause of this bug?

#11 Updated by captgrrr about 5 years ago

Thought I would give this game a shot because of all the changes to depth and fast depth recently and the comment from January I had missed. As of 6496 things are still broken. Toggling fast depth only seems to work once for me. Does it rebuild the shader cache the first time its toggled? The game slows from 30fps to about 5 for a few seconds the first time I toggle the setting. While its slowing down I can even move and the water looks normal. After the first toggle of the setting it doesn't seem to make a difference.

#13 Updated by captgrrr about 5 years ago

RFCEGD-4.png is of the d3d11 backend again to hopefully reduce confusion of comment #6... my bad...

#14 Updated by JMC4789 over 4 years ago

  • Has duplicate Emulator Issues #9351: Water Flickering in Final Fantasy Crystal Bearers still isn't fixed. added

#15 Updated by Lumbeeslayer over 4 years ago

Here is a video on youtube I posted showing the issue. https://youtu.be/W7NjxXn_HnM

#16 Updated by Lumbeeslayer over 4 years ago

Please tell me someone is working to get this bug fixed before Dolphin 5.0 release

#17 Updated by JMC4789 over 4 years ago

Probably not. It's not really a regression, it's not a hugely popular game, it's not exactly game breaking. We don't really have any leads as to what's going wrong.

So yeah.

#18 Updated by JosJuice over 4 years ago

#19 Updated by JosJuice over 4 years ago

  • Has duplicate Emulator Issues #9485: Final Fantasy Crystal Bearers Water Texture Flickering [Short description of your bug here (~10 words)] added

#20 Updated by JosJuice about 4 years ago

  • % Done changed from 100 to 0

#21 Updated by seapancake almost 4 years ago

5626

Not seeing this in 5.0-985 as per attached. Anyone else able to re-test?

#22 Updated by captgrrr almost 4 years ago

seapancake wrote:

Not seeing this in 5.0-985 as per attached. Anyone else able to re-test?

Working here as well! Yay! At least in dx12 and vulkan. Dx11 currently hangs on my wii games but not my GC games tested so far but meh different issue YAY!

Dolphin 5.0-1265
Windows 10 x64
i73770k
fury x

#23 Updated by JosJuice almost 4 years ago

  • Status changed from Accepted to Fixed

I'm marking this issue as fixed, then.

Also available in: Atom PDF