Project

General

Profile

Emulator Issues #7099

Nintendo Puzzle Collection GBA Connectivity works Improperly; Framerate Issue

Added by JMC4789 over 5 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Nintendo Puzzle Collection - GPZJ01

What's the problem? Describe what went wrong in few words.

The VBA-M side always seems to be in frameskip and running way too fast. Even with Dolphin's frame limiter running twice as fast as it should (using the timer for estimation, the GBA emulator seemed to think it was running fine.)

Also, it takes forever to connect as well; but if you're patient that seems to work consistently.

What did you expect to happen instead?

Since I knew this would happen prior, yeah, I kinda hate this question. Basically, it should work where both emulators run full speed at the same time without framerate issues.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Set Controller 1 to GC controller, Controller 2 to GBA
2. Start Nintendo Puzzle Collection
3. Start VBA-M, load Bios
4. Navigate Nintendo Puzzle Collection to lower right corner, select it.
5. After a while, the VBA-M will finally load.
6. Select the game of your choice, personally, I think Doctor Mario and Yoshi Cookie suck, so I select the far superior Panel De Pon.
7. Hit buttons on whatever you're using for the GBA controller. It should load if you hit start or L and R or whatever. It just starts when it feels like it, even on console.
8. You'll notice the GBA is running very fast, upwards of 10 seconds pass in the GBA before one second will pass on my computer. Setting dolphin to as low as possible (10 fps limit) gets it to about twice as fast.
9. Give up because the game is impossible to play at those speeds.
10. Should be noted that even when Dolphin is closed the game will continue to play, except now it tends to go into the 3000% range.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

4.0.2, 4.0-1242

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

Nope.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Core i5 3570K @ 3.4GHz, GTX 760, Windows 7x64

Are you using the 32 or the 64 bit version of Dolphin?

64bit

The only other thing I could do is make a video, but I think the text description is just as good.


Related issues

Blocks Emulator - Emulator Issues #7098: GBA Connectivity Master IssueAccepted

History

#2 Updated by MayImilae over 5 years ago

  • Operating system N/A added

I wonder if this will fix the googlecode glitch...

#3 Updated by JMC4789 over 4 years ago

  • Status changed from New to Fix pending

#4 Updated by JMC4789 over 4 years ago

  • Status changed from Fix pending to Fixed

Also available in: Atom PDF