Project

General

Profile

Emulator Issues #7134

Conduit 2 - reflections rendering incorrectly

Added by muonsoftware about 5 years ago. Updated about 1 month ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Conduit 2

Game ID?

SC2P8P

What's the problem? Describe what went wrong in few words.

The game uses a reflection effect to simulate shiny surfaces that is rendered incorrectly in Dolphin. This happens in both Direct3D and OpenGL backends. What it looks like to me is that it is using the wrong texture for the cubemap.

Bloom looks odd too but I'm chalking that up to EFB scaling issues

What did you expect to happen instead?

Reflection effects should look the same as on the Wii

What steps will reproduce the problem?

  1. Start the single player campaign
  2. Look around at shiny surfaces, eg glass/metal

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

Every SVN revision between 4.0-1126 and 4.0-1304, 3.5-1124 and 3.0

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

No

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Q6600 o/c 3ghz, Radeon 6850 o/c 850/1200, 4gb DDR2 SDRAM, Windows 7x64 latest drivers

Mid 2009 MacBook Pro Core2Duo T9600, Nvidia 9600M GT, 4gb RAM, Windows 7x64 via bootcamp, recent Nvidia Drivers

Are you using the 32 or the 64 bit version of Dolphin?
64-bit

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Gallery with screenshots from Dolphin and Wii is here:-

http://imgur.com/a/YZrcc#0

Gameplay video from wii

https://www.youtube.com/watch?v=CMPmqeeYf4o

History

#1 Updated by NeoBrainX about 5 years ago

When reporting issues related to graphics, please always provide a fifo log:
http://wiki.dolphin-emu.org/index.php?title=FifoPlayer

#2 Updated by MayImilae about 5 years ago

  • Category set to gfx

#3 Updated by muonsoftware about 5 years ago

I'm still having trouble capturing a FIFO log. In today's build there was a fix for the wxwidgets assert that was tripping things up before, and now I can capture the log OK. However, I can't save it without Dolphin crashing:

Problem signature:
Problem Event Name: APPCRASH
Application Name: Dolphin.exe
Application Version: 0.0.0.0
Application Timestamp: 53385edd
Fault Module Name: MSVCR120.dll
Fault Module Version: 12.0.21005.1
Fault Module Timestamp: 524f83ff
Exception Code: c0000005
Exception Offset: 000000000003c630
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 2057
Additional Information 1: dda9
Additional Information 2: dda97ffb17111c9244658619dd882053
Additional Information 3: f5ed
Additional Information 4: f5ed4f39788906e534480e7883a7d3c1

#4 Updated by JMC4789 over 4 years ago

Play back the fifo-log in single core. Also try the latest dev builds and what not.

#5 Updated by muonsoftware over 4 years ago

Here's a fresh log, from 4.0-3469. The reflections on the circular glass floor in front are incorrect (wrong texture/wrong scaling?)

https://drive.google.com/file/d/0B7dea6okGcjESDBUSENOZEJNck0/edit?usp=sharing

#6 Updated by JMC4789 almost 3 years ago

  • Status changed from New to Accepted

I've reproduced this bug.

#7 Updated by shatteredlites about 1 month ago

this issue is gone only tested on Vulkan though

Also available in: Atom PDF