Project

General

Profile

Emulator Issues #7183

F-Zero GX Chapter 2 rock shadows missing (D3D)

Added by xwidghet almost 4 years ago. Updated over 1 year ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
F-ZERO GX (US Version)

Game ID?
GFZE01

What's the problem? Describe what went wrong in few words.
When using the Directx 11 renderer the shadows for the rocks on chapter 2 are missing.

What did you expect to happen instead?
For the shadows under the rocks to be rendered.

What steps will reproduce the problem?
1. Chapter 2 requires being unlocked so you will need to use my save game data to access it.
2. Start the game up with the Directx 11 renderer.
3. After getting to the startup screen select Story, and start chapter 2.
4. Look at the rocks on the cliff, they should have shadows under them.

Which versions of Dolphin did you test on?
3.5 through 4.0-1417 on both 64bit and 32bit.

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1 64bit
Nvidia GTX 560 448 core
Intel Core i5 2500k (OC'd to 4.4ghz)

Are you using the 32 or the 64 bit version of Dolphin?
Both 64bit and 32bit.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
OpenGL - http://i.imgur.com/m4zUb9H.jpg
DirectX 11 - http://i.imgur.com/T75zBAW.jpg
Memory Card - http://www.mediafire.com/download/y01rb05ykyu31rj/MemoryCardA.USA.raw

History

#1 Updated by JMC4789 almost 4 years ago

  • Status changed from New to Accepted

Confirmed

#2 Updated by MayImilae almost 4 years ago

  • Category set to gfx

I really wish we had a D3D tag.

#4 Updated by JMC4789 about 3 years ago

I need to get my eyes checked sometime...

#7 Updated by JMC4789 over 1 year ago

  • Status changed from Accepted to Won't fix

This is a LogicOps issue, which D3D11/12 cannot properly support due to API Limitations.

Sorry :(

Also available in: Atom PDF