Project

General

Profile

Emulator Issues #720

Zelda TP slows down dramatically in Hyrule Field after Goron Mines

Added by cerebus5 almost 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Beat Goron Mines or get a savegame (I can supply one), and visit
outdoors areas. Whereas before speed was around 13fps, now it drops to
4fps (6 with efb hack).

What version of the product are you using? On what operating system?
Tried it on XP32 and Vista


Related issues

Is duplicate of Emulator - Emulator Issues #2499: The Legend of Zelda - Twilight Princess slowdowns on Hyrule FieldFixed

History

#1 Updated by marcus almost 11 years ago

That's wierd...

#2 Updated by cerebus5 almost 11 years ago

http://forums.ngemu.com/1601556-post535.html If that helps there is my savegame.

#3 Updated by marcus almost 11 years ago

No, sorry. I don't have tp. Can someone who does comfirm this?

#4 Updated by cerebus5 almost 11 years ago

it was tested by other members of the forum and they had the same results:
http://forums.ngemu.com/1601898-post542.html
http://forums.ngemu.com/1601653-post539.html

#5 Updated by marcus almost 11 years ago

ok. someone will start working on it when they notice this issue report.

#6 Updated by TTnickTT over 10 years ago

This isn't bugged it's just a very heavy place to run for Dolphin/computer

#7 Updated by marcus over 10 years ago

But it was fine before he beat it...

#8 Updated by omegadox over 10 years ago

  • Status changed from New to Accepted

This is because the outdoor maps uses a lot of vertices which puts a big load on the
vertex loaders. Our vertex loaders need better optimization.

#9 Updated by BhaaL over 10 years ago

I can confirm this, but i rather think its a problem of viewing distance.

The first time you go to Hyrule Fields is while it is still covered in the darkness,
and even after Kakariko when returning to save Colin the field is shown at night.
After Goron Mines, the first time I went back out it was broad daylight - with an
incredible viewing distance compared to night/darkness view.

#11 Updated by cerebus5 over 10 years ago

That's possible. I can't remember if it's nighttime the first time out but it could
be. But it slows down even if you don't have a visible drawing distance - like just
when you come out of the gate at Lake Hylia it's just a wall but still very slow.

#12 Updated by Anonymous over 10 years ago

just use wireframe to see what's going on. probably a mass of vertices somewhere,
just poor programming on the game makers' part :p

#13 Updated by fsahmkow27 over 10 years ago

I imagine that it has to do with the big amount of polygons loaded. A reason which
could explain why fps drops more is: the game preloads all of Hyrule field, and
dolphin tries to render all the geometry instead of rendering as the user gets to an
area.

#14 Updated by marcus over 10 years ago

yeah, technically, we COULD lower the draw distance...but that would be cheating.

#15 Updated by Anonymous over 10 years ago

uh, and how would we do that? :> The gpu is just sent a scene to render...trying to
"lower the draw distance" would be a massive, ugly hack afaik

#16 Updated by BhaaL over 10 years ago

Indeed, I'd rather take the slowdowns than pollute code. Real GC hardware doesn't
budge, so I guess theres still a lot to optimize :)

#17 Updated by marcus over 10 years ago

I didn't say it would be easy...but it was a bad idea anyway.

#18 Updated by pua4life about 10 years ago

Its not gameissue,its bug in the code. Using direct3d and enabling any hack gives
fullspeed.

#19 Updated by marcus about 10 years ago

This is unrelated to issue 1436.

#20 Updated by dusmanija about 10 years ago

Well... Not realy. After the goron mines the fps still goes down to half the normal
speed.

#21 Updated by Anonymous over 9 years ago

  • Status changed from Accepted to Duplicate

#22 Updated by marcus over 9 years ago

Usually the newer issue is merged into the older issue, no?

#23 Updated by Anonymous over 9 years ago

there isn't really any important info in either of them, and the other one already had a better title :P

#24 Updated by acrion over 9 years ago

It seems likely that the Wii GPU has built-in occlusion and culling that the emulator
is missing.

Large areas are going from running at 100% (150% capable) to about 30% to 50% in the
areas mentioned on my machine, regardless of what direction I'm looking or what is
actually visible. It almost sounds like it is missing basic culling.

#25 Updated by Xtreme2damax over 9 years ago

Any way to test that in Dolphin to see if that is what is causing these slowdowns?
Are you familiar enough with coding to add basic support into the emulator if these
features are indeed missing?

Is there any way to determine if the actual hardware even supports the features you
mentioned?

#26 Updated by acrion over 9 years ago

No, I'm providing a possible avenue for the developers to investigate. It seems likely
because when there is a view distance limit due to the fog when I first went through
the fields, the framerate was moderate. But when I could see significantly further,
the framerate dropped. Also, it doesn't matter what direction I'm looking in, directly
at the ground should exclude most of the map from being rendered, but it doesn't appear
to help.

#27 Updated by nicolas.vidalro over 9 years ago

Well, I think that's not a viewing distance problem (fog, or night would not help). That's just because, while youre playing the games it unlocks Hyrule Field parts, when you first enter HF in the game, its very basic, with poor details and reduced area, after Goron mines it's larger and fully detailled. Maybe at this point of the storyline the game is loading the whole Hyrule Field and stuff that wasn't loaded before.
Someone tested the Hyrule field speed hack? How does it works?

#28 Updated by xaney062396 about 5 years ago

Every time I update the Dolphin emulator this issue seems to be worse for me. I updated from 3.0 to 4.0 and it's even worse.
Also, in 3.0 when I go to howl along with a stone it freezes as soon as I press (A). I usually can get around this by saving state, then disabling lighting and other contributes to the quality I can SOMETIMES make it work. Then keep loading up the saved state and trying it every time till it goes through.

I understand Zelda: Twilight Princess is a HUGE game and Dolphin seems to have a very tough time running it, but at the very least I'd suggest a way to improve something to make it work a little better.

My PC Spects?
Hewlett-Packard
Intel Core i7
x64
996 GB Disk Space
8.0 GB RAM
And my CPU is almost always just 15% when I run the game. So it has TONS of CPU space to use just doesn't seem to use it.

So yeah any suggestions on my end would help out.

#29 Updated by comwiz.k over 4 years ago

Here's Speed Hack Patch for RZDK01 (Korean)

$Hyrule Field Speed Hack (Korean)
0x80047DEC:dword:0x60000000
0x80047E08:dword:0x60000000
0x80047E20:dword:0x60000000
0x80047E3C:dword:0x60000000
0x80047E40:dword:0x60000000
0x80047E44:dword:0x60000000
0x80047E48:dword:0x60000000
0x80047E4C:dword:0x60000000
0x80047E50:dword:0x60000000
0x80047E54:dword:0x60000000
0x80047E58:dword:0x60000000
0x80047E5C:dword:0x60000000
0x80047E60:dword:0x60000000
0x80047E64:dword:0x60000000
0x80047E68:dword:0x60000000
0x80047E6C:dword:0x60000000
0x80047E70:dword:0x60000000
0x80047E74:dword:0x60000000
0x80047E78:dword:0x60000000
0x80047E7C:dword:0x60000000
0x80047E80:dword:0x60000000
0x80047E84:dword:0x60000000
0x80047E88:dword:0x60000000
0x80047E8C:dword:0x60000000
0x80047E90:dword:0x60000000
0x80047E94:dword:0x60000000
0x80047EB0:dword:0x60000000
0x80047EC8:dword:0x60000000
0x80047EE4:dword:0x60000000

Also available in: Atom PDF