Project

General

Profile

Emulator Issues #7225

The Urbz: Sims in the City bathroom/sex censors malfunction

Added by JMC4789 almost 6 years ago. Updated 6 months ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
GFX
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

The Urbz: Sims in the City - GUBE69

What's the problem? Describe what went wrong in few words.

When you take a crap in game, typical pixelation censors show up to make sure the naughtiness is not visible (and because they didn't animate/texture anything.)

For some reason, when you do this in Dolphin, a huge square blots out all the color without pixelation, meaning that the graphics are severely glitched during the scenes in question.

What did you expect to happen instead?

I expected it to work, of course.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1.Start a new game
2.Find a stall to crap in
3.Observe glitched censoring

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

4.0-1456, 4.0

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

no

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Core i5 3570K, GTX 760, Windows 7 x64

Are you using the 32 or the 64 bit version of Dolphin?

x64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

I went through the trouble (and 30+ second loadtimes) of checking on console to get a proper screenshot. I also tried various settings in emulator, including the most accurate settings I could come up with

Console - http://i.imgur.com/gfnAa3o.png
Emulator - http://i.imgur.com/Gc98B1T.jpg

Now, the real kicker is that the censor doesn't show up at all in the fifologs! I tried, really! Here's the resulting fifolog regardless.

Fifo - https://dl.dropboxusercontent.com/u/484730/UrbzCensor.7z

History

#1 Updated by skidau almost 6 years ago

The censor uses EFB pokes. See issue 4966.

#2 Updated by JMC4789 almost 6 years ago

I am not using skip EFB access to CPU, I am not experience slowdown either.

#3 Updated by skidau almost 6 years ago

It does not look like EFB pokes are functioning anymore.

#4 Updated by JMC4789 almost 6 years ago

I misread what you were saying somehow. Anyway, that would make sense, but they're still working in Monster Hunter Tri, at least. The fact it's using EFB pokes probably is the reason why they don't show up in fifologs, either.

#5 Updated by JMC4789 almost 6 years ago

pinumbernumber on IRC gratiously tested Sim's bustin' out.

on OGL, it looks like this: http://imgur.com/a/bQcAM
D3D looks like this: http://imgur.com/lL7S5VX

Strangely enough, this is probably the same behavior, I probably just needed to zoom in more on D3D rather than being lazy and quickly checking it.

#6 Updated by JMC4789 about 5 years ago

  • Status changed from New to Accepted

This is working on OpenGL now. D3D is still offset.

#7 Updated by JMC4789 about 5 years ago

Ahem, apologies; I should link to the build that fixed it in OpenGL -> https://dolphin-emu.org/download/dev/68a4cc6b724657c61e86b5cb37ae2a2012710030/

#8 Updated by flacs 6 months ago

  • Status changed from Accepted to Fixed

According to the wiki Direct3D works now. The issue is assumed to have been fixed some time before http://dolphin-emu.org/download/dev/master/5.0-2462/.

Also available in: Atom PDF