Project

General

Profile

Emulator Issues #7230

True Crime New York City Crashes in a Variety of Ways

Added by JMC4789 over 5 years ago. Updated over 1 year ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

True Crime: New York City - G2CE52

What's the problem? Describe what went wrong in few words.

The game crashes during the tutorial when you do just about anything other than shoot. Try to jump through the window (required to continue) it will crash. Try to punch someone? It will crash.

What did you expect to happen instead?

To crash at least as little as its previous game. Which is also known to just randomly crash in Dolphin, but it's much more rare.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Start a new game
2. Try to complete the tutorial, I dare you.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

4.0.2, 4.0-1451

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?

nope

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Core i5 3570K, GTX 760, Windows 7

Are you using the 32 or the 64 bit version of Dolphin?

64bit

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

I tried single core, switching graphics backends and other obvious solutions that may work. MMU Speedhack was on as the game won't boot without it.

Screenshot of the character disappearing after trying to punch out the window.

http://i.imgur.com/946NENL.jpg

If you immediately dive through the window you can make it to the next area, where it will immediately crash in a similar manner.


Related issues

Has duplicate Emulator - Emulator Issues #7421: True crime New York city is DSI exception in stmw and imwDuplicate

History

#1 Updated by JMC4789 over 5 years ago

In what appears to be the death knell of this game ever being full speed in dolphin, it appears this game requires Full MMU emulation, rather than the MMU speedhack that it has set currently.

MMU Speedhack just crashes way too much for it to be playable, and Full MMU seems to work, but is incredibly slow, as expected.

#2 Updated by kostamarino over 5 years ago

LLE audio also seems to work.

#3 Updated by JMC4789 over 5 years ago

Why would LLE audio help this, though? I'll look into it more later; I just never thought to try audio changes. LLE audio being forced would be much, much more preferable than full MMU.

#4 Updated by JMC4789 over 5 years ago

No, LLE audio does not work.

#5 Updated by kostamarino over 5 years ago

Sorry, my bad, i didn't test it enough it crashed a bit afterwards.

#6 Updated by JMC4789 over 5 years ago

It tends to crash whenever it feels like it; but I've yet to get through the entire tutorial without it crashing. Full MMU works fine, but yeah, performance is bad. Then again, playing the game at all is better than this.

#7 Updated by JMC4789 over 5 years ago

Full MMU isn't working just fine for me any more, what the heck?

#8 Updated by magumagu9 over 5 years ago

Bisect it? If there's some sort of regression, it might point towards the issue.

#9 Updated by JMC4789 over 5 years ago

It appears to be unrelated to the MMU stuff; I tried it in 4.0 and managed to reproduce the crash from a slightly different spot. I guess I did something wrong when testing this...

#10 Updated by JMC4789 over 5 years ago

  • Status changed from New to Accepted

I've seen videos of crashes of this. I'm not the only one. Don't know how to fix it though, no setting seems to handle it.

#11 Updated by JMC4789 about 5 years ago

It seems like the game is trying to lock-on to something that doesn't exist, causing the crash.

#12 Updated by ZephyrSurfer almost 5 years ago

There is a lot of errors now that 4.0-3746 shows them as warnings.

Note that it is easy to reproduce the crash if you simply melee some tvs to your left when you start the game on the first level, running into them while doing so.

#13 Updated by JMC4789 almost 5 years ago

Weird thing is, once you get through the tutorial I'm unable to crash the game.

#14 Updated by ZephyrSurfer almost 5 years ago

I agree about the locking to a non-existent target idea you had; it looks like that.

Near the end of the tutorial in the master(tested with 4.0 3798) it crashes when you drop from the ladder. I don't think that was the case with 4.0-3746.

Also is this a bug on actual hardware?.
This was made with default mmu Dolphin 4.0-3746:
http://s000.tinyupload.com/index.php?file_id=62333918261490255074

#15 Updated by JMC4789 almost 5 years ago

It can sometimes crash on the ladder, sometimes won't. It's random. Just keep trying and you can get through. Once the tutorial is over the game won't crash.

#16 Updated by ZephyrSurfer almost 5 years ago

Are you quite sure?. I got past that as you can see in my attachment.
Is your game crashing if you try Full MMU too?

#17 Updated by ZephyrSurfer almost 5 years ago

Yeah I guess it is random. I made a savestate before the ladder and no matter what it will crash when I hit the bottom.
I restarted on the same build and made a savestate before the ladder and it always works.
Strange behaviours!

#18 Updated by ZephyrSurfer almost 5 years ago

I got the game to crash in one of the buildings when I was asked to go in during a robbery. I hit a pool table and it crashed. The same addresses as tutorial appear in the error message.

#19 Updated by ZephyrSurfer almost 5 years ago

Many Case Name 0 level simply crash Dolphin when selected
Ok to test simply enable debug mode ->
Then select
Case Name 2 BC01
Mission Name 2 BC1_M1
Then walk through the kitchen Door in the restaurant.
I've tested Many revisions

Full MMU, BAT and WIPs don't change behaviour but selecting Full MMU does not show the error messages on invalid addresses anymore :(

#20 Updated by ZephyrSurfer almost 5 years ago

The example above has been partly fixed last week in PR #1693
And by party fixed I mean It's the first time one could enter the kitchen in the example above. If other characters run through those doors they will disappear I think they teleport outside the map. Any melee will cause a crash after this happens.

However the game still crashes often.

With this information it is evident to me that the issue is Dolphin not causing DSI exceptions/other exceptions where it should.

If there is any information on how I'd progress on this "educated guess" to fixing this issue would be appreciated.

I'm guessing hwtests are the only way to find out more about the consoles behaviour on where else it generates such exceptions.

#21 Updated by JMC4789 almost 5 years ago

Underclocking the CPU seems to fix it. Source: https://dl.dolphin-emu.org/prs/pr-1798-dolphin-latest-x64.7z go to configure/advanced, and underclock the CPU to about 70 - 80%

#22 Updated by JMC4789 over 1 year ago

  • Subject changed from True Crime New York City crashes when going near the window during Tutorial to True Crime New York City Crashes in a Variety of Ways

So, underclocking the CPU helps with that particular crash (which is caused by the game locking onto something out of bounds, and then you try to punch and it teleports you out of bounds,) but it's not a CPU clock issue!

There's a way to just crash the game by jumping on boxes in the first room of the game. Dolphin's video dumping is shit so I couldn't edit it, but here's proof. You can softlock the game in ~20 seconds.

https://www.youtube.com/watch?v=1LEdiB-_MuU

#23 Updated by JMC4789 10 months ago

Also available in: Atom PDF