Project

General

Profile

Emulator Issues #7255

Yugioh: The Falsebound Kingdom game freeze

Added by ismalo112 over 5 years ago. Updated over 2 years ago.

Status:
Working as intended
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

[READ THIS: https://forums.dolphin-emu.org/showthread.php?pid=276132 <<<
Your answers are there!]
[Leave the questions as they are and answer them in the next line]
[Remove lines written inside brackets [], but nothing else]

Game Name?
Yugioh: The Falsebound Kingdom

Game ID?
GYFEA4

What's the problem? Describe what went wrong in few words.
Sometimes when I get out of a battle, the game freezes and the background music keeps playing and switches between map music and battle music. Nothing else happens.

What did you expect to happen instead?
To be able to go back to the map after leaving a battle.

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Play the game
2. Play until it happens again (Happened twice consecutively so far.)

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0, 3.0

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)

Windows 7 Professional
i7 950 @ 3.07GHz
AMD Radeon HD 6850

Are you using the 32 or the 64 bit version of Dolphin?
64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]

[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs.]


Related issues

Has duplicate Emulator - Emulator Issues #8166: Yu-gi-oh! The Falsebound Kingdom Gamebreaking FreezeDuplicate

Has duplicate Emulator - Emulator Issues #8683: Waning: Invalid WriteDuplicate

History

#1 Updated by JMC4789 over 5 years ago

1: Try Latest Dev Builds.
2: Try Single Core.

#2 Updated by ismalo112 over 5 years ago

Didn't work. I've made a multiple save states while playing through a mission, playing through about 75% of the mission, and now it seems like whenever I enter a battle, the game freezes as soon as it starts.
I can record and upload it if it helps.

#3 Updated by JMC4789 over 5 years ago

I'm just trying to narrow down what's going on, don't be surprised if none of this works.

Try using different CPU Cores (JITIL, and Interpreter. Be warned interpreter is slow) and the various graphics backends. This likely just is a crash that can't be worked around, whether it's a problem on your end of the emulator, but I want to make sure before we go digging into what could be causing it.

#4 Updated by ismalo112 over 5 years ago

I ran it on 4.02 earlier and the freeze stopped occuring, but now it randomly crashes with this error message:
"BackPatch: Currently only supporting reads.

Attempted to write ######### (gives a lot of different numbers)"

And when I press OK it gives me this.

"BackPatch write - not through EAX."

And when pressing OK on that it just goes back to the previous message.

#5 Updated by ahmet29992 over 5 years ago

Hello,

After having the same problems as described above, I searched the internet to find a solution on this. I was not able to find a solution, however, by using an older version of Dolphin, these crashes did not occur so far. Reduced FPS from monster attacks (for example the Silver Fang attack) did also not occur anymore. I decided to try this version, because there was another game (Medabots: Infinity) which also had a sound glitch, and Yu-Gi-Oh: Falsebound Kingdom worked perfectly on this version.

The version is Dolphin 3.0-232

If for some reason your game is still crashing, please let me know and I'll try to help.

#6 Updated by JMC4789 over 5 years ago

That's relatively interesting. If this could be confirmed as fixing it, then we'd really have to look into that build to see what happened.

#7 Updated by ahmet29992 over 5 years ago

Update:

After playing Yu-Gi-Oh: Falsebound Kingdom on the Dolphin 3.0-232 emulator for a few days (many hours a day), I have recieved several crashes, but these are rare. In total, the game has crashed three times for me, but the crashes were different, and they gave an error message. This is different than with the most recent version of Dolphin. The crashes did not ruin my gameplay, as they happen rarely. The crashes might be prevented by using save states, but I have not tried this yet. I have searched what could fix the error that appears in Dolphin 3.0-232, and I have found that enabling MMU would most likely fix it. After enabling MMU, the game did not crash a single time, but I have not played long with it because of the decrease in FPS. On the Dolphin 4.0.2 emulator, there is a point where the game always crashes. After enabling MMU for Dolphin 4.0.2, the game still crashed. However, an annoying sound appeared with MMU enabled (after the crash, until task was ended).

#8 Updated by dieguitoleonm about 5 years ago

having the same issue, the game screen freezes after winning a battle (where the experience points are given) and it happens in the same map, haven't tried to downgrade dolphin yet.

#9 Updated by JMC4789 about 5 years ago

Can this be retested on latest master? There were a few hang fixes.

#10 Updated by JMC4789 about 5 years ago

This could be fixed... can anyone at all please confirm the crashes still happen?

#11 Updated by ismalo112 about 5 years ago

I'll kinda gave up playing the game, but I might start again soon. I'll let you guys know if I find something

#12 Updated by JMC4789 about 5 years ago

We had another game that died the same way get fixed recently, that's why I asked.

#13 Updated by CoolDuelist14 almost 5 years ago

I'm using version 4.0-4418 right now, with JITIL Recompiler and DSP HLE emulation. I've tried one mission so far, and the game hasn't crashed. However, mine gives me audio cues when it is about to crash (generally Silver Fang's attack being cut off), but the animation still continues. The only thing that crashes now is the sound effects of the attacks and the victory fanfare. The background music still plays though, transitioning to battle and map music just fine.

#14 Updated by rboas5 almost 5 years ago

My game has crashed four consecutive at the same spot. Fighting the last boss on level five. I have the most up to date version of dolphin. I have also edited my settings so it does not lag. So I have a feeling the glitch is with the game. Not really that it lags out

#15 Updated by JMC4789 almost 5 years ago

Can you try it with single core mode?

#16 Updated by magumagu9 over 4 years ago

issue 8166 has been merged into this issue.

#17 Updated by RoyCastillo97 over 4 years ago

I have the same problem, my game freezes after winning a battle and the sound still running...
But this seems to freeze only in certain time of the day. Mine is crashing mostly when is afternoon and rarely at night. I don't know what is causing this error.

#18 Updated by JMC4789 over 4 years ago

issue 8166 has been merged into this issue.

#19 Updated by themonkeymonk over 4 years ago

As of today I can confirm that this issue still occurs. I have not yet tested based on different times of day, although that might explain the problem. The first time I played through this section it worked with no issue, but the second time it kept crashing on various settings configurations (but would have occurred at the same time for the in-game day).

#20 Updated by JMC4789 over 4 years ago

  • Status changed from New to Accepted

I haven't been able to reproduce this crash in single core. As this is an extremely light game, can you try that?

#21 Updated by JMC4789 over 4 years ago

issue 8683 has been merged into this issue.

#22 Updated by casszephyr over 4 years ago

This issue still happens. I've tried using the latest version of Dolphin as well as older version (4.0 and 3.0 stable versions). Also tried changing the suggested settings, like single core etc.

To me it seems like the issue happens after you've engaged in a certain number of battles (about 10) in any given chapter. The game freezes at the end of the battle when you're getting experience. This makes it impossible to get through chapter 4 on Yugi's story. I can provide screenshots or save state so that you will generate the error at the end of one battle if needed.

#23 Updated by theryanking131 over 4 years ago

chapter 4 is where i cant go any further either, as it's showing the stats after a victory it simply freezes and gives the warning msg and im forced to close the emulation.

#24 Updated by keffvalk over 4 years ago

My game stops after i get in the 10th fight in a game. mission 3 mostly...plz fix

#25 Updated by JMC4789 over 4 years ago

Anyone up for testing? This could fix the issue: https://dl.dolphin-emu.org/prs/pr-2717-dolphin-latest-x64.7z

#26 Updated by OverlordBadman about 4 years ago

Greetings, I've just had a similar issue occur on 5.0 rc17 and I tried the build you linked JMC to have the same issue. The issue I get is that messages of "Invalid Write to" and "Invalid Read to" that essentially don't go away. I'm not sure if the error occurs with dual core checked off but it seems less likely or takes longer. Regardless, I went through two missions without dual core and then the next mission with dual core: error.

#27 Updated by thejoemontondo about 4 years ago

I've been playing the game on version 7007 and have encontered this same issue. At the end of a combat the game will freeze and endless pop ups of "Invalid read from to" and "Invalid write to to" messages will pop up until I force Dolphin to close. This issue is consistently happening. I am running windows 10 if that might have anything to do with it.

#28 Updated by Jcthemvp about 3 years ago

I've played this game on the latest dolphin version 5.0 and it crashes on Kaiba's Framed mission when faced vs the enemy with blackland fire dragon as their lead monster and baby dragon on its team with a non-stop pop up of "invalid to read" with a bunch of numbers thus closing the emulator. Another issue is when I saved my Story mode on Framed (it shows that it goes through on memory card A) it loads back to the previous mission Surrounded. I'm using a Laptop Vista running windows 10.

#29 Updated by quadpolar almost 3 years ago

This game works totally fine so far (I've done Yugi to mission 10, Kaiba to 8) on version 3.0-232.

This game is unplayable on the latest version of dolphin (5.0). I have tried single core.

At least 3 bugs exist in 5.0:
1) Saving does not work properly. Even if you go past mission 6 in the Yugi campaign, the game only saves your progress up to mission 6. Similar for Kaiba campaign but I don't recall which mission
2) Failed read/writes
After 10 or so battles (can be with same enemy) the game tries to access memory it shouldn't. This seems to only occur on certain maps, and even under certain conditions (I think battling in the field as opposed to a castle triggers it). I encountered it:

Once on the first map during a field battle
Several times on the 4th yugi mission
Once on the 6th mission (I did many field battles, when I retried I only battled in castles and made it past this mission)
Every time on the 4th Kaiba mission

3) This is the real game-breaker. On the 9th Yugi mission after any battle takes place the audio cuts to a buzzing sound and the game totally locks up. I could not find a way around.

None of these occur in the 3.0-232 build

#30 Updated by JMC4789 over 2 years ago

  • Status changed from Accepted to Working as intended

These issues occur on Console.

Also available in: Atom PDF