Project

General

Profile

Emulator Issues #7332

Dragon Ball Z Budokai (1 and 2) render interlaced fields, which dolphin doesn't support.

Added by ecalle.kevin about 6 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

The problem occurred after changes of 4.0-1533
link : https://fr.dolphin-emu.org/download/dev/edbf90f9d25fdf5d2c080b1854695a9d77cd2134/

Affected games (only the PAL version are tested)
Dragon Ball Z
Budokai (1) PAL : GD7PB2
Budokai 2 PAL : GZ3PB2

Examples
Budokai (1) : http://i.imgur.com/aByOlNk.jpg
Budokai 2 :http://i.imgur.com/wqqlPbT.jpg

As can be seen in the screenshots, the game is displayed with a resolution much too large horizontally (x2 ?) And roughly half vertically. There he has a concern with a multiplier "* 2" in the code ?

My configuration
Intel I3 2350
nVIDIA 410m with the drivers 337.88

I should point out the configuration of Dolphin is the same in both versions, the executables are launched with the same settings files.


Related issues

Has duplicate Emulator - Emulator Issues #7565: Dragonball Z Budokai 2 Screen FlickeringDuplicate

Has duplicate Emulator - Emulator Issues #9617: Dragon Ball Z Budokai 1 & 2 Screen Shaking NTSC/PALDuplicate

Is duplicate of Emulator - Emulator Issues #10473: Dolphin does not support Interlaced OutputAccepted

History

#1 Updated by magumagu9 about 6 years ago

What exactly are your settings? Specifically, what is your XFB setting, do you have progressive scan enabled, are you using some sort of widescreen hack, and anything else that isn't a default setting.

If you stretch the emulator window horizontally on 4.0-1533, can you see more of the game?

Do you have a build environment? I might want you to try a patch, and I want to know whether to send a full build or just a code patch.

#2 Updated by ecalle.kevin about 6 years ago

ini file of its games are by default, and here is an image that summarizes all the graphics settings used:
http://i.imgur.com/7FFHPNi.png
Even changing the internal resolution, EFB copy to and the others, the bug is still present.
Stretching the window horizontally, nothing happens, the image is always the same, it is just refocused on the windows window.
Only the D3D plugin is affected.

After, but on the order of detail DBZ Budokai games also have a slight problem tremors image, but it may be due to a previous revision to the 4.0

For the build environment, I use Visual Studio Express 2012.

#3 Updated by magumagu9 about 6 years ago

Only D3D... so OpenGL is okay?

Does changing the XFB setting to either Real or disabled have an effect?

#4 Updated by ecalle.kevin about 6 years ago

After checking, OpenGL only works XBF disabled, with virtual there is a black screen, and real a startup crash.

For D3D, here are the pictures for real XBF and disabled
http://i.imgur.com/rjDp2mX.png
Thus the Budokai games do suffer that from image shake, if XBF is disabled and those for the two graphics plugins.

But this does not explain why since 4.0-1533 the bug in Budokai games emerge when XBF is virtual.

#5 Updated by RayDreOfficial about 6 years ago

Confirmed. I have the same issue when using D3D. In previous builds, this issue did not exist. I will try to pinpoint exactly which build caused this issue.

#7 Updated by JMC4789 about 6 years ago

  • Status changed from New to Accepted
  • Regression set to Yes
  • Milestone set to Current

Okay, thank you guys for your work. Hopefully this won't be too hard to sort out. Please make sure you test out the latest builds in case it has already been fixed.

#8 Updated by ecalle.kevin about 6 years ago

With the same parameters (D3D and virtual XBF), the recents builds has aslo the problem.

see :http://i.imgur.com/TSwqzcw.jpg

#9 Updated by JMC4789 about 6 years ago

If it works with no XFB, and the RealXFB is what I think it is, then things should be fine soon.

Virtual XFB is really broken.

#10 Updated by JMC4789 almost 6 years ago

Is this fixed in latest master?

#11 Updated by JMC4789 almost 6 years ago

It isn't, I checked myself. It uses a weird way of doing interlacing, I think, and that's causing it to shake when XFB is off, and fail when it's on.

#12 Updated by JMC4789 almost 6 years ago

  • Milestone deleted (Current)

Real XFB startup crash was caused by the NVIDIA driver bugs. The game works with XFB off (but shakes) so I'm removing the milestone current.

#13 Updated by phire over 5 years ago

  • Regression changed from Yes to No

These issues are a side-effect of the game rendering interlaced frames.

It renders 1 feild at a time with an EFB resolution of 640x224, the viewport is offset by 1 line each field causing the shaking in no-xfb.

There is no code in dolphin to handle the rendering of interlaced XFBs, so realxfb and virtualxfb are broken.

The fact that this used to work is a complete fluke (or bug)

#14 Updated by alegend45 over 5 years ago

With No XFB, Budokai 1 has just a jitter. With Virtual XFB, there's a jitter, and the image is squashed vertically by a factor of 2. With Real XFB, there's a jitter and the two fields are displaced horizontally.

#15 Updated by alegend45 over 5 years ago

This is all with OpenGL, BTW.

#16 Updated by JMC4789 about 5 years ago

issue 7565 has been merged into this issue.

#17 Updated by phire about 4 years ago

#18 Updated by ecalle.kevin almost 4 years ago

Sorry for not respond a this subject, but the issue is solved with 4.0-7517 (from booto, VI: derive field timing from VI registers).
https://fr.dolphin-emu.org/download/dev/ecbb83fa0f6c63def7b0e7d17b6f7e8b47bcb724/?cr=fr

Budokai 1 and 2 have always the display which trembles, but it is another problem.

#19 Updated by JosJuice almost 4 years ago

  • Status changed from Accepted to Fixed
  • Regression changed from No to Yes
  • Regression start set to 4.0-1533
  • Fixed in set to 4.0-7517

Okay. Let's use issue 9617 for tracking the shaking.

#20 Updated by JosJuice almost 4 years ago

#21 Updated by phire almost 4 years ago

  • Status changed from Fixed to Accepted
  • Regression changed from Yes to No
  • Regression start deleted (4.0-1533)
  • Fixed in deleted (4.0-7517)

No. This is the correct issue. The screen shaking is caused by the fact that dolphin can't handle interlaced fields correctly at all.

It's just that dolphin's behaviour when it encounters these interlaced fields varies from commit to commit.

#22 Updated by phire almost 4 years ago

#23 Updated by JMC4789 almost 3 years ago

  • Status changed from Accepted to Duplicate

#24 Updated by JMC4789 almost 3 years ago

Also available in: Atom PDF