Project

General

Profile

Emulator Issues #7338

Beyond Good and Evil - Text is jumbled when using JIT core

Added by loganstromberg over 5 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Beyond Good and Evil

Game ID?
GGEE41

What's the problem? Describe what went wrong in few words.
All dynamic text in the game (that is, text that is rendered using a font bitmap and a texcoord atlas) is jumbled when using the JIT core, presumably because the texcoords are being improperly calculated. This causes all text to be unreadable.
Switching to JIT-IL core will solve the issue. I have not tried it with interpreter.

What did you expect to happen instead?
The text would be readable

What steps will reproduce the problem?
1. Start up the game and look at the main menu

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?

4.0.0: Text renders properly
4.0-1192: Text is jumbled
4.0-1761: Text is jumbled

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
4.0.0 works perfectly with both recompilers. I have not tried 4.0.2

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Win7 x64, AMD Phenom X4 3.15ghz, Geforce 9800GT

Are you using the 32 or the 64 bit version of Dolphin?
64 bit

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
JIT64IL DC core showing the proper output: http://i.imgur.com/P9HqJYw.jpg
JIT64 DC core exhibiting the issue: http://i.imgur.com/f0Sfwa8.jpg

History

#1 Updated by magumagu9 over 5 years ago

Thanks for the clear bug report.

If you have the time, could you track down exactly which revision broke it?

#2 Updated by loganstromberg over 5 years ago

I should also clarify: Changing the video backend doesn't fix the issue. Using Interpreter shows the correct output.

I traced the source of the regression to 4.0-971 "Fix Non-IEEE mode".

#3 Updated by loganstromberg over 5 years ago

The same build also broke collision detection pretty badly in a few places of BG&E. I haven't noticed it affecting many other games though. Should I file that as a separate bug?

#4 Updated by loganstromberg over 5 years ago

Looks like this isn't the only game that regressed due to 4.0-971:
https://code.google.com/p/dolphin-emu/issues/detail?id=7237

I have a Phenom X4 640 (no SSE3 support), if that matters.

#5 Updated by MayImilae over 5 years ago

Unable to reproduce in OGL or D3D.

Windows 7 x64
Core i5 3570K @ 4.7ghz
Nvidia GeForce GTX 760

#6 Updated by MayImilae over 5 years ago

Can you provide more CPU information please? You appear to be running a slight overclock or something, the only results I get searching for the CPU you described is... you, posting on the Dolphin forums. Furthermore, most phenoms are in the 800 range, the only ones in the 600 range I can find are athlons or mobile dual core chips. Considering this is likely an SSE related issue, we really need accurate CPU specs on your chip.

A screenshot from CPU-Z would be great.

#7 Updated by loganstromberg over 5 years ago

You're correct, it is a slight overclock. The stock speed is 3.0ghz.

CPU-Z: http://i.imgur.com/6ghsuPN.jpg

#8 Updated by MayImilae over 5 years ago

Name: Phenom X4
Specification: Athlon II X4 640

O_O

Curious. It has SSE3 and SSE4a, but no SSE4. Hmm...

#9 Updated by loganstromberg over 5 years ago

Verified fixed as of r2338. Thanks!

#10 Updated by JMC4789 over 5 years ago

  • Status changed from New to Fixed

Also available in: Atom PDF