Project

General

Profile

Emulator Issues #7360

Dolphin crashes after stopping emulation

Added by ms.techsupport about 6 years ago. Updated over 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
All

Game ID?
All

What's the problem? Describe what went wrong in few words.
Dolphin always crashes after stopping emulation. Emulation itself has no problems, however.

What did you expect to happen instead?
Expected: Dolphin to return to game selection.

What steps will reproduce the problem?

  1. Open Dolphin
  2. Start a game
  3. End emulation

Which versions of Dolphin did you test on?
4.0-1822

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
4.0.2 or any version that has Vertex Streaming Hack.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
OS: Windows 7 Ultimate x64
CPU: Intel Core i5 2500k
RAM: 8GB
GPU: Nvidia GeForce GTX 560 Ti 448, Drivers v337.88

Are you using the 32 or the 64 bit version of Dolphin?
64 bit

History

#1 Updated by ms.techsupport about 6 years ago

I forgot to mention: Dolphin does not crash on stop if D3D is selected as the graphics backend. This only happens in OpenGL.

#2 Updated by JMC4789 about 6 years ago

  • Status changed from New to Questionable

Using a NVIDIA GTX 760 on the same driver version, I am unable to reproduce your issue. Also on Windows 7 x64.

#3 Updated by ms.techsupport about 6 years ago

Could it be a 5xx-6xx series issue?

#4 Updated by JMC4789 about 6 years ago

6xx is related to 7xx, and 4xx is related to 5xx. I have both 4xx and 7xx cards. I do tend to have my ATI card crash on emulator close a lot, but not my NVIDIA cards.

#5 Updated by shadoxfix about 6 years ago

I'm using a HD7870 and can't reproduce this either.

#6 Updated by JMC4789 about 6 years ago

my HD5850 doesn't full support Direct X11, so it shouldn't be surprising that it sometimes crashes/generates pixelshader errors.

#7 Updated by badkarma12 about 6 years ago

It happens on my 660m, but only for gamecube games, specifically wind waker.

#8 Updated by loganstromberg about 6 years ago

Can't reproduce on 4.0-1761. Does it depend at all on how the emulation ends (i.e. pressing the "Stop" button, pressing Esc, closing the game window, etc.)?

Geforce 9800GT, Win7x64
Driver version 306.23

#9 Updated by ms.techsupport about 6 years ago

Doesn't depend. Stop, Esc & closing the game window yields the same result.

#10 Updated by TellowKrinkle about 6 years ago

I'm having this issue as well. I'm using a mac (15" 2012 MBP MD103LL/A, has an i7-3615qm and a 650m) running Mac OS X 10.9.3 (13D65).
I found that it started happening on version 3.5-1116 (it crashes on 3.5-1116 and above, not on 3.5-1108 and below).
Here's a link to my crash report: http://pastie.org/9348849

#11 Updated by lizzardfish007 over 5 years ago

Same problem with me too, with versions 4.0 - 3889, 4235, 2121, 2235, and 1857. It closes perfectly fine with Direct D3D with Intel graphics selected, but OpenGL almost always crashes when closed. Just as a note, I have an NVIDIA GT 750M, and I have selected the NVIDIA card to be the preferred graphics processor for Dolphin.

#12 Updated by skidau over 5 years ago

Crash on shutdown in single core mode, EFB2RAM, RealXFB disabled:

atio6axx.dll!00000000532b5309() Unknown

Dolphin.exe!OGL::FramebufferManager::~FramebufferManager() Line 331 C++
[External Code]
Dolphin.exe!OGL::Renderer::Shutdown() Line 674 C++
Dolphin.exe!OGL::VideoBackend::Video_Cleanup() Line 238 C++
Dolphin.exe!Core::EmuThread() Line 464 C++
[External Code]

https://github.com/dolphin-emu/dolphin/blob/master/Source/Core/VideoBackends/OGL/FramebufferManager.cpp#L331

FramebufferManager::~FramebufferManager()
{
glBindFramebuffer(GL_FRAMEBUFFER, 0);
GLuint glObj[3];
// Note: OpenGL deletion functions silently ignore parameters of "0".
glDeleteFramebuffers(m_EFBLayers, m_efbFramebuffer); <=== Line 331
glDeleteFramebuffers(m_EFBLayers, m_resolvedFramebuffer);
delete [] m_efbFramebuffer;
delete [] m_resolvedFramebuffer;
m_efbFramebuffer = nullptr;
m_resolvedFramebuffer = nullptr;

#13 Updated by skidau over 5 years ago

Game is F-Zero GX

#14 Updated by Helios over 2 years ago

  • Status changed from Questionable to Invalid

Cannot reproduce, closing

Also available in: Atom PDF