Project

General

Profile

Emulator Issues #7367

Setting gamecube controller rumble setting to either of the sawtooth modes and hitting test results in a divide by zero error. (Mayflash GC)

Added by badkarma12 about 6 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Game ID?

What's the problem? Describe what went wrong in few words.
Selecting the sawtooth modes in the rumble portion of the gamecube controller setup menu results in a program crash with an attempted divide by zero error.

What did you expect to happen instead?
Dolphin to not emulate the USS Yorktown. http://en.wikipedia.org/wiki/USS_Yorktown_(CG-48)#Smart_ship_testbed

What steps will reproduce the problem?
[Don't assume we have ever played the game and know any level names. Be as
specific as possible.]
1. Open gamecube controller setup.
2. Sect motors and select either sawtooth rumble mode.
3. Hit test.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
4.0-1841

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
I know that these functions used to work but I'm not sure when the last version they were functional was.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8.1 x64
Mayfair gamecube to usb adapter
I7 3632qm
16gb ram

Are you using the 32 or the 64 bit version of Dolphin?
64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
[Upload big files to a hosting service and post links here!]

-
[Do not attach files to this issue. Upload them to another site and
link here. Use imgur.com for images and pastie.org for logs.]

History

#1 Updated by JMC4789 about 6 years ago

It's probably a bug in the mayflash driver rather than Dolphin.

#2 Updated by JMC4789 about 6 years ago

  • Status changed from New to Accepted

But uh, thinking about it I don't think Dolphin should crash. I'll see if anyone else can come up with a better answer, I noticed this a long time ago and just thought it was a mayflash bug. The fact Dolphin crashes though is a problem.

#3 Updated by rachelbryk about 6 years ago

It works for me with a ps3 controller with motioninjoy drivers, so seconding mayflash bug.

#4 Updated by badkarma12 about 6 years ago

I Don't doubt it's the drive not playing nice, but windows log says that the may flash driver stayed running the whole time and never died.

#5 Updated by loganstromberg about 6 years ago

This reminds me, I use a Mayflash Dual Box Pro and the rumble feature would sometimes cause Dolphin crashes, mostly while fishing in Animal Crossing. I was always meaning to trace it through with the debugger; maybe there's some common root cause.

#6 Updated by Lioncash almost 6 years ago

Does this still occur in the lastest master?

#7 Updated by JMC4789 almost 6 years ago

Yes.

#8 Updated by JMC4789 almost 6 years ago

  • Status changed from Accepted to Invalid

Report this to Mayflash, it's not a bug in Dolphin according to multiple devs.

Also available in: Atom PDF