Project

General

Profile

Emulator Issues #7422

Deleting the uncompressed Wii ISO after compressing it within Dolphin doesn't work

Added by knuckles500 almost 6 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
I can confirm all Wii games are affected, I haven't tested Gamecube games.

Game ID?
See above.

What's the problem? Describe what went wrong in few words.
If you compress an ISO of a Wii game within Dolphin, the game list will refresh after the compression process is complete. When you go to delete the uncompressed ISO of the game you just compressed (using Dolphin's "Delete ISO..."), the game list will refresh but the uncompressed game image will still show up in the game list. The uncompressed ISO will also still exist in the user's directory.

However, if you reopen Dolphin and attempt to delete the uncompressed ISO that wouldn't delete before from within Dolphin, it will actually work.

While attempting to delete the uncompressed ISO you just compressed doesn't work, you can still remove any other file in the game list with "Delete ISO...".

What did you expect to happen instead?
Dolphin should remove any ISO when "Delete ISO..." is clicked, even after compressing an ISO image.

What steps will reproduce the problem?
1. Make sure you have at least 1 uncompressed Wii game.
2. In the game list, right click the uncompressed Wii game and click "Compress ISO...". After the compression is complete, exit out of the compression progress window and the game list will refresh.
3. In the game list, right click the uncompressed Wii game and click "Delete ISO...". After confirming, the game list will refresh. The uncompressed game that you tried to delete will still be in the list.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
Dolphin 4.0-1975 (bd377b9580c65ea6937b3cc7fc254d87683f360b)

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Dolphin 4.0.2
Dolphin 4.0-652 (c5b1ec3329d47006bfddb381f730ad4310528b00)

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
OS: Windows 7 Home Premium SP1
GFX Card: NVidia GeForce 680 GTX
CPU: Intel 2500k @ 3.3ghz
MB: Asrock z68 extreme 3 w/ latest BIOS

Are you using the 32 or the 64 bit version of Dolphin?
64 bit.

History

#1 Updated by kostamarino almost 6 years ago

It seems that dolphin uses the file and doesn't let it get deleted.

#2 Updated by Billiard26 almost 6 years ago

  • Status changed from New to Questionable

Cannot reproduce. Ensure you have permissions to delete the file?

#3 Updated by knuckles500 almost 6 years ago

I can't reproduce this either. I'm guessing I somehow had the file open somewhere else at the time and I didn't catch it. Sorry about that...

#4 Updated by JMC4789 almost 6 years ago

  • Status changed from Questionable to Invalid

No worries. It's good for users to be judicious.

Also available in: Atom PDF