Project

General

Profile

Emulator Issues #7480

[Regression] Japanese versions of Wii System Menu broken since 4.0-822

Added by mbc07 about 6 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Wii System Menu (any japanese version)

Game ID?
N/A

What's the problem? Describe what went wrong in few words.
Starting in 4.0-822, installing System Menu WAD of a japanese version (for example, v128 - 2.0J) and then booting System Menu will show only english text and an error page when accessing Settings menu

What did you expect to happen instead?
When booting from japanese Wii Menu, all text should be japanese (regardless of Wii language settings in Dolphin). Also, accessing Settings menu should work like the EUR and USA variants instead of showing error...

What steps will reproduce the problem?
(you must use Dolphin 4.0-822 or newer)
1. Grab a WAD from a japanese version of Wii Menu (either from update partition or from NUS Downloader)
2. Install it in Dolphin through Tools => Install WAD
3. Boot Wii Menu through Tools => Load System Menu
4. Emulation will start. Note the Health and Safety text that will be in english instead of japanese
5. Click the circular Wii button and go to Settings. You'll have an error page instead of the settings

Which versions of Dolphin did you test on?
Dolphin 4.0-2109 [x64]

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
Any version of Dolphin before 4.0-822 doesn't show that issue

What are your PC specifications?
CPU: Intel Core i7-3630QM @ 2.4GHz
GPU: nVidia GeForce GT 635M
RAM: 8 GB
OS: Windows 8.1 (Update 1) [x64]

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
* Screenshot of the error page: http://goo.gl/kLS6jt
* From what I tested, Pull Request 48 (https://github.com/dolphin-emu/dolphin/pull/48) caused the regression.
* Accordingly to WiiBrew, this error occur on real Wii if you, for example, install japanese version in a american Wii (soft brick). It may be related to Dolphin selecting the wrong 256-byte settings.txt file when booting Wii Menu.
* This may affect other japanese Wii softwares, but I don't own any to test...

History

#2 Updated by JMC4789 about 6 years ago

  • Regression set to Yes
  • Milestone set to Current

I'll test this later and confirm. Thank you for the report.

#3 Updated by parlane about 6 years ago

  • Status changed from New to Fixed

#4 Updated by NeoBrainX about 6 years ago

Would you be so kind and explain when and how this was fixed?

#5 Updated by parlane about 6 years ago

  • Status changed from Fixed to New

#6 Updated by parlane about 6 years ago

  • Status changed from New to Invalid

Update your VS compiler to Update 2. This is not a code bug.

#7 Updated by mbc07 about 6 years ago

It's an issue with the compiler then? Anyway, I'm using builds from official build bot and the issue still occur with the official builds...

#8 Updated by parlane about 6 years ago

Try the latest ?

#10 Updated by mbc07 about 6 years ago

Indeed, fixed. Do you know since which build the official build bot compiler got fixed? I'm doing several testings with different Wii Menu versions and stickied to official 4.0-2109 build during these tests until I noticed this issue...

#11 Updated by Anonymous about 6 years ago

I've just checked that build and confirmed the issue is fixed.

#12 Updated by parlane about 6 years ago

Since the one that says failed on this page:

https://buildbot.dolphin-emu.org/builders/release-win-x64

#13 Updated by mbc07 about 6 years ago

Since official 4.0-2139 build then. Thanks for the info

#14 Updated by NeoBrainX about 6 years ago

Thanks for making me owner of this issue for no reason.

#15 Updated by delroth about 6 years ago

I'm kind of curious how this is a compiler bug? Are you sure it's not an undefined behavior that's going to bite us in the ass again later on?

Since I haven't seen any details I'm assuming you're assuming it's a compiler issue because the compiler update fixes it. LMK if I'm wrong and you looked further into this.

If you haven't looked further, you should, otherwise this is not fixed.

Also available in: Atom PDF