Project

General

Profile

Emulator Issues #7497

007 Agent Under Fire - Desyncing in Vehicle Levels During TAS

Added by aleckermit76 over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
007: Agent Under Fire

Game ID?
GW7E69

What's the problem? Describe what went wrong in few words.
During TAS the vehicle levels (on-rail and driving) consistently desync. Loading a savestate multiple times can give you different results each time. The on-foot levels have never desynced on me.

What did you expect to happen instead?
Syncing.

What steps will reproduce the problem?
1. Start a TAS movie recording and play the 2nd level.
2. It will desync at some point.
3. Cry yourself to sleep.

Which versions of Dolphin did you test on?
4.0-2182, and multiple older versions (4.0 1xxx).

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
No.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
Windows 8 64-bit, Intel Core i3-3120M, integrated graphics.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
I've attached a .dtm that plays through level 1 very quickly to get you to level 2 where it desyncs.


Related issues

Is duplicate of Emulator - Emulator Issues #7219: 007 Agent Under Fire - Savestate Inaccuracies.Accepted

Has duplicate Emulator - Emulator Issues #8101: Innacurate Savestates in 007 Agent Under Fire's Vehicle LevelsDuplicate

History

#1 Updated by JMC4789 over 6 years ago

It doesn't desync when playing in netplay, so it's likely something not being saved to the savestate, at least, that's my best guess.

#2 Updated by aleckermit76 over 6 years ago

I forgot to mention you'll need version 1.0 of the game. If you can't find it try getting DOPE with your ROMS.

#3 Updated by JMC4789 over 6 years ago

  • Status changed from New to Accepted

It's likely a savestate issue. I wasn't able to reproduce due to not being a TASer, but, I've seen multiple people post this issue... I guess accepting?

#4 Updated by jesse_lun over 6 years ago

Since this wasn't posted here:
http://tasvideos.org/forum/viewtopic.php?p=393346#393346

This appears to happen on Spider man 2 as well.

Video of intended outcome
https://www.youtube.com/watch?v=M9bHuGRoDi0

Video of desyncd outcome
http://youtu.be/FQkyFlffjds

#5 Updated by JMC4789 over 6 years ago

These are both MMU titles, right? Could that be a key to what's happening? Should be noted that F-Zero GX is also an MMU title, and someone a long time ago reported savestates are breaking replays...

#6 Updated by JosJuice about 6 years ago

issue 8101 has been merged into this issue.

#7 Updated by aleckermit76 about 6 years ago

Is there any update on this issue? I've been waiting a long time for this to be fixed.

#8 Updated by aleckermit76 about 6 years ago

The issue still exists on the latest version of Dolphin (4.0-5110).

#9 Updated by JMC4789 about 6 years ago

issue 8101 has been merged into this issue.

#10 Updated by JMC4789 about 6 years ago

issue 8101 has been merged into this issue.

#11 Updated by jesse_lun about 6 years ago

Hey, it was noted that F Zero GX also desynced in the comments on this video

https://www.youtube.com/watch?v=QlHVEgGawGg

But this time the ingame replay seemed fine apparently.

#12 Updated by JMC4789 about 6 years ago

  • Status changed from Accepted to Duplicate

Also available in: Atom PDF