Project

General

Profile

Emulator Issues #7578

Dolphin stops working when streaming over NVIDIA SHIELD GameStream or Limelight

Added by danos0100 over 6 years ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
N/A (Dolphin-emu itself is the problem)

Game ID?
N/A

What's the problem? Describe what went wrong in few words.
Using a NVIDIA SHIELD Tablet, I am not anble to use NVIDIA GameStream with Dolphin. Once I start Dolphin (either over Steam or GameStream) it immediately stops working. If I start Dolphin first and then GameStream, Dolphin crashes, too. Also using the open-source implementation of GameStream, Limelight, leads to the same error. Furthermore, if I us Dolphin 3.5 or lower, there are no problems at startup, but once I go into any config, it also stops working. Only workaround at the moment is using 3.5 and going to config before streaming. This requires you to own another Xinput compatible controller besides the NVIDIA SHIELD portable or controller. (phew. That was a bit more than a /few/ words :D )

What did you expect to happen instead?
I expect Dolphin to behave like when not streaming.

What steps will reproduce the problem?
1. Add Dolphin as a non-steam-game in Steam or add it in NVIDIA GeForce Experience under Settings --> GameStream --> Click the '+' icon on the right and select the Dolphin .exe file.
2. Install Limelight on an Android Device (search for it in the Play Store) if you don't own an NVIDIA SHIELD or SHIELD Tablet and then connect to your computer by entering its IP (the computer must have an NVIDIA GeForce GTX 650 or higher)
3. If you added Dolphin to Steam as a non-steam-game, launch Steam from limelight, then in Steam go to Library --> Dolphin --> Start Game.
If you added Dolphin directly to GeForce Experience, launch Dolphin from Limelight.
4. Dolphin won't start, but therefore you get a message from Windows: "Dolphin stopped working".
If you are using Dolpin 3.5 or lower, ist will stop working when clicking on one of the option buttons, e.g. to set the controller bindings.

Dolphin 3.5 and 3.5-367 are old versions of Dolphin that have
known issues and bugs, so don't report issues about them and test the
latest Dolphin version first.
Which versions of Dolphin did you test on?
3.5 and 4.0-2628
both x64

Does using an older version of Dolphin solve your issue? If yes, which
versions of Dolphin used to work?
as stated above, 3.5 works better but still has problems.

What are your PC specifications? (including, but not limited to: Operating
System, CPU and GPU)
on an Intel i7 3820 pc
NVIDIA GeForce GTX 680
16 GB RAM
Windows 8.1 Pro x64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)
Seems to have worked with older versions of GeForce Experience, but I need the newest version to communicate with my SHIELD Tablet.

Thanks in advance :)

History

#1 Updated by MofoMan2000 over 6 years ago

I was having trouble streaming to Twitch using Open Broadcasting Software. Perhaps I was running into the same issue?

#2 Updated by darkrocket over 6 years ago

I think this issue has already been reported: https://code.google.com/p/dolphin-emu/issues/detail?id=7171

Also available in: Atom PDF